summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
Diffstat (limited to 'system')
-rw-r--r--system/pyinotify/README4
-rw-r--r--system/pyinotify/pyinotify.SlackBuild53
-rw-r--r--system/pyinotify/pyinotify.info10
-rw-r--r--system/pyinotify/slack-desc19
-rw-r--r--system/pyserial/README1
-rw-r--r--system/pyserial/pyserial.SlackBuild55
-rw-r--r--system/pyserial/pyserial.info10
-rw-r--r--system/pyserial/slack-desc19
8 files changed, 0 insertions, 171 deletions
diff --git a/system/pyinotify/README b/system/pyinotify/README
deleted file mode 100644
index 40c4baeba2..0000000000
--- a/system/pyinotify/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Pyinotify is a Python module for monitoring filesystems changes.
-Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
-called inotify. inotify is an event-driven notifier, its notifications
-are exported from kernel space to user space through three system calls.
diff --git a/system/pyinotify/pyinotify.SlackBuild b/system/pyinotify/pyinotify.SlackBuild
deleted file mode 100644
index 342ac21cb5..0000000000
--- a/system/pyinotify/pyinotify.SlackBuild
+++ /dev/null
@@ -1,53 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyinotify
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=pyinotify
-VERSION=${VERSION:-0.9.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ACKS ChangeLog_old COPYING NEWS_old $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/pyinotify/pyinotify.info b/system/pyinotify/pyinotify.info
deleted file mode 100644
index 2d2a78f4f7..0000000000
--- a/system/pyinotify/pyinotify.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyinotify"
-VERSION="0.9.0"
-HOMEPAGE="http://trac.dbzteam.org/pyinotify"
-DOWNLOAD="http://seb.dbzteam.org/pub/pyinotify/releases/pyinotify-0.9.0.tar.gz"
-MD5SUM="9822b3cfe1494e1a9e8bce70b1214db7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="rworkman"
diff --git a/system/pyinotify/slack-desc b/system/pyinotify/slack-desc
deleted file mode 100644
index aff3d5d100..0000000000
--- a/system/pyinotify/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyinotify: Pyinotify (python inotify module)
-pyinotify:
-pyinotify: Pyinotify is a Python module for monitoring filesystems changes.
-pyinotify: Pyinotify relies on a Linux Kernel feature (merged in kernel 2.6.13)
-pyinotify: called inotify. inotify is an event-driven notifier; its
-pyinotify: notifications are exported from kernel space to user space through
-pyinotify: three system calls.
-pyinotify:
-pyinotify: Homepage: http://pyinotify.sourceforge.net/
-pyinotify:
-pyinotify:
diff --git a/system/pyserial/README b/system/pyserial/README
deleted file mode 100644
index bc6ddf9364..0000000000
--- a/system/pyserial/README
+++ /dev/null
@@ -1 +0,0 @@
-pyserial is a python module that encapsulates access to a serial port.
diff --git a/system/pyserial/pyserial.SlackBuild b/system/pyserial/pyserial.SlackBuild
deleted file mode 100644
index 40ddd60fea..0000000000
--- a/system/pyserial/pyserial.SlackBuild
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pyserial
-
-# Written by Grissiom <chaos.proton@gmail.com>
-# Updated by Dustin Schnee <schnee72{at}gmail{dot}com>
-
-PRGNAM=pyserial
-VERSION=${VERSION:-2.5_rc2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRC_VERSION=$(printf $VERSION | tr _ -)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$SRC_VERSION
-tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
-cd $PRGNAM-$SRC_VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt LICENSE.txt README.txt PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/pyserial/pyserial.info b/system/pyserial/pyserial.info
deleted file mode 100644
index 5c22421b62..0000000000
--- a/system/pyserial/pyserial.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyserial"
-VERSION="2.5_rc2"
-HOMEPAGE="http://pyserial.sourceforge.net/index.html"
-DOWNLOAD="http://downloads.sourceforge.net/pyserial/pyserial-2.5-rc2.tar.gz"
-MD5SUM="feee06e28ff5337c010c5e326ec4efd3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Grissiom"
-EMAIL="chaos.proton@gmail.com"
-APPROVED="rworkman"
diff --git a/system/pyserial/slack-desc b/system/pyserial/slack-desc
deleted file mode 100644
index 95859372c1..0000000000
--- a/system/pyserial/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pyserial: pyserial (python module for accessing the serial port)
-pyserial:
-pyserial: This module encapsulates the access for the serial port. It provides
-pyserial: backends for Python running on Windows, Linux, BSD (possibly any POSIX
-pyserial: compliant system), Jython and IronPython (.NET and Mono).
-pyserial:
-pyserial: Homepage: http://pyserial.sourceforge.net
-pyserial:
-pyserial:
-pyserial:
-pyserial: