summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Vasilis Papavasileiou <el03020@mail.ntua.gr>2010-05-11 15:18:43 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 15:18:43 +0200
commit34a435d47fd8f1ea03b403ee05f47cb0a471975e (patch)
tree508525ebb9b692086131be9fce43e56086ec0c75
parentda67c8d8935dbd6f7919a73d107f6463c1b1a3b9 (diff)
downloadslackbuilds-34a435d47fd8f1ea03b403ee05f47cb0a471975e.tar.gz
slackbuilds-34a435d47fd8f1ea03b403ee05f47cb0a471975e.tar.xz
system/pygresql: Initial import
-rw-r--r--system/pygresql/README12
-rw-r--r--system/pygresql/pygresql.SlackBuild52
-rw-r--r--system/pygresql/pygresql.info8
-rw-r--r--system/pygresql/slack-desc11
4 files changed, 83 insertions, 0 deletions
diff --git a/system/pygresql/README b/system/pygresql/README
new file mode 100644
index 0000000000..ceff7c65e0
--- /dev/null
+++ b/system/pygresql/README
@@ -0,0 +1,12 @@
+PyGreSQL is a PostgreSQL access for Python.
+
+PyGreSQL is a Python module that interfaces to a PostgreSQL database. It
+embeds the PostgreSQL query library to allow easy use of the powerful
+PostgreSQL features from a Python script.
+
+PyGreSQL provides two different APIs, the "classic" interface provided by the
+pg module and the newer DB-API 2.0 compliant interface provided by the pgdb
+module.
+
+This SlackBuild requires that PostgreSQL is installed to build, and to be
+useful. A PostgreSQL SlackBuild is available from SlackBuilds.org.
diff --git a/system/pygresql/pygresql.SlackBuild b/system/pygresql/pygresql.SlackBuild
new file mode 100644
index 0000000000..d668606296
--- /dev/null
+++ b/system/pygresql/pygresql.SlackBuild
@@ -0,0 +1,52 @@
+#!/bin/sh
+
+# Slackware build script for pygresql
+# Written by Vasilis Papavasileiou <el03020 at mail dot ntua dot gr>
+
+set -e
+
+PRGNAM=pygresql
+ORIG_PRGNAM=PyGreSQL
+VERSION=3.8.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $ORIG_PRGNAM-$VERSION
+tar -xzvf $CWD/$ORIG_PRGNAM.tgz
+cd $ORIG_PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# there is a module in C
+CFLAGS="$SLKCFLAGS" \
+python setup.py build || exit 1
+python setup.py install --root $PKG || exit 1
+
+( cd $PKG
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir $PKG/usr/doc -p
+mv docs $PKG/usr/doc/$PRGNAM-$VERSION
+mv tutorial $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/pygresql/pygresql.info b/system/pygresql/pygresql.info
new file mode 100644
index 0000000000..d4d0da6a4f
--- /dev/null
+++ b/system/pygresql/pygresql.info
@@ -0,0 +1,8 @@
+PRGNAM="pygresql"
+VERSION="3.8.1"
+HOMEPAGE="http://www.pygresql.org"
+DOWNLOAD="ftp://ftp.pygresql.org/pub/distrib/PyGreSQL.tgz"
+MD5SUM="5575979dac93c9c5795d7693a8f91c86"
+MAINTAINER="Vasilis Papavasileiou"
+EMAIL="el03020@mail.ntua.gr"
+APPROVED="BP{k}"
diff --git a/system/pygresql/slack-desc b/system/pygresql/slack-desc
new file mode 100644
index 0000000000..7922c1d25c
--- /dev/null
+++ b/system/pygresql/slack-desc
@@ -0,0 +1,11 @@
+pygresql: pygresql (PostgreSQL access for Python)
+pygresql:
+pygresql: PyGreSQL is a Python module that interfaces to a PostgreSQL
+pygresql: database. It embeds the PostgreSQL query library to allow easy use
+pygresql: of the powerful PostgreSQL features from a Python script.
+pygresql:
+pygresql: Homepage: http://www.pygresql.org
+pygresql:
+pygresql:
+pygresql:
+pygresql: