summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Frank Caraballo <fecaraballo{at}gmail{dot}com>2010-05-12 17:42:08 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-12 17:42:08 +0200
commit2bd62a324d63c5169b8b9528f818ac6cef72a8cf (patch)
tree9b78872339f816e6f9310b18d08c0de79d75e679
parentba8f4565d00fe7cdc90c55d53cabdb2780b6c103 (diff)
downloadslackbuilds-2bd62a324d63c5169b8b9528f818ac6cef72a8cf.tar.gz
slackbuilds-2bd62a324d63c5169b8b9528f818ac6cef72a8cf.tar.xz
libraries/pyxdg: Updated for version 0.17
-rw-r--r--libraries/pyxdg/README3
-rw-r--r--libraries/pyxdg/pyxdg.SlackBuild13
-rw-r--r--libraries/pyxdg/pyxdg.info8
-rw-r--r--libraries/pyxdg/slack-desc12
4 files changed, 17 insertions, 19 deletions
diff --git a/libraries/pyxdg/README b/libraries/pyxdg/README
index acfab5dcef..485a238ba1 100644
--- a/libraries/pyxdg/README
+++ b/libraries/pyxdg/README
@@ -1,2 +1 @@
-PyXDG contains implementations of freedesktop.org
-standards in python.
+PyXDG contains implementations of freedesktop.org standards in python.
diff --git a/libraries/pyxdg/pyxdg.SlackBuild b/libraries/pyxdg/pyxdg.SlackBuild
index ae9adc7e8e..dd9dc57017 100644
--- a/libraries/pyxdg/pyxdg.SlackBuild
+++ b/libraries/pyxdg/pyxdg.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyxdg
-VERSION=0.15
+VERSION=${VERSION:-0.17}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -33,21 +33,20 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="AUTHORS ChangeLog COPYING PKG-INFO README TODO"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || exit 1
cd $PRGNAM-$VERSION || exit 1
-
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -66,9 +65,9 @@ python setup.py install --root $PKG || exit 1
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING INSTALL PKG-INFO README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/libraries/pyxdg/pyxdg.info b/libraries/pyxdg/pyxdg.info
index c853bf95cf..f494b221a5 100644
--- a/libraries/pyxdg/pyxdg.info
+++ b/libraries/pyxdg/pyxdg.info
@@ -1,8 +1,8 @@
PRGNAM="pyxdg"
-VERSION="0.15"
+VERSION="0.17"
HOMEPAGE="http://freedesktop.org/wiki/Software/pyxdg"
-DOWNLOAD="http://www.freedesktop.org/~lanius/pyxdg-0.15.tar.gz"
-MD5SUM="86a5441285fc908145414b63348d11a3"
+DOWNLOAD="http://www.freedesktop.org/~lanius/pyxdg-0.17.tar.gz"
+MD5SUM="a086de99cc536095684d87f15594e4db"
MAINTAINER="Frank Caraballo"
EMAIL="fecaraballo{at}gmail{dot}com"
-APPROVED="David Somero"
+APPROVED="Michiel" \ No newline at end of file
diff --git a/libraries/pyxdg/slack-desc b/libraries/pyxdg/slack-desc
index 7242731e60..0b61589cfd 100644
--- a/libraries/pyxdg/slack-desc
+++ b/libraries/pyxdg/slack-desc
@@ -1,15 +1,14 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
pyxdg: PyXDG (Python Library)
pyxdg:
-pyxdg: PyXDG contains implementations of freedesktop.org
-pyxdg: standards in python.
+pyxdg: PyXDG contains implementations of freedesktop.org standards in python.
pyxdg:
pyxdg: Homepage: http://freedesktop.org/wiki/Software/pyxdg
pyxdg:
@@ -17,3 +16,4 @@ pyxdg:
pyxdg:
pyxdg:
pyxdg:
+pyxdg: