summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mikko Varri <vmj@linuxbox.fi>2010-05-12 23:29:47 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 23:29:47 +0200
commit89f1daa6e515c2292d86f0d37109bc068812326c (patch)
tree6b432e3edaaea89cb0e07cd07ae46e51653be85f
parent4406fcfcb598d2776160bd37c58f81b70eb3c07f (diff)
downloadslackbuilds-89f1daa6e515c2292d86f0d37109bc068812326c.tar.gz
slackbuilds-89f1daa6e515c2292d86f0d37109bc068812326c.tar.xz
libraries/FormEncode: Added to 12.2 repository
-rw-r--r--libraries/FormEncode/FormEncode.SlackBuild44
-rw-r--r--libraries/FormEncode/FormEncode.info8
-rw-r--r--libraries/FormEncode/README10
-rw-r--r--libraries/FormEncode/slack-desc19
4 files changed, 81 insertions, 0 deletions
diff --git a/libraries/FormEncode/FormEncode.SlackBuild b/libraries/FormEncode/FormEncode.SlackBuild
new file mode 100644
index 0000000000..d680716aa0
--- /dev/null
+++ b/libraries/FormEncode/FormEncode.SlackBuild
@@ -0,0 +1,44 @@
+#!/bin/sh
+
+# Slackware build script for FormEncode
+
+# Written by Mikko Varri (vmj@linuxbox.fi)
+# Public domain
+
+PRGNAM=FormEncode
+VERSION=${VERSION:-1.2}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a docs/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/FormEncode/FormEncode.info b/libraries/FormEncode/FormEncode.info
new file mode 100644
index 0000000000..2d5f8052ed
--- /dev/null
+++ b/libraries/FormEncode/FormEncode.info
@@ -0,0 +1,8 @@
+PRGNAM="FormEncode"
+VERSION="1.2"
+HOMEPAGE="http://FormEncode.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/F/FormEncode/FormEncode-1.2.tar.gz"
+MD5SUM="da9d30ad0115ed8de86dc3b796899b41"
+MAINTAINER="Mikko Varri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="rworkman"
diff --git a/libraries/FormEncode/README b/libraries/FormEncode/README
new file mode 100644
index 0000000000..d029a4fbb0
--- /dev/null
+++ b/libraries/FormEncode/README
@@ -0,0 +1,10 @@
+FormEncode (HTML form validation, generation, and conversion package)
+
+FormEncode validates and converts nested structures. It allows for a
+declarative form of defining the validation, and decoupled processes
+for filling and generating forms.
+
+NOTE: To build this package, setuptools needs to be installed
+(available at SlackBuilds.org as "pysetuptools").
+
+NOTE: Running the test suite requires nose.
diff --git a/libraries/FormEncode/slack-desc b/libraries/FormEncode/slack-desc
new file mode 100644
index 0000000000..e120d46f11
--- /dev/null
+++ b/libraries/FormEncode/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+FormEncode: FormEncode (HTML form validation, generation, and conversion package)
+FormEncode:
+FormEncode: FormEncode validates and converts nested structures. It allows for a
+FormEncode: declarative form of defining the validation, and decoupled processes
+FormEncode: for filling and generating forms.
+FormEncode:
+FormEncode: http://FormEncode.org/
+FormEncode:
+FormEncode:
+FormEncode:
+FormEncode: