summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Lionel Young <redtricycle@gmail.com>2010-06-29 22:45:29 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-06-29 22:45:29 -0500
commit7174ecea5a0099cc50c78394de9ff367ae0c8d82 (patch)
treed5cd787315843006a75b6f14efaad53cdd010a7b
parentb8f1f705a1d2154fec53813315ca46bf50741abb (diff)
downloadslackbuilds-7174ecea5a0099cc50c78394de9ff367ae0c8d82.tar.gz
slackbuilds-7174ecea5a0099cc50c78394de9ff367ae0c8d82.tar.xz
libraries/Geraldo: Added (reports engine for Python / Django apps)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/Geraldo/Geraldo.SlackBuild71
-rw-r--r--libraries/Geraldo/Geraldo.info10
-rw-r--r--libraries/Geraldo/README5
-rw-r--r--libraries/Geraldo/slack-desc19
4 files changed, 105 insertions, 0 deletions
diff --git a/libraries/Geraldo/Geraldo.SlackBuild b/libraries/Geraldo/Geraldo.SlackBuild
new file mode 100644
index 0000000000..d66dd89cbf
--- /dev/null
+++ b/libraries/Geraldo/Geraldo.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009 Eric Hameleers <alien@slackware.com>, Eindhoven, Netherlands
+
+# Slackware build script for Geraldo
+# Written by Lionel Young <redtricycle@gmail.com>
+# Based on http://slackbuilds.org/template.SlackBuild
+
+PRGNAM=Geraldo
+VERSION=${VERSION:-0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION-final.tar.gz
+cd $PRGNAM-$VERSION-final
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES AUTHORS LICENSE README examples geraldo/tests \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/Geraldo/Geraldo.info b/libraries/Geraldo/Geraldo.info
new file mode 100644
index 0000000000..9b96d022f0
--- /dev/null
+++ b/libraries/Geraldo/Geraldo.info
@@ -0,0 +1,10 @@
+PRGNAM="Geraldo"
+VERSION="0.4"
+HOMEPAGE="http://www.geraldoreports.org/"
+DOWNLOAD="http://downloads.sourceforge.net/geraldo/Geraldo-0.4-final.tar.gz"
+MD5SUM="4d9dfcc82590bb210cccc5d6b4db7cb7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
+APPROVED="rworkman"
diff --git a/libraries/Geraldo/README b/libraries/Geraldo/README
new file mode 100644
index 0000000000..21c21d3d7e
--- /dev/null
+++ b/libraries/Geraldo/README
@@ -0,0 +1,5 @@
+Geraldo is a reports engine for Python or Django applications. It uses the
+power of ReportLab to generate reports with page header and footer, child
+bands, report begin and summary bands, agreggation and graphic elements, etc.
+
+This requires reportlab.
diff --git a/libraries/Geraldo/slack-desc b/libraries/Geraldo/slack-desc
new file mode 100644
index 0000000000..c52e1c87df
--- /dev/null
+++ b/libraries/Geraldo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+Geraldo: Geraldo (Python Reports Engine)
+Geraldo:
+Geraldo: Geraldo is a reports engine for Python or Django applications.
+Geraldo:
+Geraldo: It uses the power of ReportLab to generate reports with page header
+Geraldo: and footer, child bands, report begin and summary bands, agreggation
+Geraldo: and graphic elements, etc.
+Geraldo:
+Geraldo: Home: http://www.geraldoreports.org/
+Geraldo:
+Geraldo: