summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Niels Horn <niels.horn@gmail.com>2010-05-13 01:01:11 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-13 01:01:11 +0200
commitdf1a04d3ffbc96fa7049fdf80f677c0ba3688669 (patch)
tree515d4904d1867424984bc9c99901819c1c5e06ca
parent6684de1a477a46179cc66772d9ebe20540d31165 (diff)
downloadslackbuilds-df1a04d3ffbc96fa7049fdf80f677c0ba3688669.tar.gz
slackbuilds-df1a04d3ffbc96fa7049fdf80f677c0ba3688669.tar.xz
system/statifier: Added to 13.0 repository
-rw-r--r--system/statifier/64pure.patch11
-rw-r--r--system/statifier/README3
-rw-r--r--system/statifier/slack-desc19
-rw-r--r--system/statifier/statifier.SlackBuild79
-rw-r--r--system/statifier/statifier.info10
5 files changed, 122 insertions, 0 deletions
diff --git a/system/statifier/64pure.patch b/system/statifier/64pure.patch
new file mode 100644
index 0000000000..606cb2ccfb
--- /dev/null
+++ b/system/statifier/64pure.patch
@@ -0,0 +1,11 @@
+--- statifier-1.6.15/configs/config.x86_64 2005-02-16 09:06:35.000000000 -0200
++++ statifier-1.6.15_patched/configs/config.x86_64 2009-12-25 23:42:05.000000000 -0200
+@@ -9,7 +9,7 @@
+
+ # ELF32
+ # Have elf32 ?
+- ELF32 := yes
++ ELF32 := no
+ # Special flags to compile elf32
+ FLAGS_32 := -m32
+ # Flags to compile C to asm elf32 (mostly to be sure calling convention)
diff --git a/system/statifier/README b/system/statifier/README
new file mode 100644
index 0000000000..c9c7e17210
--- /dev/null
+++ b/system/statifier/README
@@ -0,0 +1,3 @@
+Statifier combines a dynamically linked executable with its libraries into
+one large file. The result can be easier to distribute and may make a
+32-bits binary work on 64-bits.
diff --git a/system/statifier/slack-desc b/system/statifier/slack-desc
new file mode 100644
index 0000000000..4aefec3b83
--- /dev/null
+++ b/system/statifier/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+statifier: Statifier (Transform dynamic executables into static files)
+statifier:
+statifier: Statifier combines a dynamically linked executable with its libraries
+statifier: into one large file. The result can be easier to distribute and may
+statifier: make a 32-bits binary work on 64-bits.
+statifier:
+statifier: http://statifier.sourceforge.net/
+statifier:
+statifier:
+statifier:
+statifier:
diff --git a/system/statifier/statifier.SlackBuild b/system/statifier/statifier.SlackBuild
new file mode 100644
index 0000000000..60655314ef
--- /dev/null
+++ b/system/statifier/statifier.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/sh
+
+# Slackware build script for statifier
+
+# Written by Niels Horn <niels.horn@gmail.com>
+# revision date: 2009/12/26
+
+PRGNAM=statifier
+VERSION=${VERSION:-1.6.15}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# We need to patch config.x86_64 because Slackware64 is not multi-lib and we
+# only have the 32-bits libraries
+patch -p1 < $CWD/64pure.patch
+
+# "usr/lib/" is hardcoded in the Makefile...
+sed -i "s,usr/lib/,usr/lib${LIBDIRSUFFIX}/," src/Makefile
+# And in the startup script...
+sed -i "s,usr/lib/,usr/lib${LIBDIRSUFFIX}/," src/statifier
+
+# The "configure" script is run by "make" and we really should not mess with
+# the CFLAGS & options
+# Make *needs* to be run with "-j1" or strange things may happen...
+MAKEFLAGS="" make -j1
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS ChangeLog FAQ INSTALL LICENSE NEWS README RELEASE THANKS \
+ TODO VERSION doc $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/statifier/statifier.info b/system/statifier/statifier.info
new file mode 100644
index 0000000000..6ff5c25074
--- /dev/null
+++ b/system/statifier/statifier.info
@@ -0,0 +1,10 @@
+PRGNAM="statifier"
+VERSION="1.6.15"
+HOMEPAGE="http://statifier.sourceforge.net/"
+DOWNLOAD="http://sourceforge.net/projects/statifier/files/statifier/1.6.15/statifier-1.6.15.tar.gz/download"
+MD5SUM="624bf5d2096ef495bd9d8f5b8963b23b"
+DOWNLOAD_x86_64="UNSUPPORTED"
+MD5SUM_x86_64="UNSUPPORTED"
+MAINTAINER="Niels Horn"
+EMAIL="niels.horn@gmail.com"
+APPROVED="rworkman"