summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2010-04-09 10:47:27 -0500
committer Robby Workman <rworkman@slackbuilds.org>2010-05-15 10:25:59 +0200
commit1e6de1892bf750cd32a95cc0284cd05792d2413c (patch)
treefe22e9190ee51015f3255cc32d05d4039d011a19
parentce650dfee78b81935ffa20d737425d91cdb494ea (diff)
downloadslackbuilds-1e6de1892bf750cd32a95cc0284cd05792d2413c.tar.gz
slackbuilds-1e6de1892bf750cd32a95cc0284cd05792d2413c.tar.xz
libraries/argparse: Added (optparse sub for python)
-rw-r--r--libraries/argparse/README11
-rwxr-xr-xlibraries/argparse/argparse.SlackBuild75
-rw-r--r--libraries/argparse/argparse.info10
-rw-r--r--libraries/argparse/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/libraries/argparse/README b/libraries/argparse/README
new file mode 100644
index 0000000000..d084cfa857
--- /dev/null
+++ b/libraries/argparse/README
@@ -0,0 +1,11 @@
+The argparse python module provides an easy declarative interface for
+creating command line tools. Argparse knows how to parse the arguments
+and flags from sys.argv, convert arg strings into objects for your program,
+format and print informative help messages, and much more...
+
+The argparse module improves on the standard library optparse module in
+a number of ways including handling positional arguments, support for
+sub-commands, allowing alternative option prefixes like + and /,
+handling zero-or-more and one-or-more style arguments, producing more
+informative usage messages, and providing a much simpler interface for
+custom types and actions.
diff --git a/libraries/argparse/argparse.SlackBuild b/libraries/argparse/argparse.SlackBuild
new file mode 100755
index 0000000000..cdec671c3a
--- /dev/null
+++ b/libraries/argparse/argparse.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for argparse.
+
+# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=argparse
+VERSION=${VERSION:-1.1}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" \
+ -e "current ar archive" | grep ELF | cut -f 1 -d : | xargs \
+ strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/argparse/argparse.info b/libraries/argparse/argparse.info
new file mode 100644
index 0000000000..692980ed8a
--- /dev/null
+++ b/libraries/argparse/argparse.info
@@ -0,0 +1,10 @@
+PRGNAM="argparse"
+VERSION="1.1"
+HOMEPAGE="http://code.google.com/p/argparse/"
+DOWNLOAD="http://argparse.googlecode.com/files/argparse-1.1.zip"
+MD5SUM="e62565cde81a8deb61f90dcb5e8861a4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="rworkman"
diff --git a/libraries/argparse/slack-desc b/libraries/argparse/slack-desc
new file mode 100644
index 0000000000..908018abd2
--- /dev/null
+++ b/libraries/argparse/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+argparse: argparse (Python command line parsing)
+argparse:
+argparse: The argparse module provides an easy, declarative interface for
+argparse: creating command line tools.
+argparse:
+argparse: http://code.google.com/p/argparse/
+argparse:
+argparse:
+argparse:
+argparse:
+argparse: