summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author dsomero <xgizzmo@gmail.com>2010-05-27 04:23:00 -0400
committer David Somero <xgizzmo@slackbuilds.org>2010-05-27 12:10:05 +0200
commitc7a67cd9b5cb2594f842088136493100cc469169 (patch)
tree85e1aafe669234fdb66b96efcded1b0ad85b265f
parentc10192dc58346f9e98d92a06b7b2b96ccf160f3f (diff)
downloadslackbuilds-c7a67cd9b5cb2594f842088136493100cc469169.tar.gz
slackbuilds-c7a67cd9b5cb2594f842088136493100cc469169.tar.xz
desktop/wally: Removed (Build failure)
-rw-r--r--desktop/wally/README5
-rw-r--r--desktop/wally/doinst.sh10
-rw-r--r--desktop/wally/slack-desc19
-rw-r--r--desktop/wally/wally-2.3.0-disable_popup.patch9
-rw-r--r--desktop/wally/wally.SlackBuild71
-rw-r--r--desktop/wally/wally.info10
6 files changed, 0 insertions, 124 deletions
diff --git a/desktop/wally/README b/desktop/wally/README
deleted file mode 100644
index abdbabecb1..0000000000
--- a/desktop/wally/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Wally is a Qt4 wallpaper changer, using multiple sources like files, folders,
-FTP remote folders, Flickr, Yahoo!, Panoramio, Pikeo, Ipernity, Photobucket,
-Buzznet, Picasa, Smugmug and Bing images. Now it's available in many languages!!
-
-Note: For xfce users read README.XFCE4 to activate wally.
diff --git a/desktop/wally/doinst.sh b/desktop/wally/doinst.sh
deleted file mode 100644
index 13524a5ae1..0000000000
--- a/desktop/wally/doinst.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache usr/share/icons/oxygen >/dev/null 2>&1
- fi
-fi
-
diff --git a/desktop/wally/slack-desc b/desktop/wally/slack-desc
deleted file mode 100644
index 0268fee774..0000000000
--- a/desktop/wally/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-wally: wally
-wally:
-wally: Wally is a Qt4 wallpaper changer, using multiple sources like files,
-wally: folders, FTP remote folders, Flickr, Yahoo!, Panoramio, Pikeo,
-wally: Ipernity, Photobucket, Buzznet, Picasa, Smugmug and Bing images. Now
-wally: it's available in many languages!!
-wally:
-wally: Homepage: http://www.becrux.com/index.php?page=projects&name=wally
-wally:
-wally:
-wally:
diff --git a/desktop/wally/wally-2.3.0-disable_popup.patch b/desktop/wally/wally-2.3.0-disable_popup.patch
deleted file mode 100644
index 6c1ad0e2b7..0000000000
--- a/desktop/wally/wally-2.3.0-disable_popup.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -Naur wally-2.3.0.orig/wallyplugin/CMakeLists.txt wally-2.3.0/wallyplugin/CMakeLists.txt
---- wally-2.3.0.orig/wallyplugin/CMakeLists.txt 2009-10-21 06:59:24.000000000 +0000
-+++ wally-2.3.0/wallyplugin/CMakeLists.txt 2009-11-14 07:17:20.000000000 +0000
-@@ -27,5 +27,3 @@
- install(FILES plasma-wallpaper-wallyplugin.desktop DESTINATION ${SERVICES_INSTALL_DIR})
- install(FILES wallyplugin.png DESTINATION ${ICON_INSTALL_DIR}/oxygen/16x16/apps)
-
--install(CODE "execute_process(COMMAND kbuildsycoca4 OUTPUT_QUIET ERROR_QUIET)")
--install(CODE "execute_process(COMMAND kdialog --title \"WallyPlugin\" --msgbox \"WallyPlugin will be loaded next time KDE is started. Please select it in Appearance Settings.\")")
diff --git a/desktop/wally/wally.SlackBuild b/desktop/wally/wally.SlackBuild
deleted file mode 100644
index 1ecd97bb30..0000000000
--- a/desktop/wally/wally.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for wally
-
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
-
-PRGNAM=wally
-VERSION=${VERSION:-2.3.2}
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch -p1 < $CWD/wally-2.3.0-disable_popup.patch
-
-cd build
- cmake -G "Unix Makefiles" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_BUILD_TYPE=Release ..
-
- make VERBOSE=1
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog DISCLAIMER LICENSE README* TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/wally/wally.info b/desktop/wally/wally.info
deleted file mode 100644
index eb1206518f..0000000000
--- a/desktop/wally/wally.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="wally"
-VERSION="2.3.2"
-HOMEPAGE="http://www.becrux.com/index.php?page=projects&name=wally"
-DOWNLOAD="http://www.becrux.com/pages/projects/wally/wally-2.3.2.tar.gz"
-MD5SUM="78b3381b44e2669327e88a6718ddaa23"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="Erik Hanson"