summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2010-06-14 02:08:45 -0500
committer Erik Hanson <erik@slackbuilds.org>2010-06-14 02:08:45 -0500
commit8386c632165f2c6a39d941652681da27e4919ea4 (patch)
tree0c3d425bbcd3e82878b1d56160fd23cffd86163b
parent7d19ca799549b44e08b6f545066f0763daab5126 (diff)
downloadslackbuilds-8386c632165f2c6a39d941652681da27e4919ea4.tar.gz
slackbuilds-8386c632165f2c6a39d941652681da27e4919ea4.tar.xz
games/fceux: Updated for version 2.1.4a.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--games/fceux/Nintendo.pngbin0 -> 29286 bytes
-rw-r--r--games/fceux/README2
-rw-r--r--games/fceux/enable-recording.patch12
-rw-r--r--games/fceux/fceux.SlackBuild45
-rw-r--r--games/fceux/fceux.desktop10
-rw-r--r--games/fceux/fceux.info9
6 files changed, 48 insertions, 30 deletions
diff --git a/games/fceux/Nintendo.png b/games/fceux/Nintendo.png
new file mode 100644
index 0000000000..b7bb4202f7
--- /dev/null
+++ b/games/fceux/Nintendo.png
Binary files differ
diff --git a/games/fceux/README b/games/fceux/README
index 1b2d1785b3..4cb9534b61 100644
--- a/games/fceux/README
+++ b/games/fceux/README
@@ -5,4 +5,4 @@ Famicom Disk System (FDS) emulator. It supports both PAL
(European) and NTSC (USA/JPN) modes. It supports both Windows
and SDL versions for cross compatibility.
-This requires scons and zenity.
+This package requires scons (available at SBo)
diff --git a/games/fceux/enable-recording.patch b/games/fceux/enable-recording.patch
new file mode 100644
index 0000000000..9f27f5fbef
--- /dev/null
+++ b/games/fceux/enable-recording.patch
@@ -0,0 +1,12 @@
+diff -up fceu2.1.4a/SConstruct.00 fceu2.1.4a/SConstruct
+--- fceu2.1.4a/SConstruct.00 2010-06-05 20:53:37.621706694 -0700
++++ fceu2.1.4a/SConstruct 2010-06-05 20:53:51.370717520 -0700
+@@ -10,7 +10,7 @@ opts.AddVariables(
+ BoolVariable('DEBUG', 'Build with debugging symbols', 1),
+ BoolVariable('LUA', 'Enable Lua support', 1),
+ BoolVariable('NEWPPU', 'Enable new PPU core', 1),
+- BoolVariable('CREATE_AVI', 'Enable avi creation support (SDL only)', 0),
++ BoolVariable('CREATE_AVI', 'Enable avi creation support (SDL only)', 1),
+ BoolVariable('LOGO', 'Enable a logoscreen when creating avis (SDL only)', '1'),
+ BoolVariable('GTK', 'Enable GTK2 GUI (SDL only)', 1),
+ BoolVariable('GTK_LITE', 'Enable GTK2 for dialogs only', 0)
diff --git a/games/fceux/fceux.SlackBuild b/games/fceux/fceux.SlackBuild
index d2236f743d..2b57bf1031 100644
--- a/games/fceux/fceux.SlackBuild
+++ b/games/fceux/fceux.SlackBuild
@@ -5,16 +5,14 @@
# Written by M.Dinslage (daedra1980@gmail.com)
PRGNAM=fceux
-VERSION=${VERSION:-2.1.3}
-BUILD=${BUILD:-4}
+VERSION=${VERSION:-2.1.4a}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -38,14 +36,15 @@ else
LIBDIRSUFFIX=""
fi
-set -e
+set -e # Exit on most errors
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.src.tar.bz2
-cd fceu
+cd fceu$VERSION
+patch -p1 < $CWD/enable-recording.patch
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -54,34 +53,32 @@ find . \
-exec chmod 644 {} \;
scons
+
+#Dont use scons install, we'll take care of install ourselves
mkdir -p $PKG/usr/bin
install -m 0755 bin/fceux $PKG/usr/bin
+
+#install man pages
mkdir -p $PKG/usr/man/man6
install -m 0644 documentation/fceux.6 $PKG/usr/man/man6
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/fceux
-cp -a \
- bin/fceux.chm COPYING INSTALL NEWS README-SDL TODO-PROJECT \
- $PKG/usr/doc/$PRGNAM-$VERSION/fceux
-
-# Build gfceux
-cd $TMP/gfceux
-python setup.py install --prefix=$PKG/usr
-mkdir -p $PKG/usr/man/man1
-mv $PKG/usr/share/man/man1/gfceux.1 $PKG/usr/man/man1
-gzip -9 $PKG/usr/man/man?/*
-rm -rf $PKG/usr/share/man
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/gfceux
-cp ChangeLog COPYING INSTALL TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION/gfceux
-
-# This is supposed to work with gtk+2-2.14.x as well...
-sed -i "s%2.16%2.14%" $PKG/usr/share/gfceux/gfceux.glade
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ bin/fceux.chm COPYING INSTALL NEWS README-SDL TODO-PROJECT \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+#Add icon and application launcher
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+cat $CWD/Nintendo.png > $PKG/usr/share/pixmaps/Nintendo.png
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/games/fceux/fceux.desktop b/games/fceux/fceux.desktop
new file mode 100644
index 0000000000..660c385b14
--- /dev/null
+++ b/games/fceux/fceux.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Fceux
+GenericName=Nintendo/Famicon Emulator
+Exec=fceux
+Terminal=false
+Type=Application
+Categories=Application;Game;Emulator;
+Icon=/usr/share/pixmaps/Nintendo.png
+StartupNotify=false
diff --git a/games/fceux/fceux.info b/games/fceux/fceux.info
index 2a0e1ca131..eb04f72bd5 100644
--- a/games/fceux/fceux.info
+++ b/games/fceux/fceux.info
@@ -1,11 +1,10 @@
PRGNAM="fceux"
-VERSION="2.1.3"
+VERSION="2.1.4a"
HOMEPAGE="http://fceux.com/web/home.html"
-DOWNLOAD="http://downloads.sourceforge.net/project/fceultra/Source%20Code/2.1.3%20src/fceux-2.1.3.src.tar.bz2"
-MD5SUM="2943e3be634b4c1c1f5114e03c681af4"
+DOWNLOAD="http://downloads.sourceforge.net/fceultra/fceux-2.1.4a.src.tar.bz2"
+MD5SUM="a1252a888cdc8b2c42ae031211f2fad6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="M.Dinslage"
EMAIL="daedra1980@gmail.com"
-APPROVED="dsomero"
-
+APPROVED="Erik Hanson"