summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Pierre Cazenave <pwcazenave at gmail {dot} com>2010-07-30 02:25:12 -0500
committer Erik Hanson <erik@slackbuilds.org>2010-07-31 22:31:51 -0500
commit21958ef7ba7e8961f2fa26c4d93b34f9b5810074 (patch)
tree1e3030368b892d92af929cd4c5c9626ab9f8381e
parentdd30c9a90adcaf8b59ce0ddb6a14d255d3f00ad1 (diff)
downloadslackbuilds-21958ef7ba7e8961f2fa26c4d93b34f9b5810074.tar.gz
slackbuilds-21958ef7ba7e8961f2fa26c4d93b34f9b5810074.tar.xz
libraries/iulib: Added (image understanding library)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--libraries/iulib/README7
-rw-r--r--libraries/iulib/iulib-0.3-install.patch39
-rw-r--r--libraries/iulib/iulib.SlackBuild95
-rw-r--r--libraries/iulib/iulib.info10
-rw-r--r--libraries/iulib/slack-desc19
5 files changed, 170 insertions, 0 deletions
diff --git a/libraries/iulib/README b/libraries/iulib/README
new file mode 100644
index 0000000000..26af136cb4
--- /dev/null
+++ b/libraries/iulib/README
@@ -0,0 +1,7 @@
+Iulib is a library of image understanding-related algorithms. It provides
+basic image processing, mathematical morphology, and machine learning
+algorithms. Iulib implements easy-to-use image and video I/O functions, as
+well as a large number of common image processing functions.
+
+Design goals are high portability, easy-to-understand algorithms, no reliance
+on STL, and using a minimal set of data structures.
diff --git a/libraries/iulib/iulib-0.3-install.patch b/libraries/iulib/iulib-0.3-install.patch
new file mode 100644
index 0000000000..76be8707b0
--- /dev/null
+++ b/libraries/iulib/iulib-0.3-install.patch
@@ -0,0 +1,39 @@
+
+--- Makefile.in
++++ Makefile.in
+@@ -43,7 +43,7 @@ POST_UNINSTALL = :
+ @have_vidio_TRUE@am__append_4 = $(srcdir)/vidio/vidio.h
+ @have_v4l2_TRUE@am__append_5 = $(srcdir)/vidio/v4l2cap.cc
+ subdir = .
+-DIST_COMMON = $(am__configure_deps) $(am__include_HEADERS_DIST) \
++DIST_COMMON = README $(am__configure_deps) $(am__include_HEADERS_DIST) \
+ $(colib_HEADERS) $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
+ $(top_srcdir)/configure COPYING INSTALL TODO depcomp \
+ install-sh missing
+@@ -997,6 +997,7 @@ installdirs:
+ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(colibdir)" "$(DESTDIR)$(includedir)"; do \
+ test -z "$$dir" || $(mkdir_p) "$$dir"; \
+ done
++install: install-am
+ install-exec: install-exec-am
+ install-data: install-data-am
+ uninstall: uninstall-am
+@@ -1088,18 +1089,6 @@ uninstall-am: uninstall-colibHEADERS uninstall-includeHEADERS \
+ uninstall-am uninstall-colibHEADERS uninstall-includeHEADERS \
+ uninstall-info-am uninstall-libLIBRARIES
+
+-
+-# make installation of colib a separate target
+-
+-install-colib:
+- install -d $(colibdir)
+- install $(colib_HEADERS) $(colibdir)
+-
+-install: all install-colib
+- install -d $(includedir)
+- install -d $(libdir)
+- install $(include_HEADERS) $(includedir)
+- install $(lib_LIBRARIES) $(libdir)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/libraries/iulib/iulib.SlackBuild b/libraries/iulib/iulib.SlackBuild
new file mode 100644
index 0000000000..9de6f3b4be
--- /dev/null
+++ b/libraries/iulib/iulib.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for iulib.
+
+# Copyright 2010 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=iulib
+VERSION=0.3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM
+chown -R root:root .
+chmod -R a-s,u+w,go+r-w .
+
+# add a gentoo patch to fix the Makefile so DESTDIR works
+patch -p0 < $CWD/iulib-0.3-install.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libdir=/usr/lib${LIBDIRSUFFIX}
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES COPYING DIRS INSTALL README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/iulib/iulib.info b/libraries/iulib/iulib.info
new file mode 100644
index 0000000000..e8c07b379f
--- /dev/null
+++ b/libraries/iulib/iulib.info
@@ -0,0 +1,10 @@
+PRGNAM="iulib"
+VERSION="0.3"
+HOMEPAGE="http://code.google.com/p/iulib/"
+DOWNLOAD="http://iulib.googlecode.com/files/iulib-0.3.tar.gz"
+MD5SUM="eb98f97d5b93fae6ff1e416922a4f389"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Pierre Cazenave"
+EMAIL="pwcazenave < at > gmail {dot} com"
+APPROVED="rworkman"
diff --git a/libraries/iulib/slack-desc b/libraries/iulib/slack-desc
new file mode 100644
index 0000000000..c03d121777
--- /dev/null
+++ b/libraries/iulib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-----------------------------------------------------|
+iulib: Iulib (image understanding library)
+iulib:
+iulib: Iulib is a library of image understanding-related algorithms.
+iulib: It provides basic image processing, mathematical morphology,
+iulib: and machine learning algorithms. Iulib implements easy-to-use
+iulib: image and video I/O functions, as well as a large number of
+iulib: common image processing functions.
+iulib:
+iulib: http://code.google.com/p/iulib/
+iulib:
+iulib: