summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja[at]gmail[dot]com>2010-08-03 02:50:00 -0500
committer Erik Hanson <erik@slackbuilds.org>2010-08-11 01:53:01 -0500
commitb88b095f6039f404171cf6d73dd68c5fe59b4f25 (patch)
treeed098992ef7f56bbacacb752f631ffb4a85abc12
parent08a3217f62195c9ece60b7600545510d3b561543 (diff)
downloadslackbuilds-b88b095f6039f404171cf6d73dd68c5fe59b4f25.tar.gz
slackbuilds-b88b095f6039f404171cf6d73dd68c5fe59b4f25.tar.xz
games/assaultcube: Miscellaneous cleanups.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--games/assaultcube/README9
-rw-r--r--games/assaultcube/assaultcube.SlackBuild29
-rw-r--r--games/assaultcube/assaultcube.desktop7
-rw-r--r--games/assaultcube/assaultcube.info8
-rw-r--r--games/assaultcube/doinst.sh6
5 files changed, 32 insertions, 27 deletions
diff --git a/games/assaultcube/README b/games/assaultcube/README
index 218b4debbf..e45916b721 100644
--- a/games/assaultcube/README
+++ b/games/assaultcube/README
@@ -1,6 +1,5 @@
-formerly ActionCube, is a free first-person-shooter
-based on the game Cube. Set in a realistic looking
-environment, as far as thatīs possible with this
-engine, while gameplay stays fast and arcade.
+AssaultCube (formerly ActionCube) is a free first-person-shooter based on
+the game Cube. Set in a realistic looking environment, as far as that's
+possible with this engine, while gameplay stays fast and arcade.
-Requires OpenAL.
+This requires OpenAL.
diff --git a/games/assaultcube/assaultcube.SlackBuild b/games/assaultcube/assaultcube.SlackBuild
index 778eb97be1..9444fd2ff4 100644
--- a/games/assaultcube/assaultcube.SlackBuild
+++ b/games/assaultcube/assaultcube.SlackBuild
@@ -6,16 +6,14 @@
SRCNAM=AssaultCube
PRGNAM=assaultcube
-VERSION=${VERSION:-1.0.4}
-BUILD=${BUILD:-1}
+VERSION=1.0.4
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -31,6 +29,8 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
fi
set -e
@@ -38,10 +38,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf ${SRCNAM}_v1.0.2
-tar xvf $CWD/${SRCNAM}_v1.0.2.tar.bz2
-cd ${SRCNAM}_v1.0.2
-tar xvf $CWD/${SRCNAM}_v${VERSION}-Update.tar.bz2
+rm -rf ${SRCNAM}_v${VERSION}
+tar xvf $CWD/${SRCNAM}_v${VERSION}.tar.bz2
+cd ${SRCNAM}_v${VERSION}
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -52,9 +51,10 @@ find . \
# We need to change the order of the enet libs and includes. Enet libs and include
# directories need to be declared first as compile will fail if enet is already
# installed on the system and the Makefile uses system files instead. Also, use
-# custom SLKCFLAGS.
+# custom SLKCFLAGS and remove precompiled binaries.
patch -p1 < $CWD/Makefile.patch
sed -i "s|-O2|$SLKCFLAGS|" source/enet/configure
+rm -f bin_unix/*
CXXOPTFLAGS="$SLKCFLAGS -fomit-frame-pointer" \
make -C source/src
@@ -72,14 +72,17 @@ cp -ar \
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/share/{applications,pixmaps}
+mkdir -p $PKG/usr/share/applications
install -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications
-convert icon.ico $PRGNAM.png
-install -m 0644 $PRGNAM-0.png $PKG/usr/share/pixmaps/$PRGNAM.png
+for i in 16 32 64 96 128; do
+ convert icon.ico -resize ${i}x${i}! $PRGNAM-$i.png
+ install -D -m 0644 $PRGNAM-$i-0.png \
+ $PKG/usr/share/icons/hicolor/${i}x${i}/apps/$PRGNAM.png
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- source/*.txt source/src/*.txt docs \
+ source/*.txt source/src/*.txt docs README.html \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/games/assaultcube/assaultcube.desktop b/games/assaultcube/assaultcube.desktop
index 7029fcbe28..11ef79431c 100644
--- a/games/assaultcube/assaultcube.desktop
+++ b/games/assaultcube/assaultcube.desktop
@@ -1,12 +1,11 @@
[Desktop Entry]
-Encoding=UTF-8
-Exec=/usr/games/assaultcube
+Exec=assaultcube
Icon=assaultcube
Type=Application
+X-MultipleArgs=false
Terminal=false
-MultipleArgs=false
Name=AssaultCube
GenericName=Realistic Multiplayer FPS
-MimeType=text/html
+MimeType=text/html;
StartupNotify=false
Categories=Game;ActionGame;
diff --git a/games/assaultcube/assaultcube.info b/games/assaultcube/assaultcube.info
index 1e94b0fe9a..87fa9eb0c3 100644
--- a/games/assaultcube/assaultcube.info
+++ b/games/assaultcube/assaultcube.info
@@ -1,12 +1,10 @@
PRGNAM="assaultcube"
VERSION="1.0.4"
HOMEPAGE="http://assault.cubers.net/"
-DOWNLOAD="http://downloads.sourceforge.net/actiongame/AssaultCube_v1.0.2.tar.bz2
- http://downloads.sourceforge.net/sourceforge/actiongame/AssaultCube_v1.0.4-Update.tar.bz2"
-MD5SUM="e083182699e65c240d8c7fa051644e6f
- d907a279879fed8c21cd3ba83ce984bf"
+DOWNLOAD="http://downloads.sourceforge.net/actiongame/AssaultCube_v1.0.4.tar.bz2"
+MD5SUM="310dfc4c225329cdf1333e08a35ff175"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
-APPROVED="dsomero"
+APPROVED="rworkman"
diff --git a/games/assaultcube/doinst.sh b/games/assaultcube/doinst.sh
index 4e8ba7071d..1f8ff67ded 100644
--- a/games/assaultcube/doinst.sh
+++ b/games/assaultcube/doinst.sh
@@ -2,3 +2,9 @@ if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+