summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Petar Petrov <ppetrov@paju.oulu.fi>2013-07-06 01:22:06 -0500
committer Niels Horn <niels.horn@slackbuilds.org>2013-07-07 09:11:53 -0300
commitd2c42f9118a01a2164bdf11c406986b7f3a95811 (patch)
tree76c38cab353550d6fa978227bc51d954200b8e22
parent86c1caa9147a66993a4e61eea6166582d766a968 (diff)
downloadslackbuilds-d2c42f9118a01a2164bdf11c406986b7f3a95811.tar.gz
slackbuilds-d2c42f9118a01a2164bdf11c406986b7f3a95811.tar.xz
academic/jalview: Added (A Sequence Alignment Editor and Viewer)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--academic/jalview/README16
-rw-r--r--academic/jalview/References28
-rw-r--r--academic/jalview/doinst.sh3
-rw-r--r--academic/jalview/jalview16
-rw-r--r--academic/jalview/jalview.SlackBuild81
-rw-r--r--academic/jalview/jalview.desktop8
-rw-r--r--academic/jalview/jalview.info12
-rw-r--r--academic/jalview/jalview.pngbin0 -> 2471 bytes
-rw-r--r--academic/jalview/slack-desc19
9 files changed, 183 insertions, 0 deletions
diff --git a/academic/jalview/README b/academic/jalview/README
new file mode 100644
index 0000000000..abb473680a
--- /dev/null
+++ b/academic/jalview/README
@@ -0,0 +1,16 @@
+Jalview - A Sequence Alignment Editor and Viewer
+
+Jalview is a free program developed for the interactive editing,
+analysis and visualization of multiple sequence alignments (MSA). It
+can also work with sequence annotation, secondary structure
+information, phylogenetic trees and 3D molecular structures.
+
+If you use Jalview 2 in your work, please cite:
+Waterhouse AM, Procter JB, Martin DMA, Clamp M, Barton GJ (2009)
+Jalview Version 2-a multiple sequence alignment editor and analysis
+workbench. Bioinformatics 25: 1189-1191.
+
+NOTE:
+The silly requirement of p7zip is just for extracting the program's
+contents at build time. You do not need it in order to use Jalview
+later on, but it's a nice tool to have anyways... ;)
diff --git a/academic/jalview/References b/academic/jalview/References
new file mode 100644
index 0000000000..bb4030f270
--- /dev/null
+++ b/academic/jalview/References
@@ -0,0 +1,28 @@
+Peer reviewed publications
+
+If you use Jalview 2 in your work, please cite Waterhouse et al.
+(2009).
+To cite an analysis performed with JABAWS, please use Troshin et al.
+(2011).
+
+Troshin PV, Procter JB, Barton GJ (2011) Java bioinformatics analysis
+web services for multiple sequence alignment--JABAWS:MSA.
+Bioinformatics 27: 2001-2002.
+http://bioinformatics.oxfordjournals.org/content/27/14/2001
+
+Waterhouse AM, Procter JB, Martin DMA, Clamp M, Barton GJ (2009)
+Jalview Version 2-a multiple sequence alignment editor and analysis
+workbench. Bioinformatics 25: 1189-1191.
+http://bioinformatics.oxfordjournals.org/content/25/9/1189
+
+Thompson JD, Muller A, Waterhouse A, Procter J, Barton GJ, et al.
+(2006) MACSIMS: multiple alignment of complete sequences information
+management system. BMC Bioinformatics 7: 318.
+http://www.biomedcentral.com/1471-2105/7/318
+
+Clamp M, Cuff J, Searle SM, Barton GJ (2004) The Jalview Java
+alignment editor. Bioinformatics 20: 426-427.
+http://bioinformatics.oxfordjournals.org/content/20/3/426
+
+Take a look at the citations for the Jalview 2 paper in PubMedCentral:
+http://www.ncbi.nlm.nih.gov/pubmed?linkname=pubmed_pubmed_citedin&from_uid=19151095
diff --git a/academic/jalview/doinst.sh b/academic/jalview/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/academic/jalview/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/academic/jalview/jalview b/academic/jalview/jalview
new file mode 100644
index 0000000000..31813c2c2a
--- /dev/null
+++ b/academic/jalview/jalview
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# This wrapper script is taken from Arch Linux AUR entry of jalview.
+# https://aur.archlinux.org/packages/jalview/
+# Maintainer of the PKGBUILD is Stefan Seemayer.
+
+progname="jalview"
+mainclass="jalview.bin.Jalview"
+basedir="/usr/share/java/$progname"
+
+# build classpath: all jars in $basedir
+cp=$( ls $basedir/*.jar | xargs echo | sed "s/ /:/g" );
+
+
+# run jar
+"$JAVA_HOME/bin/java" -cp $cp $mainclass
diff --git a/academic/jalview/jalview.SlackBuild b/academic/jalview/jalview.SlackBuild
new file mode 100644
index 0000000000..101b9b7bf3
--- /dev/null
+++ b/academic/jalview/jalview.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/sh
+
+# Slackware build script for jalview
+
+# Copyright 2013 Petar Petrov, ppetrov@paju.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# With help from the jalview PKGBUILD at Arch linux AUR:
+# https://aur.archlinux.org/packages/jalview/
+
+PRGNAM=jalview
+VERSION=${VERSION:-2.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=install.bin
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+7z e $CWD/$SRCNAM
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+mkdir -p $PKG/usr/share/java/$PRGNAM
+cp -a *.jar $PKG/usr/share/java/$PRGNAM
+
+# The wrapper is from Arch. Thank you!
+install -D -m755 $CWD/$PRGNAM $PKG/usr/bin/$PRGNAM
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ building.html exampleFeatures.txt LICENSE README_IA \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/TheJalviewTutorial_screen.pdf > $PKG/usr/doc/$PRGNAM-$VERSION/Tutorial.pdf
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# Menu item and icon
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/jalview/jalview.desktop b/academic/jalview/jalview.desktop
new file mode 100644
index 0000000000..bfc8d516f5
--- /dev/null
+++ b/academic/jalview/jalview.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Jalview
+Comment=A Sequence Alignment Editor and Viewer
+Exec=jalview
+Icon=jalview
+StartupNotify=false
+Type=Application
+Categories=Education;
diff --git a/academic/jalview/jalview.info b/academic/jalview/jalview.info
new file mode 100644
index 0000000000..29b7a3356c
--- /dev/null
+++ b/academic/jalview/jalview.info
@@ -0,0 +1,12 @@
+PRGNAM="jalview"
+VERSION="2.8"
+HOMEPAGE="http://www.jalview.org/"
+DOWNLOAD="http://www.jalview.org/Web_Installers/InstData/Linux/NoVM/install.bin \
+ http://www.jalview.org/tutorial/TheJalviewTutorial_screen.pdf"
+MD5SUM="8efc117dc7947b24577b319ffdadb024 \
+ e08a446029df593d2e2722c5f273ce6c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jdk p7zip"
+MAINTAINER="Petar Petrov"
+EMAIL="ppetrov@paju.oulu.fi"
diff --git a/academic/jalview/jalview.png b/academic/jalview/jalview.png
new file mode 100644
index 0000000000..56dcdcaf99
--- /dev/null
+++ b/academic/jalview/jalview.png
Binary files differ
diff --git a/academic/jalview/slack-desc b/academic/jalview/slack-desc
new file mode 100644
index 0000000000..3d6bb1f727
--- /dev/null
+++ b/academic/jalview/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jalview: jalview (A Sequence Alignment Editor and Viewer)
+jalview:
+jalview: Jalview is a free program developed for the interactive editing,
+jalview: analysis and visualization of multiple sequence alignments (MSA).
+jalview: It can also work with sequence annotation, secondary structure
+jalview: information, phylogenetic trees and 3D molecular structures.
+jalview:
+jalview: Home: http://www.jalview.org/
+jalview: References: /usr/doc/jalview-$VERSION/References
+jalview:
+jalview: