summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2016-01-28 10:34:47 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-01-29 07:16:33 +0700
commit25359453930f3f464aa3a89d689747c96e1c409f (patch)
tree7be2483e614a8333684b71dc6340001cef0d400e
parent98953d997269a470dde1eedde5a70d502da78e12 (diff)
downloadslackbuilds-25359453930f3f464aa3a89d689747c96e1c409f.tar.gz
slackbuilds-25359453930f3f464aa3a89d689747c96e1c409f.tar.xz
games/pcsx2: Removed.
(I don't want to maintain this) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--games/pcsx2/README6
-rw-r--r--games/pcsx2/doinst.sh3
-rw-r--r--games/pcsx2/pcsx2.SlackBuild104
-rw-r--r--games/pcsx2/pcsx2.info10
-rw-r--r--games/pcsx2/slack-desc19
5 files changed, 0 insertions, 142 deletions
diff --git a/games/pcsx2/README b/games/pcsx2/README
deleted file mode 100644
index 05ac7d7db5..0000000000
--- a/games/pcsx2/README
+++ /dev/null
@@ -1,6 +0,0 @@
-PCSX2 is a PlayStation 2 emulator for Windows and Linux, started by
-the same team that brought you PCSX (a Sony PlayStation 1 emulator).
-
-wxPython, portaudio and soundtouch are optional dependencies.
-
-NOTE: This is buildable only on x86 32bit platform.
diff --git a/games/pcsx2/doinst.sh b/games/pcsx2/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/games/pcsx2/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/games/pcsx2/pcsx2.SlackBuild b/games/pcsx2/pcsx2.SlackBuild
deleted file mode 100644
index 6027c22f1f..0000000000
--- a/games/pcsx2/pcsx2.SlackBuild
+++ /dev/null
@@ -1,104 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pcsx2
-# Copyright 2014 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pcsx2
-VERSION=${VERSION:-r5913}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i686 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=core2"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="pcsx2/Docs/*.txt pcsx2/Docs/*.doc"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Set our locations
-sed -i \
- -e "s|share/doc/pcsx2|doc/${PRGNAM}-${VERSION}|" \
- -e "s|share/man|man|" \
- CMakeLists.txt
-
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DPLUGIN_DIR=/usr/lib/$PRGNAM \
- -DPACKAGE_MODE=ON \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/pcsx2/pcsx2.info b/games/pcsx2/pcsx2.info
deleted file mode 100644
index d37b6065f0..0000000000
--- a/games/pcsx2/pcsx2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pcsx2"
-VERSION="r5913"
-HOMEPAGE="http://pcsx2.net"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/pcsx2-r5913.tar.xz"
-MD5SUM="51a81cc75f171d3c369dd590de2c1aae"
-DOWNLOAD_x86_64="UNSUPPORTED"
-MD5SUM_x86_64=""
-REQUIRES="wxPython nvidia-cg-toolkit portaudio soundtouch sparsehash"
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/games/pcsx2/slack-desc b/games/pcsx2/slack-desc
deleted file mode 100644
index 7511c9bbd2..0000000000
--- a/games/pcsx2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pcsx2: pcsx2 (Playstation 2 emulator)
-pcsx2:
-pcsx2: PCSX2 is a PlayStation 2 emulator for Windows and Linux, started by
-pcsx2: the same team that brought you PCSX (a Sony PlayStation 1 emulator).
-pcsx2:
-pcsx2: homepage: http://pcsx2.net
-pcsx2:
-pcsx2:
-pcsx2:
-pcsx2:
-pcsx2: