summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author wigums <pioneer22675@gmail.com>2018-08-10 22:52:50 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2018-08-11 07:23:11 +0700
commit332d7ff41f73d4e725cbb3f0022811a8c30355ee (patch)
tree424f3238050f0d35aeb3d5ea256ae27f012b0499
parent6c23eea23a2025e85eef9b1c74e8872e16c7d12d (diff)
downloadslackbuilds-332d7ff41f73d4e725cbb3f0022811a8c30355ee.tar.gz
slackbuilds-332d7ff41f73d4e725cbb3f0022811a8c30355ee.tar.xz
network/netdiscover: Added (network address discovering tool).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--network/netdiscover/README3
-rw-r--r--network/netdiscover/netdiscover.SlackBuild96
-rw-r--r--network/netdiscover/netdiscover.info10
-rw-r--r--network/netdiscover/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/network/netdiscover/README b/network/netdiscover/README
new file mode 100644
index 0000000000..1f3c41ba6f
--- /dev/null
+++ b/network/netdiscover/README
@@ -0,0 +1,3 @@
+Netdiscover is a network address discovering tool, developed mainly for those
+wireless networks without dhcp server, it also works on hub/switched networks.
+It is based on arp packets, it will send arp requests and sniff for replys.
diff --git a/network/netdiscover/netdiscover.SlackBuild b/network/netdiscover/netdiscover.SlackBuild
new file mode 100644
index 0000000000..a9cbccaaf5
--- /dev/null
+++ b/network/netdiscover/netdiscover.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/sh
+
+# Slackware build script for netdiscover
+
+
+# DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+# Version 2, December 2004
+
+# Copyright (C) 2004 Sam Hocevar <sam@hocevar.net>
+
+# Everyone is permitted to copy and distribute verbatim or modified
+# copies of this license document, and changing it is allowed as long
+# as the name is changed.
+
+# DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
+# TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+# 0. You just DO WHAT THE FUCK YOU WANT TO.
+
+
+PRGNAM=netdiscover
+VERSION=${VERSION:-886319a}
+COMMIT=${COMMIT:-886319af1758a1cb9cc1ec904ea46646572797c9}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's:share/man:man:' CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/netdiscover/netdiscover.info b/network/netdiscover/netdiscover.info
new file mode 100644
index 0000000000..c48e710ce2
--- /dev/null
+++ b/network/netdiscover/netdiscover.info
@@ -0,0 +1,10 @@
+PRGNAM="netdiscover"
+VERSION="886319a"
+HOMEPAGE="https://github.com/alexxy/netdiscover/"
+DOWNLOAD="https://github.com/alexxy/netdiscover/archive/886319a/netdiscover-886319af1758a1cb9cc1ec904ea46646572797c9.tar.gz"
+MD5SUM="ae7f940fd699ccce7c0167f215a7e217"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="wigums"
+EMAIL="pioneer22675@gmail.com"
diff --git a/network/netdiscover/slack-desc b/network/netdiscover/slack-desc
new file mode 100644
index 0000000000..430f930226
--- /dev/null
+++ b/network/netdiscover/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+netdiscover: netdiscover (network address discovering tool)
+netdiscover:
+netdiscover: Netdiscover is a network address discovering tool, developed mainly
+netdiscover: for those wireless networks without dhcp server, it also works on
+netdiscover: hub/switched networks.
+netdiscover:
+netdiscover:
+netdiscover:
+netdiscover:
+netdiscover:
+netdiscover: