summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2016-11-20 19:48:32 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-11-26 11:47:24 +0700
commit344a0bc5f5e7b2264b6a583a7a57f36542a633f8 (patch)
tree929f00e53961054c9741d452cc3c1451696e05bc
parenta287692c1ba829a06b6f026d0d2879f454233d5a (diff)
downloadslackbuilds-344a0bc5f5e7b2264b6a583a7a57f36542a633f8.tar.gz
slackbuilds-344a0bc5f5e7b2264b6a583a7a57f36542a633f8.tar.xz
desktop/numix-icon-theme-square: Added (Numix Square icon theme).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--desktop/numix-icon-theme-square/README3
-rw-r--r--desktop/numix-icon-theme-square/doinst.sh13
-rw-r--r--desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild61
-rw-r--r--desktop/numix-icon-theme-square/numix-icon-theme-square.info10
-rw-r--r--desktop/numix-icon-theme-square/slack-desc19
5 files changed, 106 insertions, 0 deletions
diff --git a/desktop/numix-icon-theme-square/README b/desktop/numix-icon-theme-square/README
new file mode 100644
index 0000000000..f5f36a4983
--- /dev/null
+++ b/desktop/numix-icon-theme-square/README
@@ -0,0 +1,3 @@
+numix-icon-theme-square (Numix Square icon theme)
+
+Numix Square is an icon theme for Linux from the Numix project.
diff --git a/desktop/numix-icon-theme-square/doinst.sh b/desktop/numix-icon-theme-square/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/desktop/numix-icon-theme-square/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild b/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
new file mode 100644
index 0000000000..1969fff842
--- /dev/null
+++ b/desktop/numix-icon-theme-square/numix-icon-theme-square.SlackBuild
@@ -0,0 +1,61 @@
+#!/bin/sh
+#
+# Slackware build script for numix-icon-theme-square.
+#
+# Copyright 2016 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM="numix-icon-theme-square"
+VERSION=${VERSION:-1.0.1.6.201611180631}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+CWD=$(pwd)
+
+set -e
+
+SRCVER="1.0.1+6~201611180631~ubuntu16.10.1"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRCVER
+tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.xz
+cd $PRGNAM-$SRCVER
+chown -R root:root .
+
+mkdir -p $PKG/usr/share/icons
+cp -ar Numix-Square Numix-Square-Light $PKG/usr/share/icons
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/numix-icon-theme-square/numix-icon-theme-square.info b/desktop/numix-icon-theme-square/numix-icon-theme-square.info
new file mode 100644
index 0000000000..0bf95a8750
--- /dev/null
+++ b/desktop/numix-icon-theme-square/numix-icon-theme-square.info
@@ -0,0 +1,10 @@
+PRGNAM="numix-icon-theme-square"
+VERSION="1.0.1.6.201611180631"
+HOMEPAGE="https://github.com/numixproject/numix-icon-theme-square"
+DOWNLOAD="https://launchpad.net/~numix/+archive/ubuntu/ppa/+files/numix-icon-theme-square_1.0.1+6~201611180631~ubuntu16.10.1.tar.xz"
+MD5SUM="938a207bccdaa271218f75743dd26066"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="numix-icon-theme"
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/desktop/numix-icon-theme-square/slack-desc b/desktop/numix-icon-theme-square/slack-desc
new file mode 100644
index 0000000000..5d45e68983
--- /dev/null
+++ b/desktop/numix-icon-theme-square/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+numix-icon-theme-square: numix-icon-theme-square (Numix Square icon theme)
+numix-icon-theme-square:
+numix-icon-theme-square: Numix Square is an icon theme for Linux from the Numix project.
+numix-icon-theme-square:
+numix-icon-theme-square: Home Page: https://github.com/numixproject/numix-icon-theme-square/
+numix-icon-theme-square:
+numix-icon-theme-square:
+numix-icon-theme-square:
+numix-icon-theme-square:
+numix-icon-theme-square:
+numix-icon-theme-square: