summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Michales Michaloudes <korgie@gmail.com>2011-07-10 23:09:13 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2011-07-14 21:54:03 -0300
commit3d64300970c3eb83d34fbe2e84e363b5d1e31bb1 (patch)
tree85cf0ffaf4dd55ee9a293f428447f43d7f612a78
parent180f01556f5f1bb0acda588ffd86223502766442 (diff)
downloadslackbuilds-3d64300970c3eb83d34fbe2e84e363b5d1e31bb1.tar.gz
slackbuilds-3d64300970c3eb83d34fbe2e84e363b5d1e31bb1.tar.xz
audio/aeolus: Added (pipe organ emulator)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--audio/aeolus/README10
-rw-r--r--audio/aeolus/aeolus.SlackBuild74
-rw-r--r--audio/aeolus/aeolus.info10
-rw-r--r--audio/aeolus/aeolus_64.xpm75
-rw-r--r--audio/aeolus/slack-desc19
5 files changed, 188 insertions, 0 deletions
diff --git a/audio/aeolus/README b/audio/aeolus/README
new file mode 100644
index 0000000000..bb65185ed5
--- /dev/null
+++ b/audio/aeolus/README
@@ -0,0 +1,10 @@
+Aeolus is a synthesised (i.e. not sampled) pipe organ emulator that
+should be good enough to make an organist enjoy playing it. It is a
+software synthesiser optimised for this job, with possibly hundreds of
+controls for each stop, that enable the user to "voice" his instrument.
+First presented at the 2nd LAD conference in Karlsruhe, end of April
+2004.
+
+Requires: clthreads, clxclient, clalsadrv, jack-audio-connection-kit,
+stops
+
diff --git a/audio/aeolus/aeolus.SlackBuild b/audio/aeolus/aeolus.SlackBuild
new file mode 100644
index 0000000000..b6cf383f75
--- /dev/null
+++ b/audio/aeolus/aeolus.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/sh
+# Slackware build script for <aeolus>
+# Written by Michales Michaloudes korgie@gmail.com
+
+PRGNAM=aeolus
+VERSION=${VERSION:-0.8.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i -e 's+/usr/local+/usr+' -e '/ldconfig/d' $TMP/$PRGNAM-$VERSION/source/Makefile
+cd $TMP/$PRGNAM-$VERSION/source/
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+cd $TMP/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING INSTALL \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/aeolus/aeolus.info b/audio/aeolus/aeolus.info
new file mode 100644
index 0000000000..ba730c9060
--- /dev/null
+++ b/audio/aeolus/aeolus.info
@@ -0,0 +1,10 @@
+PRGNAM="aeolus"
+VERSION="0.8.4"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/aeolus/index.html"
+DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/aeolus-0.8.4.tar.bz2"
+MD5SUM="0dcbfb2ab386419f306e1d947815163a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Michales Michaloudes"
+EMAIL="korgie@gmail.com"
+APPROVED="dsomero"
diff --git a/audio/aeolus/aeolus_64.xpm b/audio/aeolus/aeolus_64.xpm
new file mode 100644
index 0000000000..457f31b464
--- /dev/null
+++ b/audio/aeolus/aeolus_64.xpm
@@ -0,0 +1,75 @@
+/* XPM */
+static char * aeolus_64_xpm[] = {
+"64 64 8 1",
+" c #272744",
+". c #3D3522",
+"+ c #4B4838",
+"@ c #4A4A5F",
+"# c #59595B",
+"$ c #666865",
+"% c #6F707F",
+"& c #9A9BA1",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$@@@@@@@@@@#@@@@@@@@@@@@@@@@@@@@#@@@@@@@@@@@@@@@@@@@@#",
+"$&&&&$$$$$$@%%%%%%%& #@%%&%&%%@@@ %%%%%% # @%%%&%% @ %&%%%&&% #",
+"$&&&$$$$$$$@ @@@@@ # @ @@@ @@ @@@@ @ # @@@ @@ @ @ @ #",
+"$$$$$$$$$$$@ @@ # @@ @@ @@@@ % # @@ @@ @ #",
+"$$$$$$$$$$$@ @@ # @@ @@ @%%%@% # @@ @@ @@ #",
+"$$$$#######@@@##################################################",
+"$$$#@ #+++..+.+++$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ @@@@ #$++$+$$+$+$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ %%%% #$$$&$$$$$+$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ #+..+...+.+$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$#@@@@@@@@@#++++++++++$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$########$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$@@@@@@@@ @#@# @@@@@@@@ @ @@#@@@@ @@@@@@@@@ @ @#",
+"$&&$$$$$$$$@%&&&%&&& #@&&%&&&&%@@ %%&&%% # &&&&&% @@@&&&%%&& #",
+"$&&$$$$$$$$@ # @@ # @@ #",
+"$$$$$$$$$$$@ @% # &%%%@% @@ %%%%@% # %@%% @@ @ #",
+"$$$$$$$$$$$@ # @@@@@@ @@ @@@@@@ # @@@@ @@ @ #",
+"$$$$$#####$##########$##########################################",
+"$$$$@ #+........++.........#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ @@@ @@ #$++++++++++..$++$+..#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ &&&&%&@ +$$&&&&&&&++.+&$&&+..#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ #+........++.........#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$@ #++++++++++#.........#$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$####@##@#@#@%##@###@##@###@#@@@#@@###@#@@##@@###@#@@#",
+"$&$$$$$$$$$@@%@@@%@% # %@%@%%%@ @ @%%@@@ # %%@@@@ @@ %%%@@ #",
+"$&$$$$$$$$$@ @@@@%@% # @@@@@%%@@@ @@%@@ # @@@@@@ @@ @%@@@ #",
+"$$$$$$$$$$$@ @@ # @@ @@ @ # @@ @@@% #",
+"$$$$$$$$$$$@ @@ # @@ @@ @ # @ @@ @@@@ #",
+"$$$$#######@@@@@@@@@@#@@@@@@@@@@@@@@@@@@@@#@@@#@##@###@#####@@##",
+"$$$#@ @%%%@@ @@ @@@%%@% @@ @@@ @+.......++#+......",
+"$$$$@ %@@@ @ @@%%%%@ @ @@@@@ @ @@@@@ @ +..++++...+..+.#$+",
+"$$$$@ @ @ @@@ @ %%%%%@ @ @@%%%%% +..+$$$...+..$$$$$",
+"$$$$@ @@ @ @@% @ @ +.........+.......",
+"$$$$@ @ @@ @@ @@ @@ @#........+#+......",
+"$$$$$########$$$########$$########$$$########$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$#@@@@@@@@@#@#@@@@@@@##@@@@@@@@@#@#@@@@@@@##@@@@@@@@@#",
+"$&&$$$$$$$$@ %%%%@%@ # &@%@%%%@@ %%%@%%@% # &@%@%%%@ @ @%%@@@ #",
+"$&$$$$$$$$$@ @@@@%%@ # @@@%%%%@@@ @@%@%%% # @@@%%%%@@@ @@@%@@ #",
+"$$$$$$$$$$$@ @@ # @@ @@ @ # @@ @ #",
+"$$$$$$$$$$$@ @& # %% @@ @@ # @@ @@ @ #",
+"$$$$#######@ @@@ @@@@#@@@@ @@@@@@@@@@@@@@#@@@@@@@@@##@@@@@@@@@#",
+"$$$#@@@@@@@@@@@%@@@%@@%@@# @#++++++++++#+++++++++#+++++++",
+"$$$#@@%%%%%%%@@%%%%%%@%@ @ @ @@ @ #...+++....+..++++...+..+++++",
+"$$$$@ @@ @@ @@@ @ %%%%%%@ #...&$$....+..$$$$...+..$$$$$",
+"$$$$@ @@ @ %@ @ @@@ #.....+....+....++...+.....++",
+"$$$$@ @@@ @@@ @@@ @@ #+.+...++++#........+#+..+...",
+"$$$$##########################################$#########$#######",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$##$$$$$$$$###$$$$$$$##$$$$$$$$$",
+"$$&$&&$$$$$$$$$&$&$$$$$$$$$$$###$&$$######$$&$###$##$&&$###$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$##############################$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$#######$$$$$####$#$$#######$$$$$$$",
+"$$&&&&$$$$$$$$$&$&$$$$$$$$$$$###$$$$######$$$$###$##&&$$###$$$$$",
+"$$$$$$$$$$$$$$$$$$#$$$$$$$$$$##############################$$$$$",
+"$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$"};
diff --git a/audio/aeolus/slack-desc b/audio/aeolus/slack-desc
new file mode 100644
index 0000000000..1edd189e8c
--- /dev/null
+++ b/audio/aeolus/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+aeolus: aeolus (pipe organ emulator)
+aeolus:
+aeolus: Aeolus is a synthesised (i.e. not sampled) pipe organ emulator that
+aeolus: should be good enough to make an organist enjoy playing it. It is a
+aeolus: software synthesiser optimised for this job, with possibly hundreds of
+aeolus: controls for each stop, that enable the user to voice his instrument.
+aeolus: First presented at the 2nd LAD conference in Karlsruhe, end of April
+aeolus: 2004.
+aeolus:
+aeolus:
+aeolus: