summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Philip Lacroix <slackph at posteo dot de>2017-02-12 07:35:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-18 07:54:02 +0700
commit3e78bf4a382010101ab09a23b1194e678f722b77 (patch)
treefef742cf1f0fe6c60115b78747d85364cc807e2e
parentd57fd6a94440b4da2a7dfccf0da3ae86c15c3971 (diff)
downloadslackbuilds-3e78bf4a382010101ab09a23b1194e678f722b77.tar.gz
slackbuilds-3e78bf4a382010101ab09a23b1194e678f722b77.tar.xz
system/glances: Updated for version 2.8.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/glances/README54
-rw-r--r--system/glances/doinst.sh11
-rw-r--r--system/glances/glances.SlackBuild23
-rw-r--r--system/glances/glances.info6
-rw-r--r--system/glances/slack-desc8
5 files changed, 65 insertions, 37 deletions
diff --git a/system/glances/README b/system/glances/README
index d91793e83c..79c22dce72 100644
--- a/system/glances/README
+++ b/system/glances/README
@@ -1,27 +1,45 @@
-glances is a free (LGPL) cross-platform curses-based system monitoring tool
+glances is a free (LGPL), cross-platform, curses-based system monitoring tool
which aims to present a maximum of information in a minimum of space, ideally
-to fit in a classical 80x24 terminal, or larger for additional data as it can
+to fit in a classical 80x24 terminal, or larger for additional data. It can
adapt the displayed information dynamically, depending on the terminal size.
-
-This tool can also work in client/server mode. Remote monitoring can be done
-via terminal or web interface.
+A client/server mode is also available and remote monitoring can be done via
+terminal or a web interface.
glances is written in Python and uses the psutil library to fetch statistical
-values from key elements, like CPU, load average, memory, network, disks,
-file systems, processes, etc.
+values from key elements, like CPU, load average, memory, network, disks, file
+systems, processes, etc.
OPTIONAL DEPENDENCIES
-Available on SBo: batinfo (battery monitoring support), bottle (Web server
-mode), hddtemp (HHD temperature monitoring support), matplotlib (generation
-of graphs from history data), netifaces (IP plugin), py3sensors (HW monitoring
-support), pymdstat (RAID support), python3, statsd (StatsD export module),
-pysnmp (SNMP support).
+* Available on SBo:
+batinfo (for battery monitoring support)
+bottle (for web server mode)
+couchdb (for CouchDB export module)
+docker (for Docker monitoring support)
+elasticsearch (for Elastic Search export module)
+hddtemp (for HDD temperature monitoring support)
+matplotlib (for graphical/chart support)
+netifaces (for IP plugin)
+py-cpuinfo (for Quicklook CPU info module)
+py3sensors (for hardware monitoring support)
+pymdstat (for RAID support)
+python-requests (for Ports plugin)
+python-scandir (for Folders plugin)
+statsd (for StatsD export module)
+pysnmp (for SNMP support)
+pyzmq (for ZeroMQ export module)
-Not available on SBo: docker-py (Docker monitoring support), influxdb (InfluxDB
-export module), pika (RabbitMQ/ActiveMQ export module), py-cpuinfo (Quicklook
-CPU info module), pystache (action script feature), zeroconf (auto discoverer
-mode).
+* Not available on SBo:
+bernhard (for Riemann export module)
+cassandra-driver (for Cassandra export module)
+influxdb (for InfluxDB export module)
+nvidia-ml-py (for GPU plugin)
+pika (for RabbitMQ/ActiveMQ export module)
+potsdb (for OpenTSDB export module)
+pystache (for action scripting)
+wifi (for wifi plugin)
+zeroconf (for autodiscover mode)
-NOTE: When launching glances in a terminal with a bright background, the option
-'--theme-white' is recommended.
+NOTE: When launching glances from a terminal with a bright background, the
+option '--theme-white' is recommended. More options are documented in the man
+page and in the file glances.conf.
diff --git a/system/glances/doinst.sh b/system/glances/doinst.sh
new file mode 100644
index 0000000000..589723e01a
--- /dev/null
+++ b/system/glances/doinst.sh
@@ -0,0 +1,11 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ rm $NEW
+ fi
+}
+
+config /etc/glances.conf.new
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
index f1acfd3ccc..3ecfcb2320 100644
--- a/system/glances/glances.SlackBuild
+++ b/system/glances/glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for glances
-# Copyright 2013-2015 Philip Lacroix <slackph at posteo dot de>
+# Copyright 2013-2017 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glances
-VERSION=${VERSION:-2.5.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.8.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -46,14 +46,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-
-# The upstream tarball will be named differently, depending on
-# the file being downloaded manually (web browser) or with wget.
-if [ -e $CWD/v$VERSION.tar.gz ]; then
- tar xvzf $CWD/v$VERSION.tar.gz
-else
- tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
+tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
@@ -68,6 +61,7 @@ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+PRGETC=$PKG/etc
PRGUSR=$PKG/usr
PRGSHR=$PKG/usr/share
PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
@@ -76,6 +70,10 @@ PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mv $PRGSHR/man $PRGUSR/
gzip -9 $PRGUSR/man/man1/$PRGNAM.1
+# Safely install configuration file.
+mkdir $PRGETC
+mv $PRGSHR/doc/$PRGNAM/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
+
# Install documentation.
mkdir -p $PRGDOC
mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
@@ -84,6 +82,7 @@ rm -rf $PRGSHR
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/glances/glances.info b/system/glances/glances.info
index dbbc00d848..54c0168add 100644
--- a/system/glances/glances.info
+++ b/system/glances/glances.info
@@ -1,8 +1,8 @@
PRGNAM="glances"
-VERSION="2.5.1"
+VERSION="2.8.2"
HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://github.com/nicolargo/glances/archive/v2.5.1.tar.gz"
-MD5SUM="d90292fb283b2f888253d650eb28b549"
+DOWNLOAD="https://github.com/nicolargo/glances/archive/v2.8.2/glances-2.8.2.tar.gz"
+MD5SUM="c28a31def6812c44360050ae64d3c2ba"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="psutil"
diff --git a/system/glances/slack-desc b/system/glances/slack-desc
index 765d50be5e..e5b111feec 100644
--- a/system/glances/slack-desc
+++ b/system/glances/slack-desc
@@ -10,10 +10,10 @@ glances: glances (a cross-platform, curses-based system monitoring tool)
glances:
glances: glances is a cross-platform, curses-based system monitoring tool
glances: written in Python. It can adapt the displayed information depending
-glances: on the terminal size, and can also work in client/server mode for
-glances: remote monitoring. It uses the psutil library to fetch statistical
-glances: values from key elements, like CPU, load average, memory, network,
-glances: disks, file systems, processes, etc.
+glances: on the terminal size and can work in a client/server mode for remote
+glances: monitoring. It uses the psutil library to fetch statistical values
+glances: from key elements, like CPU, load average, memory, network, disks,
+glances: file systems, processes, etc.
glances:
glances: Homepage: https://github.com/nicolargo/glances
glances: