summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Halali <larryhaja[at]gmail[dot]com>2010-12-22 09:24:00 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2010-12-22 09:24:00 -0200
commit42e0bbbeda1f83edc685ddb692b7dac39bcf2968 (patch)
tree14213f07517ed8900bd332f3eb57e21d89f0d89a
parent3e2428b92106b6c4e29acbf510923f4a815bc973 (diff)
downloadslackbuilds-42e0bbbeda1f83edc685ddb692b7dac39bcf2968.tar.gz
slackbuilds-42e0bbbeda1f83edc685ddb692b7dac39bcf2968.tar.xz
libraries/irrlicht: Added (realtime 3D engine)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--libraries/irrlicht/README3
-rw-r--r--libraries/irrlicht/correct-install.diff37
-rw-r--r--libraries/irrlicht/irrlicht.SlackBuild78
-rw-r--r--libraries/irrlicht/irrlicht.info10
-rw-r--r--libraries/irrlicht/slack-desc19
5 files changed, 147 insertions, 0 deletions
diff --git a/libraries/irrlicht/README b/libraries/irrlicht/README
new file mode 100644
index 0000000000..760c0776a0
--- /dev/null
+++ b/libraries/irrlicht/README
@@ -0,0 +1,3 @@
+The Irrlicht Engine is an open source high performance realtime 3D engine
+written and usable in C++. It is completely cross-platform, using D3D,
+OpenGL and its own software renderers.
diff --git a/libraries/irrlicht/correct-install.diff b/libraries/irrlicht/correct-install.diff
new file mode 100644
index 0000000000..f945dc2c11
--- /dev/null
+++ b/libraries/irrlicht/correct-install.diff
@@ -0,0 +1,37 @@
+From: Christoph Egger <Christoph.Egger@gmx.de>
+Subject: [PATCH] debian/correct-install
+
+The variables setup for the install target does not work. We're correcting it here
+
+Signed-off-by: Christoph Egger <Christoph.Egger@gmx.de>
+
+---
+ source/Irrlicht/Makefile | 13 +++++++++++--
+ 1 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/source/Irrlicht/Makefile b/source/Irrlicht/Makefile
+index 49f990d..a66980b 100644
+--- a/source/Irrlicht/Makefile
++++ b/source/Irrlicht/Makefile
+@@ -141,8 +141,17 @@ install install_osx:
+ mkdir -p $(INSTALL_DIR)/../include/irrlicht
+ cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht/
+ cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
+- cd $(INSTALL_DIR) && ln -s -f $(SHARED_LIB).$(VERSION) $(SHARED_LIB)
+-# ldconfig -n $(INSTALL_DIR)
++ cp $(LIB_PATH)/$(STATIC_LIB) $(INSTALL_DIR)
++ cd $(INSTALL_DIR) && ln -s -f libIrrlicht.so.$(VERSION) $(SHARED_LIB)
++ #ldconfig -n $(INSTALL_DIR)
++
++install_osx:
++ $(RM) -r $(INSTALL_DIR)/../include/irrlicht
++ mkdir -p $(INSTALL_DIR)/../include/irrlicht
++ cp ../../include/*.h $(INSTALL_DIR)/../include/irrlicht
++ cp $(LIB_PATH)/$(SHARED_LIB).$(VERSION) $(INSTALL_DIR)
++ cd $(INSTALL_DIR) && ln -s libIrrlicht.dylib.$(VERSION) $(SHARED_LIB)
++ ldconfig -n $(INSTALL_DIR)
+
+ TAGS:
+ ctags *.cpp ../../include/*.h *.h
+--
+tg: (9f40966..) debian/correct-install (depends on: master)
diff --git a/libraries/irrlicht/irrlicht.SlackBuild b/libraries/irrlicht/irrlicht.SlackBuild
new file mode 100644
index 0000000000..f2c32db0e9
--- /dev/null
+++ b/libraries/irrlicht/irrlicht.SlackBuild
@@ -0,0 +1,78 @@
+#!/bin/sh
+
+# Slackware build script for irrlicht
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=irrlicht
+VERSION=${VERSION:-1.7.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Correct the install sequence.
+patch -p1 < $CWD/correct-install.diff
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make -C source/Irrlicht \
+ sharedlib staticlib
+make -C source/Irrlicht install \
+ DESTDIR=$PKG \
+ INSTALL_DIR=$PKG/usr/lib${LIBDIRSUFFIX}
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.txt $(find doc -type f -maxdepth 1 ! -name 'readme.txt') source/source.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/irrlicht/irrlicht.info b/libraries/irrlicht/irrlicht.info
new file mode 100644
index 0000000000..625fb00a86
--- /dev/null
+++ b/libraries/irrlicht/irrlicht.info
@@ -0,0 +1,10 @@
+PRGNAM="irrlicht"
+VERSION="1.7.2"
+HOMEPAGE="http://irrlicht.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/irrlicht/irrlicht-1.7.2.zip"
+MD5SUM="eb627d4c432bf73f12bc6d9ddc700b07"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Larry Halali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="Niels Horn"
diff --git a/libraries/irrlicht/slack-desc b/libraries/irrlicht/slack-desc
new file mode 100644
index 0000000000..d59ba52fdf
--- /dev/null
+++ b/libraries/irrlicht/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+irrlicht: irrlicht (realtime 3D engine)
+irrlicht:
+irrlicht: The Irrlicht Engine is an open source high performance realtime 3D
+irrlicht: engine written and usable in C++. It is completely cross-platform,
+irrlicht: using D3D, OpenGL and its own software renderers.
+irrlicht:
+irrlicht: Homepage: http://irrlicht.sourceforge.net/
+irrlicht:
+irrlicht:
+irrlicht:
+irrlicht: