summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dugan Chen <thedoogster [at] gmail [dot] com>2015-07-13 09:14:17 +0700
committer Robby Workman <rworkman@slackbuilds.org>2015-07-16 10:57:21 -0500
commit7e529f73c02dd018d4cbd63488f480495a7bae43 (patch)
tree412c3159073f2ec38437bfc5f6ef362bb0f7699d
parentfecb3e210a08f7824ffae74e8d407842ee1b2c38 (diff)
downloadslackbuilds-7e529f73c02dd018d4cbd63488f480495a7bae43.tar.gz
slackbuilds-7e529f73c02dd018d4cbd63488f480495a7bae43.tar.xz
audio/rubyripper: Updated for version 0.6.2 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--audio/rubyripper/README2
-rw-r--r--audio/rubyripper/configure.patch15
-rw-r--r--audio/rubyripper/rubyripper.SlackBuild9
-rw-r--r--audio/rubyripper/rubyripper.info10
4 files changed, 21 insertions, 15 deletions
diff --git a/audio/rubyripper/README b/audio/rubyripper/README
index 08384f9fbc..f18666b8be 100644
--- a/audio/rubyripper/README
+++ b/audio/rubyripper/README
@@ -6,7 +6,7 @@ It currently has a gtk2 and a command-line interface.
Rubyripper has the optional dependencies:
* In SBo:
-** ruby-gtk2 (for gtk2 gui, use env GTK2=true)
+** rubygem-gtk2 (for gtk2 gui, use env GTK2=true)
** cd-discid (for proper freedb support)
** lame (if the codec is wanted)
** vorbisgain, mp3gain (for replaygain support)
diff --git a/audio/rubyripper/configure.patch b/audio/rubyripper/configure.patch
index 0ceaa60e5d..a2cf2547ad 100644
--- a/audio/rubyripper/configure.patch
+++ b/audio/rubyripper/configure.patch
@@ -1,11 +1,16 @@
---- rubyripper-0.6.0/configure.orig 2010-08-31 09:01:59.859303468 -0400
-+++ rubyripper-0.6.0/configure 2010-08-31 09:02:08.122305957 -0400
-@@ -110,7 +110,7 @@
+--- configure.orig 2015-07-12 10:56:29.415500175 -0700
++++ configure 2015-07-12 10:56:57.546148494 -0700
+@@ -110,10 +110,10 @@
puts "Testing support for the graphical frontend..."
begin
- require 'gtk2'
+- puts "ruby-gtk2 bindings found"
+ require 'gtk2/base'
- puts "ruby-gtk2 bindings found"
++ puts "rubygem-gtk2 bindings found"
rescue LoadError
- puts "ruby-gtk2 is not found. The graphical frontend won't work!"
+- puts "ruby-gtk2 is not found. The graphical frontend won't work!"
++ puts "rubygem-gtk2 is not found. The graphical frontend won't work!"
+ end
+
+ puts "\nTesting support for freedb metadata fetching..."
diff --git a/audio/rubyripper/rubyripper.SlackBuild b/audio/rubyripper/rubyripper.SlackBuild
index e8b40003ba..65029db7d0 100644
--- a/audio/rubyripper/rubyripper.SlackBuild
+++ b/audio/rubyripper/rubyripper.SlackBuild
@@ -1,11 +1,12 @@
#!/bin/sh
# Slackware build script for rubyripper
-# Written 2009, by Grigorios Bouzakis (grbzks@gmail.com)
-# Updated 2010, by Vincent Batts (vbatts@hashbangbash.com)
+# Written 2009, by Grigorios Bouzakis (grbzks [at] gmail [dot] com)
+# Updated 2010, by Vincent Batts (vbatts [at] hashbangbash [dot] com)
+# Updated 2015, by Dugan Chen (thedoogster [at] gmail [dot] com)
PRGNAM=rubyripper
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.6.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -61,7 +62,7 @@ find -L . \
# we should patch this regardless, because if 'gtk2' is present
# it will fail the build
-cat ${CWD}/configure.patch | patch configure
+patch --verbose < ${CWD}/configure.patch
./configure \
--prefix=/usr \
diff --git a/audio/rubyripper/rubyripper.info b/audio/rubyripper/rubyripper.info
index f7d5601b6e..e0d1686d15 100644
--- a/audio/rubyripper/rubyripper.info
+++ b/audio/rubyripper/rubyripper.info
@@ -1,10 +1,10 @@
PRGNAM="rubyripper"
-VERSION="0.6.0"
+VERSION="0.6.2"
HOMEPAGE="http://code.google.com/p/rubyripper/"
-DOWNLOAD="http://rubyripper.googlecode.com/files/rubyripper-0.6.0.tar.bz2"
-MD5SUM="5493856f60f18a6f0d338de92c6180a0"
+DOWNLOAD="http://rubyripper.googlecode.com/files/rubyripper-0.6.2.tar.bz2"
+MD5SUM="04ee16c117ef8d839c3681b62839e8af"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@hashbangbash.com"
+MAINTAINER="Dugan Chen"
+EMAIL="thedoogster [at] gmail [dot] com"