summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Robby Workman <rw@rlworkman.net>2010-05-13 00:42:07 +0200
committer Michiel van Wessem <michiel@slackbuilds.org>2010-05-13 00:42:07 +0200
commit8b7cfb1fcd6b3ec8d61e2b5235fe6e0d97efa8ab (patch)
tree65b29e11571f91a7490dc2a2eec36697c1bb349a
parentc502f2567867f95213f82eb617d73042ec417e72 (diff)
downloadslackbuilds-8b7cfb1fcd6b3ec8d61e2b5235fe6e0d97efa8ab.tar.gz
slackbuilds-8b7cfb1fcd6b3ec8d61e2b5235fe6e0d97efa8ab.tar.xz
system/ulogd: Updated for version 1.24
-rw-r--r--system/ulogd/README4
-rw-r--r--system/ulogd/configure.in.diff10
-rw-r--r--system/ulogd/ulogd.SlackBuild39
-rw-r--r--system/ulogd/ulogd.info2
4 files changed, 25 insertions, 30 deletions
diff --git a/system/ulogd/README b/system/ulogd/README
index 4d0b38d032..7279f12209 100644
--- a/system/ulogd/README
+++ b/system/ulogd/README
@@ -6,7 +6,3 @@ You get an init script free of charge: /etc/rc.d/rc.ulogd --
You'll just have to make it executable and call it from one of your
init scripts. Also, be sure to have a look at /etc/ulogd.conf;
it works fine with the default, but you might want to customize it...
-
-If you don't want to build with mysql and/or sqlite3 support, you can
-run the script with either or both of these specified:
- WITH_MYSQL=no WITH_SQLITE=no
diff --git a/system/ulogd/configure.in.diff b/system/ulogd/configure.in.diff
new file mode 100644
index 0000000000..3df5d81a2a
--- /dev/null
+++ b/system/ulogd/configure.in.diff
@@ -0,0 +1,10 @@
+--- ulogd-1.24/configure.in 2005-11-25 20:58:27.000000000 +0100
++++ ulogd-1.24/configure.in 2009-11-30 08:41:40.000000000 +0100
+@@ -20,6 +20,7 @@
+ AC_C_CONST
+ AC_TYPE_SIZE_T
+ AC_STRUCT_TM
++AC_SYS_LARGEFILE
+
+ dnl Checks for library functions.
+ AC_FUNC_VPRINTF
diff --git a/system/ulogd/ulogd.SlackBuild b/system/ulogd/ulogd.SlackBuild
index 74f7582737..28dfb97ae0 100644
--- a/system/ulogd/ulogd.SlackBuild
+++ b/system/ulogd/ulogd.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for ulogd
-# Copyright 2006-2007 Robby Workman (http://rlworkman.net)
+# Copyright 2006-2009 Robby Workman, Northport, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=ulogd
VERSION=1.24
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -33,9 +33,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-WITH_MYSQL=${WITH_MYSQL:-yes}
-WITH_SQLITE=${WITH_SQLITE:-yes}
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -47,18 +44,6 @@ elif [ "$ARCH" = "x86_64" ]; then
LIBDIRSUFFIX="64"
fi
-if [ "$WITH_MYSQL" != "yes" ]; then
- do_mysql="--without-mysql"
-else
- do_mysql="--with-mysql"
-fi
-
-if [ "$WITH_SQLITE" != "yes" ]; then
- do_sqlite="--without-sqlite3"
-else
- do_sqlite="--with-sqlite3"
-fi
-
set -e
rm -rf $PKG
@@ -70,31 +55,33 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
+# Add large file support
+patch -p1 < $CWD/configure.in.diff
+autoconf
+
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
- --build=$ARCH-slackware-linux \
- $do_mysql \
- $do_sqlite
+ --with-sqlite3 \
+ --with-mysql \
+ --build=$ARCH-slackware-linux
# "mysql_config --libs" shows -rdynamic, but it causes the mysql plugin
# to barf on compilation (and running too, according to bug reports in
# other distributions), so we'll remove that flag
-if [ "$WITH_MYSQL" = "yes" ]; then
- sed -i 's%-rdynamic %%' Rules.make
-fi
+sed -i 's%-rdynamic %%' Rules.make
make
make install DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
)
install -D -m 0755 $CWD/rc.ulogd $PKG/etc/rc.d/rc.ulogd.new
@@ -121,4 +108,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/ulogd/ulogd.info b/system/ulogd/ulogd.info
index 682be25b5b..f43188bc66 100644
--- a/system/ulogd/ulogd.info
+++ b/system/ulogd/ulogd.info
@@ -2,7 +2,9 @@ PRGNAM="ulogd"
VERSION="1.24"
HOMEPAGE="http://www.netfilter.org/projects/ulogd/index.html"
DOWNLOAD="http://www.netfilter.org/projects/ulogd/files/ulogd-1.24.tar.bz2"
+DOWNLOAD_x86_64=""
MD5SUM="05b4ed2926b9a22aaeaf642917bbf8ff"
+MD5SUM_x86_64=""
MAINTAINER="Robby Workman"
EMAIL="rw@rlworkman.net"
APPROVED="BP{k}"