summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Michiel van Wessem <michiel@slackbuilds.org>2010-05-11 22:54:28 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 22:54:28 +0200
commita630d7216dbec08a4e30b1a981594428b4a90048 (patch)
tree4e1f8bbc8604b2cba8f28a9a02aba44fbdd90cb0
parent04c4c5e45b12ce0adb5a278472004a0cecac73ea (diff)
downloadslackbuilds-a630d7216dbec08a4e30b1a981594428b4a90048.tar.gz
slackbuilds-a630d7216dbec08a4e30b1a981594428b4a90048.tar.xz
misc/asr-manpages: Added to 12.1 repository
-rw-r--r--misc/asr-manpages/README8
-rw-r--r--misc/asr-manpages/asr-manpages.SlackBuild80
-rw-r--r--misc/asr-manpages/asr-manpages.info8
-rw-r--r--misc/asr-manpages/asr-manpages_1.3-6.diff330
-rw-r--r--misc/asr-manpages/google.724
-rw-r--r--misc/asr-manpages/slack-desc19
6 files changed, 469 insertions, 0 deletions
diff --git a/misc/asr-manpages/README b/misc/asr-manpages/README
new file mode 100644
index 0000000000..f6760a6034
--- /dev/null
+++ b/misc/asr-manpages/README
@@ -0,0 +1,8 @@
+alt.sysadmin.recovery manual pages
+
+A set of humorous manual pages developed on alt.sysadmin.recovery (don't treat
+them seriously!). They document a set of really useful tools that for some
+strange reason are not included in any implementation of Unix. This includes
+such famous commands as lart, sysadmin, luser, bosskill and others.
+
+The authors recommend these man pages should be installed on every system.
diff --git a/misc/asr-manpages/asr-manpages.SlackBuild b/misc/asr-manpages/asr-manpages.SlackBuild
new file mode 100644
index 0000000000..e9ec0873fb
--- /dev/null
+++ b/misc/asr-manpages/asr-manpages.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for asr-manpages
+
+# Copyright 2007-2008 Michiel van Wessem, Manchester, United Kingdom
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=asr-manpages
+VERSION=1.3.6
+SRC_VERSION=1.3
+DEB_VERSION=1.3-6
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$SRC_VERSION
+tar xvf $CWD/${PRGNAM}_$SRC_VERSION.orig.tar.gz
+cd $PRGNAM-$SRC_VERSION.orig
+
+# Patch the manpages to the latest version.
+patch -p1 < $CWD/${PRGNAM}_$DEB_VERSION.diff
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Create the directories we need
+mkdir -p $PKG/usr/man/man{1,2,3,5,7,8}
+install -m 0644 $CWD/google.7 $PKG/usr/man/man7/google.7fun
+for manpage in $(echo *fun); do
+ section=$(echo $manpage | awk -F. '{print $2}' | colrm 2 4)
+ install -m 0644 $manpage $PKG/usr/man/man$section/$manpage
+done
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog debian/copyright $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/misc/asr-manpages/asr-manpages.info b/misc/asr-manpages/asr-manpages.info
new file mode 100644
index 0000000000..af80e4d5bd
--- /dev/null
+++ b/misc/asr-manpages/asr-manpages.info
@@ -0,0 +1,8 @@
+PRGNAM="asr-manpages"
+VERSION="1.3.6"
+HOMEPAGE="http://packages.debian.org/etch/asr-manpages"
+DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/a/asr-manpages/asr-manpages_1.3.orig.tar.gz"
+MD5SUM="ee77b619e01a2d841a45469708d90631"
+MAINTAINER="Michiel van Wessem"
+EMAIL="michiel@slackbuilds.org"
+APPROVED="rworkman"
diff --git a/misc/asr-manpages/asr-manpages_1.3-6.diff b/misc/asr-manpages/asr-manpages_1.3-6.diff
new file mode 100644
index 0000000000..9e8c8c7af8
--- /dev/null
+++ b/misc/asr-manpages/asr-manpages_1.3-6.diff
@@ -0,0 +1,330 @@
+--- asr-manpages-1.3.orig/debian/changelog
++++ asr-manpages-1.3/debian/changelog
+@@ -0,0 +1,110 @@
++asr-manpages (1.3-6) unstable; urgency=low
++
++ * Rebuilt to force current standards (closes: #322807)
++ * While at that updated standards-version
++
++ -- Pawel Wiecek <coven@debian.org> Thu, 22 Sep 2005 21:42:46 +0200
++
++asr-manpages (1.3-5) unstable; urgency=low
++
++ * re-applied some fixes that got lost during repackaging
++ * fixed one more type in luser.1fun
++
++ -- Pawel Wiecek <coven@debian.org> Tue, 12 Jun 2001 15:52:50 +0200
++
++asr-manpages (1.3-4) unstable; urgency=low
++
++ * added symlinks for {axe,chainsaw,cutter}.8fun.gz (closes: #99541)
++ * now compliant with 3.5.5 policy
++
++ -- Pawel Wiecek <coven@debian.org> Fri, 8 Jun 2001 09:38:33 +0200
++
++asr-manpages (1.3-3) unstable; urgency=low
++
++ * Added Build-Depends line to debian/control (was missing)
++
++ -- Pawel Wiecek <coven@debian.org> Tue, 22 May 2001 12:25:58 +0200
++
++asr-manpages (1.3-2) unstable; urgency=low
++
++ * Re-applied fix to knife.8fun, that somehow got lost during repackaging
++ (closes: #96925)
++
++ -- Pawel Wiecek <coven@debian.org> Thu, 10 May 2001 09:33:15 +0200
++
++asr-manpages (1.3-1) unstable; urgency=low
++
++ * Rebuilt archive, moving all manpages to fun subsection to avoid possible
++ name clashes
++ * General cleanup (new standards version, etc.)
++
++ -- Pawel Wiecek <coven@debian.org> Mon, 7 May 2001 11:28:26 +0200
++
++asr-manpages (1.2-4) unstable; urgency=low
++
++ * Correction to knife.8 (closes: #58422)
++ * Updated standards version
++
++ -- Pawel Wiecek <coven@debian.org> Fri, 1 Dec 2000 15:53:24 +0100
++
++asr-manpages (1.2-3) unstable; urgency=low
++
++ * Fixed a couple of typos (fixes bugs #42461, #34173)
++ * Symlinked n.1 to undocumented.7 (fixes #36617)
++ * Updated to standards version 3.0.1
++
++ -- Pawel Wiecek <coven@debian.org> Tue, 26 Oct 1999 21:00:37 +0200
++
++asr-manpages (1.2-2) unstable; urgency=low
++
++ * Updated Standards-Version
++
++ -- Pawel Wiecek <coven@debian.org> Sat, 31 Oct 1998 22:53:44 +0100
++
++asr-manpages (1.2-1) unstable; urgency=low
++
++ * Version number changed 'cause I messed .orig somehow
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Thu, 15 Jan 1998 00:00:10 +0100
++
++asr-manpages (1.1-5) unstable; urgency=low
++
++ * Uubp(1) moved to funny-manpages since it's not present in canonical
++ asr-manpages distribution.
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Sun, 11 Jan 1998 19:39:51 +0100
++
++asr-manpages (1.1-4) unstable; urgency=low
++
++ * Added Suggests: funny-manpages to control file to encourage people to
++ install non-a.s.r pages too
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Wed, 10 Dec 1997 01:37:38 +0100
++
++asr-manpages (1.1-3) unstable; urgency=low
++
++ * Fixed a typo in the description
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Sat, 16 Aug 1997 01:28:33 +0200
++
++asr-manpages (1.1-2) unstable; urgency=low
++
++ * Corrected copyright file (copyright info for c(1) page was missing)
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Mon, 28 Jul 1997 23:53:48 +0200
++
++asr-manpages (1.1-1) unstable; urgency=low
++
++ * New man page for c(1) added
++ * Added man page for uubp(1) which was missing from distribution
++ (required some reverse engeneering)
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Mon, 28 Jul 1997 00:56:58 +0200
++
++asr-manpages (1.0-1) unstable; urgency=low
++
++ * Initial Release.
++ * Added symlinks to axe, cutter and chainsaw
++
++ -- Pawel Wiecek <coven@pwr.wroc.pl> Sun, 1 Jun 1997 23:13:56 +0200
++
+--- asr-manpages-1.3.orig/debian/control
++++ asr-manpages-1.3/debian/control
+@@ -0,0 +1,19 @@
++Source: asr-manpages
++Section: doc
++Priority: optional
++Maintainer: Pawel Wiecek <coven@debian.org>
++Build-Depends: debhelper (>> 3.0.0)
++Standards-Version: 3.6.2
++
++Package: asr-manpages
++Architecture: all
++Suggests: funny-manpages (>=1.3-2)
++Description: alt.sysadmin.recovery manual pages
++ A set of humorous manual pages developed on
++ alt.sysadmin.recovery (don't treat them seriously!).
++ They document a set of really useful tools that for some
++ strange reason are not included in any implementation of
++ Unix. This includes such famous commands as lart, sysadmin,
++ luser, bosskill and others.
++ The authors recommend these man pages should be installed
++ on every system.
+--- asr-manpages-1.3.orig/debian/copyright
++++ asr-manpages-1.3/debian/copyright
+@@ -0,0 +1,27 @@
++This package was debianized by Pawel Wiecek coven@pwr.wroc.pl on
++Sun, 1 Jun 1997 23:13:56 +0200.
++
++It was downloaded from ftp://ftp.winternet.com/users/eric/asr.pages.tar
++
++Uubp page is missing from distribution - it was reverse-engeneered from
++HTML version found on http://www.bofh.org.pl/man/.
++
++The authors of the pages are:
++ - c - Nick Williams <nickw@iname.com>
++ - lart - Tim Bandy <timn8r@risk.cs.umn.edu>
++ - slave - Ingvar Mattsson
++ - sysadmin - Abby Franquemont-Guillory <abbyfg@tezcat.com>
++ - think - John Guthrie <guthrie@math.upenn.edu>
++ - whack - Eric L. Pederson <eric@winternet.com>
++ - people - Ingvar Mattsson
++ - chastise - Ingvar Mattsson
++ - normality - Ingvar Mattsson
++ - bosskill - Eric L. Pederson <eric@winternet.com>
++ - ctluser - Simon Burr <simes@tcp.co.uk>
++ - guru - unknown author <user@foo.com>
++ - knife - Kurt Hockenbury <kurt@something.com>
++ - luser - Eric L. Pederson <eric@winternet.com>
++ - nuke - Eric S. Raymond <esr@thyrus.com>
++ - pmsd - Eric L. Pederson <eric@winternet.com>
++
++To the best of my knowledge they are all completely free.
+--- asr-manpages-1.3.orig/debian/dirs
++++ asr-manpages-1.3/debian/dirs
+@@ -0,0 +1 @@
++/usr/share/man/man8
+--- asr-manpages-1.3.orig/debian/rules
++++ asr-manpages-1.3/debian/rules
+@@ -0,0 +1,88 @@
++#!/usr/bin/make -f
++# Sample debian/rules that uses debhelper.
++# GNU copyright 1997 to 1999 by Joey Hess.
++
++# Uncomment this to turn on verbose mode.
++#export DH_VERBOSE=1
++
++# This is the debhelper compatability version to use.
++export DH_COMPAT=3
++
++configure: configure-stamp
++configure-stamp:
++ dh_testdir
++ # Add here commands to configure the package.
++
++
++ touch configure-stamp
++
++build: configure-stamp build-stamp
++build-stamp:
++ dh_testdir
++
++ # Add here commands to compile the package.
++# $(MAKE)
++ #/usr/bin/docbook-to-man debian/asr-manpages.sgml > asr-manpages.1
++
++ touch build-stamp
++
++clean:
++ dh_testdir
++ dh_testroot
++ rm -f build-stamp configure-stamp
++
++ # Add here commands to clean up after the build process.
++# -$(MAKE) clean
++
++ dh_clean
++
++install: build
++ dh_testdir
++ dh_testroot
++ dh_clean -k
++ dh_installdirs
++
++ # Add here commands to install the package into debian/asr-manpages.
++# $(MAKE) install DESTDIR=$(CURDIR)/debian/asr-manpages
++ ln -s knife.8fun.gz debian/asr-manpages/usr/share/man/man8/axe.8fun.gz
++ ln -s knife.8fun.gz debian/asr-manpages/usr/share/man/man8/chainsaw.8fun.gz
++ ln -s knife.8fun.gz debian/asr-manpages/usr/share/man/man8/cutter.8fun.gz
++
++
++# Build architecture-independent files here.
++binary-indep: build install
++# We have nothing to do by default.
++
++# Build architecture-dependent files here.
++binary-arch: build install
++ dh_testdir
++ dh_testroot
++# dh_installdebconf
++ dh_installdocs
++# dh_installexamples
++# dh_installmenu
++# dh_installlogrotate
++# dh_installemacsen
++# dh_installpam
++# dh_installmime
++# dh_installinit
++# dh_installcron
++# dh_installman # dh_installman *sucks*
++ dh_installmanpages
++# dh_installinfo
++# dh_undocumented
++ dh_installchangelogs
++# dh_link
++ dh_strip
++ dh_compress
++ dh_fixperms
++# dh_makeshlibs
++ dh_installdeb
++# dh_perl
++ dh_shlibdeps
++ dh_gencontrol
++ dh_md5sums
++ dh_builddeb
++
++binary: binary-indep binary-arch
++.PHONY: build clean binary-indep binary-arch binary install configure
+--- asr-manpages-1.3.orig/luser.8fun
++++ asr-manpages-1.3/luser.8fun
+@@ -2,7 +2,7 @@
+ .\" entertainment of the denizens of alt.sysadmin.recovery
+ .TH LUSER 8 "25 September 1995"
+ .SH NAME
+-luser \- process to control the clueless induhviduals
++luser \- process to control the clueless individuals
+ who (mis)use computer systems, peripheral devices
+ and system administrators. Word play on "loser" and "user".
+ .SH SYNOPSIS
+--- asr-manpages-1.3.orig/people.2fun
++++ asr-manpages-1.3/people.2fun
+@@ -27,7 +27,7 @@
+ int is_amoron;
+ int is_aluser;
+ int has_aclue;
+- pid_t prgp_leader;
++ pid_t pgrp_leader;
+ };
+ .fi
+ .SH RETURN VALUES
+@@ -57,7 +57,7 @@
+ is system dependent, but is usually about 3.
+ .SH EXAMPLE
+ .nf
+-#include <sys/pople.h>
++#include <sys/people.h>
+ #include <asr.h>
+ #include <signal.h>
+
+@@ -71,7 +71,7 @@
+ if (rv!=-1) {
+ for (c=0;c<rv;c++)
+ if ((ttys[c].is_amoron)||(ttys[c].is_aluser)) {
+- kill(-(ttys[c].pgrp_leader),SIGKILL);
++ kill(-(ttys[c].pgrp_leader),SIGKILL);
+ }
+ } else {
+ ; /* Handle errors in a graceful way... */
+--- asr-manpages-1.3.orig/slave.1fun
++++ asr-manpages-1.3/slave.1fun
+@@ -18,7 +18,7 @@
+ .SH THE OPTION
+ .TP
+ \-\fIf\fP
+-Send a rapid succession of \fISIHUP\fPs to \fIslave\fP, mainly used
++Send a rapid succession of \fISIGHUP\fPs to \fIslave\fP, mainly used
+ when one needs to blow off a little steam.
+ .SH THE COMMANDS
+ Almost any phrase in pidgin English is acceptable input to the
+--- asr-manpages-1.3.orig/sysadmin.1fun
++++ asr-manpages-1.3/sysadmin.1fun
+@@ -1,5 +1,5 @@
+-\." Written by Abby Franquement-Guillory (abbyfg@tezcat.com).
+-\." Convered to troff by Eric Pederson (eric@winternet.com).
++.\" Written by Abby Franquement-Guillory (abbyfg@tezcat.com).
++.\" Convered to troff by Eric Pederson (eric@winternet.com).
+ .TH SYSADMIN 1 "25 September 1995"
+ .SH NAME
+ sysadmin \- responsible for everything imaginable that may
+--- asr-manpages-1.3.orig/knife.8fun
++++ asr-manpages-1.3/knife.8fun
+@@ -1,5 +1,5 @@
+ .TH KNIFE 8
+-.SH KNIFE
++.SH NAME
+ knife, axe, cutter, chainsaw \- tools to improve network performance via SNIP
+ .SH SYNOPSIS
+ .B knife
diff --git a/misc/asr-manpages/google.7 b/misc/asr-manpages/google.7
new file mode 100644
index 0000000000..8dbe502b3f
--- /dev/null
+++ b/misc/asr-manpages/google.7
@@ -0,0 +1,24 @@
+.\" Copyright (C)2003 Piotr 'Sajmon' Sajmon <sajmon( at )tenboard.com>
+.\"
+.\" man page for google
+.\"
+.\" This program is free software; you can redistribute it and/or
+.\" modify it under the terms of the GNU General Public License
+.\" as published by the Free Software Foundation; either version 2
+.\" of the License, or (at your option) any later version.
+.\"
+.\" Translation by Jabol adam-wieckowksi(at)tlen(dot)pl
+.\"
+.TH google 7 "Jul 07, 2003"
+.LO 7
+.SH NAME:
+www.google.com \- Internet Search Engine
+.SH DESCRIPTION:
+.BI www.google.com:
+Fill the textfield with Your search query (any text You can think of) and hit enter...
+.SH AUTHOR:
+One of those answering dummies all their stupid questions, only becouse they didn't read the manual.
+.SH SEE ALSO:
+man(1)
+.SH LICENSE:
+GPL
diff --git a/misc/asr-manpages/slack-desc b/misc/asr-manpages/slack-desc
new file mode 100644
index 0000000000..08097488b6
--- /dev/null
+++ b/misc/asr-manpages/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+asr-manpages: asr-manpages (alt.sysadmin.recovery manual pages)
+asr-manpages:
+asr-manpages: A set of humorous manual pages developed on alt.sysadmin.recovery
+asr-manpages: (don't treat them seriously!). They document a set of really
+asr-manpages: useful tools that for some strange reason are not included in any
+asr-manpages: implementation of Unix.
+asr-manpages:
+asr-manpages: This includes such famous commands as lart, sysadmin, luser,
+asr-manpages: bosskill and others. The authors recommend these man pages should
+asr-manpages: be installed on every system.
+asr-manpages: