summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Philip Lacroix <philnx at posteo dot de>2015-02-07 06:33:57 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-07 06:33:57 +0700
commitade70ab197ad52e8e7a2c7652e4cc0ac83fcb3be (patch)
treeaf9090c0a718bc104e146bf9f46adda924b3a848
parent610988b2e954ad55a8ff4be76cd3675c812a9a02 (diff)
downloadslackbuilds-ade70ab197ad52e8e7a2c7652e4cc0ac83fcb3be.tar.gz
slackbuilds-ade70ab197ad52e8e7a2c7652e4cc0ac83fcb3be.tar.xz
system/glances: Updated for version 2.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/glances/README42
-rw-r--r--system/glances/glances.SlackBuild11
-rw-r--r--system/glances/glances.info6
-rw-r--r--system/glances/slack-desc14
4 files changed, 43 insertions, 30 deletions
diff --git a/system/glances/README b/system/glances/README
index 0169b34e9b..da0a08dc36 100644
--- a/system/glances/README
+++ b/system/glances/README
@@ -1,20 +1,32 @@
-Glances is a free (LGPL) cross-platform curses-based monitoring tool,
-which aims to present a maximum of information in a minimum of space
-and ideally fits in a classical 80x24 terminal, or larger for additional
-information.
+Glances is a free (LGPL) cross-platform curses-based system monitoring tool
+which aims to present a maximum of information in a minimum of space, ideally
+to fit in a classical 80x24 terminal, or larger for additional information: in
+fact it can adapt dynamically the displayed information depending on the
+terminal size.
-Glances can adapt dynamically the displayed information depending on
-the terminal size. It can also work in a client/server mode for remote
-monitoring.
+This tool can also work in client/server mode. Remote monitoring can be
+done via terminal or web interface.
-This tool is written in Python and uses the psutil library to fetch the
-statistical values from key elements, like CPU, load average, memory,
-network, disks, file systems, processes, etc.
+Glances is written in Python and uses the psutil library to fetch statistical
+values from key elements, like CPU, load average, memory, network, disks,
+file systems, processes, etc.
-Optional dependencies are hddtemp (HHD temperature monitoring support),
-pysnmp (SNMP support), matplotlib, netifaces and python3. Others not
-available on SBo are bottle (Web server mode), py3sensors (HW monitoring
-support), batinfo (battery monitoring support) and zeroconf.
+OPTIONAL DEPENDENCIES
-NOTE: when launching Glances in a terminal with a bright background, the
+Available on SBo: hddtemp (HHD temperature monitoring support), py3sensors
+(HW monitoring support), pysnmp (SNMP support), netifaces (auto discoverer
+mode), statsd (StatsD export module), matplotlib (generation of graphs from
+history data) and python3.
+
+Not available on SBo: bottle (Web server mode), batinfo (battery monitoring
+support), pymdstat (RAID support), zeroconf (auto discoverer mode), influxdb
+(InfluxDB export module), pystache (action script feature), docker-py (Docker
+monitoring support).
+
+NOTES
+
+1) When launching Glances in a terminal with a bright background, the
option '--theme-white' is recommended.
+
+2) For the optional auto discoverer mode, both zeroconf and netifaces
+are needed.
diff --git a/system/glances/glances.SlackBuild b/system/glances/glances.SlackBuild
index 3d5f740f0c..be96646c42 100644
--- a/system/glances/glances.SlackBuild
+++ b/system/glances/glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for glances
-# Copyright 2013-2014 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2013-2015 Philip Lacroix <philnx at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=glances
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,8 +47,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The tarball will be named differently, depending on the file being downloaded
-# manually or with wget.
+# The upstream tarball will be named differently, depending on the file being
+# downloaded manually (web browser) or with wget.
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvf $CWD/v$VERSION.tar.gz
else
@@ -70,7 +70,7 @@ PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
python setup.py install --root=$PKG
-# Python 3 support
+# Python 3 support.
if $(python3 -c 'import sys' 2>/dev/null); then
python3 setup.py install --root=$PKG
fi
@@ -79,6 +79,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
|| true
+# Don't mess with existing config files.
mv $PRGETC/$PRGNAM.conf $PRGETC/$PRGNAM.conf.new
mv $PRGSHR/man $PKG/usr/
diff --git a/system/glances/glances.info b/system/glances/glances.info
index 432f35a4dd..f20fa669b8 100644
--- a/system/glances/glances.info
+++ b/system/glances/glances.info
@@ -1,8 +1,8 @@
PRGNAM="glances"
-VERSION="2.2.1"
+VERSION="2.3"
HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://github.com/nicolargo/glances/archive/v2.2.1.tar.gz"
-MD5SUM="d5f0b8e38662f64a538485a65cc50755"
+DOWNLOAD="https://github.com/nicolargo/glances/archive/v2.3.tar.gz"
+MD5SUM="19c2c02c4f8768867ec18ada23cb81c2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="psutil pysetuptools"
diff --git a/system/glances/slack-desc b/system/glances/slack-desc
index e6cf4a76b8..8a6835ccd1 100644
--- a/system/glances/slack-desc
+++ b/system/glances/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-glances: glances (a cross-platform curses-based monitoring tool)
+glances: glances (a cross-platform, curses-based system monitoring tool)
glances:
-glances: glances is a cross-platform curses-based monitoring tool written in
-glances: Python, which can adapt the displayed information depending on the
-glances: terminal size. It can also work in a client/server mode for remote
-glances: monitoring. It uses the psutil library to get information from your
-glances: system.
+glances: glances is a cross-platform, curses-based system monitoring tool
+glances: written in Python. It can adapt the displayed information depending
+glances: on the terminal size, and can also work in a client/server mode for
+glances: remote monitoring. It uses the psutil library to fetch statistical
+glances: values from key elements, like CPU, load average, memory, network,
+glances: disks, file systems, processes, etc.
glances:
glances: Homepage: https://github.com/nicolargo/glances
glances:
-glances: