summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Niels Horn <niels.horn@gmail.com>2012-01-05 07:01:13 -0600
committer Erik Hanson <erik@slackbuilds.org>2012-01-05 07:01:13 -0600
commitc28b3e7500b1b3a8864b3e7d1351d515a07e2ebb (patch)
treed8c4f10da5eedf3d41e910c99d87ffcc30865c6f
parentb86f64d3d32fdb684a911506a521ab5579111016 (diff)
downloadslackbuilds-c28b3e7500b1b3a8864b3e7d1351d515a07e2ebb.tar.gz
slackbuilds-c28b3e7500b1b3a8864b3e7d1351d515a07e2ebb.tar.xz
games/sl: New maintainer, script clean-up.
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
-rw-r--r--games/sl/README12
-rw-r--r--games/sl/sl.SlackBuild70
-rw-r--r--games/sl/sl.info10
-rw-r--r--games/sl/slack-desc16
4 files changed, 60 insertions, 48 deletions
diff --git a/games/sl/README b/games/sl/README
index 33b35e724d..bef5c5c739 100644
--- a/games/sl/README
+++ b/games/sl/README
@@ -1,10 +1,4 @@
-Sl is a program that can display animations aimed to correct you if
-you type sl instead of ls by mistake. Sl stands for Steam Locomotive.
+sl is a program that displays animations aimed to correct you if you type
+sl instead of ls by mistake.
-As the original version of this program is no longer maintained,
-this build uses the Debian patchset to bring it up-to-date.
-
-Original homepage:
-http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html
-Patchset:
-http://packages.debian.org/squeeze/sl
+'sl' stands for Steam Locomotive.
diff --git a/games/sl/sl.SlackBuild b/games/sl/sl.SlackBuild
index 8d81ad906c..b41c0d171b 100644
--- a/games/sl/sl.SlackBuild
+++ b/games/sl/sl.SlackBuild
@@ -1,23 +1,42 @@
#!/bin/sh
# Slackware build script for sl.
-# This script builds the version of sl maintained by the Debian project.
-# Written by V'yacheslav Stetskevych
+# Copyright 2010 V'yacheslav Stetskevych
+# Copyright 2012 Niels Horn, Rio de Janeiro, RJ, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# revision date: 2012/01/05
PRGNAM=sl
-VERSION=${VERSION:-3.03}
-PATCHLEVEL=${PATCHLEVEL:-16}
-SRCVERSION=${SRCVERSION:-3.03.orig}
+VERSION=${VERSION:-3.03_16}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
+ORIGVERSION=$(echo $VERSION | cut -d_ -f1)
+PATCHLEVEL=$(echo $VERSION | cut -d_ -f2)
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -46,18 +65,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$SRCVERSION
-tar xvf $CWD/${PRGNAM}_$SRCVERSION.tar.gz
-cd $PRGNAM-$SRCVERSION
-# Apply the debian patchset, which creates the "debian" directory
-echo "Applying debian patchset..."
-zcat $CWD/sl_$VERSION-$PATCHLEVEL.diff.gz | patch -p1
-# Apply individual debian patches
-echo "Patching project files..."
-for file in debian/patches/*.dpatch; do
- patch -p1 < "$file"
-done
-
+rm -rf $PRGNAM-$ORIGVERSION.orig
+tar xvf $CWD/${PRGNAM}_$ORIGVERSION.orig.tar.gz
+cd $PRGNAM-$ORIGVERSION.orig
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -65,6 +75,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Apply the debian patchset, which creates the "debian" directory
+echo "Applying debian patchset..."
+zcat $CWD/sl_$ORIGVERSION-$PATCHLEVEL.diff.gz | patch -p1
+# Apply individual debian patches
+echo "Patching project files..."
+for file in debian/patches/*.dpatch; do
+ patch -p1 < "$file"
+done
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
LDFLAGS="-lcurses" \
@@ -90,17 +109,16 @@ mkdir -p $PKG/usr/man # man pages
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-mkdir -p $PKG/usr/doc/$PRGNAM-${VERSION}_$PATCHLEVEL
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a debian/README* debian/changelog debian/copyright \
- $PKG/usr/doc/$PRGNAM-${VERSION}_$PATCHLEVEL
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-${VERSION}_$PATCHLEVEL/$PRGNAM.SlackBuild
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-${VERSION}_$PATCHLEVEL-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/sl/sl.info b/games/sl/sl.info
index c0006c7914..f627bd16f0 100644
--- a/games/sl/sl.info
+++ b/games/sl/sl.info
@@ -2,11 +2,11 @@ PRGNAM="sl"
VERSION="3.03_16"
HOMEPAGE="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html"
DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/s/sl/sl_3.03.orig.tar.gz \
- http://ftp.de.debian.org/debian/pool/main/s/sl/sl_3.03-16.diff.gz"
+ http://ftp.de.debian.org/debian/pool/main/s/sl/sl_3.03-16.diff.gz"
MD5SUM="d0d997b964bb3478f7f4968eee13c698 \
- c6c20604f3f07e0149108fa5220de4b3"
+ c6c20604f3f07e0149108fa5220de4b3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="V'yacheslav Stetskevych"
-EMAIL="slava18@gmail.com"
-APPROVED="michiel"
+MAINTAINER="Niels Horn"
+EMAIL="niels.horn@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/games/sl/slack-desc b/games/sl/slack-desc
index a167e75f5b..f65539df01 100644
--- a/games/sl/slack-desc
+++ b/games/sl/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
+sl: sl (Steam Locomotive)
+sl:
+sl: sl is a program that displays animations aimed to correct you if
+sl: you type sl instead of ls by mistake.
+sl: 'sl' stands for Steam Locomotive.
+sl:
+sl:
+sl: Homepage: http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html
sl:
-sl: Sl is a program that can display animations aimed to correct you if
-sl: you type sl instead of ls by mistake. Sl stands for Steam Locomotive.
sl:
-sl: As the original version of this program is no longer maintained,
-sl: this build uses the Debian patchset to bring it up-to-date.
sl:
-sl: Original homepage:
-sl: http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html
-sl: Patchset:
-sl: http://packages.debian.org/squeeze/sl