summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Thibaut Notteboom <thibaut.notteboom@gmail.com>2019-05-25 01:37:41 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-05-25 07:31:52 +0700
commitca9f6f8bd4424ee360f584f3f09148f09e97545d (patch)
treec505ab6236f721e11dd71360e141ab12be94dbcf
parent643cd057a3057e0709b54fa8c04310f85b7b81db (diff)
downloadslackbuilds-ca9f6f8bd4424ee360f584f3f09148f09e97545d.tar.gz
slackbuilds-ca9f6f8bd4424ee360f584f3f09148f09e97545d.tar.xz
libraries/tomcat-native: Added (Apache Tomcat Component).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/tomcat-native/README7
-rw-r--r--libraries/tomcat-native/slack-desc19
-rw-r--r--libraries/tomcat-native/tomcat-native.SlackBuild102
-rw-r--r--libraries/tomcat-native/tomcat-native.info10
4 files changed, 138 insertions, 0 deletions
diff --git a/libraries/tomcat-native/README b/libraries/tomcat-native/README
new file mode 100644
index 0000000000..90e3599c48
--- /dev/null
+++ b/libraries/tomcat-native/README
@@ -0,0 +1,7 @@
+The Apache Tomcat Native Library is an optional component for use
+with Apache Tomcat that allows Tomcat to use certain native resources
+for performance, compatibility, etc.
+
+Specifically, the Apache Tomcat Native Library gives Tomcat access to
+the Apache Portable Runtime (APR) library's network connection
+(socket) implementation and random-number generator.
diff --git a/libraries/tomcat-native/slack-desc b/libraries/tomcat-native/slack-desc
new file mode 100644
index 0000000000..bd46fef557
--- /dev/null
+++ b/libraries/tomcat-native/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tomcat-native: tomcat-native (Apache Tomcat Component)
+tomcat-native:
+tomcat-native:
+tomcat-native: The Apache Tomcat Native Library is an optional component for use
+tomcat-native: with Apache Tomcat that allows Tomcat to use certain native resources
+tomcat-native: for performance, compatibility, etc.
+tomcat-native:
+tomcat-native: Specifically, the Apache Tomcat Native Library gives Tomcat access to
+tomcat-native: the Apache Portable Runtime (APR) library's network connection
+tomcat-native: (socket) implementation and random-number generator.
+tomcat-native:
diff --git a/libraries/tomcat-native/tomcat-native.SlackBuild b/libraries/tomcat-native/tomcat-native.SlackBuild
new file mode 100644
index 0000000000..53e564974f
--- /dev/null
+++ b/libraries/tomcat-native/tomcat-native.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# Slackware build script for tomcat-native
+
+# Copyright 2019 Thibaut Notteboom, Paris, FRANCE
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tomcat-native
+VERSION=${VERSION:-1.2.21}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-${VERSION}-src
+tar xvf $CWD/$PRGNAM-${VERSION}-src.tar.gz
+cd $PRGNAM-${VERSION}-src
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+(
+ cd "native"
+
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --with-java-home=$JAVA_HOME \
+ --with-apr=/usr \
+ --with-ssl=/usr \
+ --build=$ARCH-slackware-linux
+
+ make
+ make install DESTDIR=$PKG
+)
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.txt CMakeLists.txt LICENSE NOTICE README.txt TODO.txt docs/ \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/tomcat-native/tomcat-native.info b/libraries/tomcat-native/tomcat-native.info
new file mode 100644
index 0000000000..7709a0637d
--- /dev/null
+++ b/libraries/tomcat-native/tomcat-native.info
@@ -0,0 +1,10 @@
+PRGNAM="tomcat-native"
+VERSION="1.2.21"
+HOMEPAGE="https://tomcat.apache.org/native-doc/"
+DOWNLOAD="https://archive.apache.org/dist/tomcat/tomcat-connectors/native/1.2.21/source/tomcat-native-1.2.21-src.tar.gz"
+MD5SUM="6ca4e4c15e38bda426656cda5f3308c7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="adoptopenjdk"
+MAINTAINER="Thibaut Notteboom"
+EMAIL="thibaut.notteboom@gmail.com"