summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-25 00:00:23 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:15 +0700
commitbac49d8daed5a6d91ccb7f77b1110952188e611c (patch)
tree4a2924b0cfe092ed3f1c05715d4d9cb4a99ee765
parentc2950ca80e1668b2651768df7d42a43373f973f6 (diff)
downloadslackbuilds-bac49d8daed5a6d91ccb7f77b1110952188e611c.tar.gz
slackbuilds-bac49d8daed5a6d91ccb7f77b1110952188e611c.tar.xz
python/frosted: Switch to i586.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/frosted/frosted.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/python/frosted/frosted.SlackBuild b/python/frosted/frosted.SlackBuild
index 3ddd5f56b1..9527fe3fc0 100644
--- a/python/frosted/frosted.SlackBuild
+++ b/python/frosted/frosted.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for frosted
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +29,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG