summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2016-10-24 23:52:36 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-10-29 06:58:15 +0700
commitfa9eeaa91fcba8c58e51b207fbdc22b8c8ed7803 (patch)
tree9f7b766f9ce6cbe02b955b15d9f9b2301d8a8849
parentb63093126f4b5afb0d2b6a5dd5e2843b687d3d77 (diff)
downloadslackbuilds-fa9eeaa91fcba8c58e51b207fbdc22b8c8ed7803.tar.gz
slackbuilds-fa9eeaa91fcba8c58e51b207fbdc22b8c8ed7803.tar.xz
python/PyInstaller: Updated for version 3.2.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
-rw-r--r--python/PyInstaller/PyInstaller.SlackBuild12
-rw-r--r--python/PyInstaller/PyInstaller.info6
2 files changed, 9 insertions, 9 deletions
diff --git a/python/PyInstaller/PyInstaller.SlackBuild b/python/PyInstaller/PyInstaller.SlackBuild
index 2a86e3fa9f..04a2d6b8bd 100644
--- a/python/PyInstaller/PyInstaller.SlackBuild
+++ b/python/PyInstaller/PyInstaller.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for PyInstaller
-# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=PyInstaller
-VERSION=${VERSION:-2.1}
+VERSION=${VERSION:-3.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +40,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,7 +67,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
diff --git a/python/PyInstaller/PyInstaller.info b/python/PyInstaller/PyInstaller.info
index e221c87e0d..97cfd08c0e 100644
--- a/python/PyInstaller/PyInstaller.info
+++ b/python/PyInstaller/PyInstaller.info
@@ -1,8 +1,8 @@
PRGNAM="PyInstaller"
-VERSION="2.1"
+VERSION="3.2"
HOMEPAGE="http://www.pyinstaller.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/P/PyInstaller/PyInstaller-2.1.tar.gz"
-MD5SUM="248531f6fc94b0ffb02473321496d6d0"
+DOWNLOAD="https://pypi.python.org/packages/33/f9/034a89276301ef5e88efd11e5ea592e3d3b2324706e65bdff7445d271077/PyInstaller-3.2.tar.gz"
+MD5SUM="ad924928983014e6b8ce5422d7687832"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""