summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2016-12-16 22:14:04 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-17 01:18:29 +0700
commite9502cc5ac64f63be340859e06187d96de4c540d (patch)
tree735296c4bedca1a60c0488bd417d668e6f60f189
parent8ee0194cfd4fab0e4cadba25aba0c4510f6c32dd (diff)
downloadslackbuilds-e9502cc5ac64f63be340859e06187d96de4c540d.tar.gz
slackbuilds-e9502cc5ac64f63be340859e06187d96de4c540d.tar.xz
libraries/double-conversion: Added (binary<->decimal conversions).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/double-conversion/README12
-rw-r--r--libraries/double-conversion/double-conversion.SlackBuild98
-rw-r--r--libraries/double-conversion/double-conversion.info10
-rw-r--r--libraries/double-conversion/double-conversion.patch29
-rw-r--r--libraries/double-conversion/slack-desc19
5 files changed, 168 insertions, 0 deletions
diff --git a/libraries/double-conversion/README b/libraries/double-conversion/README
new file mode 100644
index 0000000000..2357add844
--- /dev/null
+++ b/libraries/double-conversion/README
@@ -0,0 +1,12 @@
+Efficient binary-decimal and decimal-binary conversion routines for
+IEEE doubles.
+
+The library consists of efficient conversion routines that have been
+extracted from the V8 JavaScript engine. The code has been refactored
+and improved so that it can be used more easily in other projects.
+
+There is extensive documentation in
+ double-conversion/double-conversion.h
+
+Other examples can be found in
+ test/cctest/test-conversions.cc
diff --git a/libraries/double-conversion/double-conversion.SlackBuild b/libraries/double-conversion/double-conversion.SlackBuild
new file mode 100644
index 0000000000..d7b288668a
--- /dev/null
+++ b/libraries/double-conversion/double-conversion.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for Google double-conversion
+
+# Copyright 2016 Andre Barboza, Belo Horizonte - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=double-conversion
+VERSION=${VERSION:-1.1.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/double-conversion.patch
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DINSTALL_CMAKE_DIR=/usr/lib${LIBDIRSUFFIX}/cmake \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ra AUTHORS COPYING LICENSE README Changelog test $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/double-conversion/double-conversion.info b/libraries/double-conversion/double-conversion.info
new file mode 100644
index 0000000000..b726b031e9
--- /dev/null
+++ b/libraries/double-conversion/double-conversion.info
@@ -0,0 +1,10 @@
+PRGNAM="double-conversion"
+VERSION="1.1.5"
+HOMEPAGE="https://github.com/google/double-conversion/"
+DOWNLOAD="https://github.com/google/double-conversion/archive/v1.1.5/double-conversion-1.1.5.tar.gz"
+MD5SUM="f7c62594d7ecfbc4421da32bc341a919"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
diff --git a/libraries/double-conversion/double-conversion.patch b/libraries/double-conversion/double-conversion.patch
new file mode 100644
index 0000000000..5c57bcb814
--- /dev/null
+++ b/libraries/double-conversion/double-conversion.patch
@@ -0,0 +1,29 @@
+diff -ur double-conversion-1.1.5.old/CMakeLists.txt double-conversion-1.1.5/CMakeLists.txt
+--- double-conversion-1.1.5.old/CMakeLists.txt 2016-12-12 20:35:31.150277793 -0200
++++ double-conversion-1.1.5/CMakeLists.txt 2016-12-12 20:55:00.341337905 -0200
+@@ -10,12 +10,6 @@
+ set(INSTALL_BIN_DIR CACHE PATH "Installation directory for libraries")
+ set(INSTALL_LIB_DIR CACHE PATH "Installation directory for libraries")
+ set(INSTALL_INCLUDE_DIR CACHE PATH "Installation directory for include")
+-# set suffix for CMake files used for packaging
+-if(WIN32 AND NOT CYGWIN)
+- set(INSTALL_CMAKE_DIR CMake)
+-else()
+- set(INSTALL_CMAKE_DIR lib/CMake/double-conversion)
+-endif()
+
+ # Make relative paths absolute (needed later)
+ foreach(p LIB BIN INCLUDE CMAKE)
+diff -ur double-conversion-1.1.5.old/src/CMakeLists.txt double-conversion-1.1.5/src/CMakeLists.txt
+--- double-conversion-1.1.5.old/src/CMakeLists.txt 2016-12-12 20:35:31.151277793 -0200
++++ double-conversion-1.1.5/src/CMakeLists.txt 2016-12-12 21:13:30.683045433 -0200
+@@ -36,7 +36,7 @@
+ install(TARGETS double-conversion
+ EXPORT double-conversionLibraryDepends
+ RUNTIME DESTINATION "${INSTALL_BIN_DIR}" COMPONENT bin
+- LIBRARY DESTINATION "${INSTALL_LIB_DIR}/lib" COMPONENT shlib
+- ARCHIVE DESTINATION "${INSTALL_LIB_DIR}/lib" COMPONENT lib
++ LIBRARY DESTINATION "${INSTALL_LIB_DIR}/lib${LIB_SUFFIX}" COMPONENT shlib
++ ARCHIVE DESTINATION "${INSTALL_LIB_DIR}/lib${LIB_SUFFIX}" COMPONENT lib
+ PUBLIC_HEADER DESTINATION "${INSTALL_INCLUDE_DIR}/include/double-conversion"
+ COMPONENT dev)
diff --git a/libraries/double-conversion/slack-desc b/libraries/double-conversion/slack-desc
new file mode 100644
index 0000000000..03ad1cb845
--- /dev/null
+++ b/libraries/double-conversion/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+double-conversion: double-conversion (Efficient binary<->decimal double conversions)
+double-conversion:
+double-conversion: This project provides binary-decimal and decimal-binary routines for
+double-conversion: IEEE doubles.
+double-conversion: The library consists of efficient conversion routines that have been
+double-conversion: extracted from the V8 JavaScript engine. The code has been refactored
+double-conversion: and improved so that it can be used more easily in other projects.
+double-conversion:
+double-conversion:
+double-conversion: https://github.com/google/double-conversion/
+double-conversion: