summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Erik Falor <ewfalor@gmail.com>2013-04-23 20:47:16 -0400
committer Niels Horn <niels.horn@slackbuilds.org>2013-04-28 12:28:11 -0300
commita7123908de9c3623c13a9c5b6a975e32f63b3328 (patch)
tree0f38550aa9f5f51b9060d4261fe077a4cf31da4b
parenta5978813a811c429f5e32405d8fd1a2738a1ca45 (diff)
downloadslackbuilds-a7123908de9c3623c13a9c5b6a975e32f63b3328.tar.gz
slackbuilds-a7123908de9c3623c13a9c5b6a975e32f63b3328.tar.xz
games/redeclipse: Updated for version 1.4.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
-rw-r--r--games/redeclipse/Makefile.patch60
-rw-r--r--games/redeclipse/redeclipse.SlackBuild14
-rw-r--r--games/redeclipse/redeclipse.info6
-rw-r--r--games/redeclipse/slack-desc2
4 files changed, 48 insertions, 34 deletions
diff --git a/games/redeclipse/Makefile.patch b/games/redeclipse/Makefile.patch
index afb6063328..6036f5844a 100644
--- a/games/redeclipse/Makefile.patch
+++ b/games/redeclipse/Makefile.patch
@@ -1,23 +1,28 @@
---- Makefile.orig 2012-08-30 23:59:06.000000000 -0600
-+++ Makefile 2012-12-24 13:15:46.139736132 -0700
-@@ -1,9 +1,10 @@
+--- Makefile.orig 2013-03-22 02:27:41.000000000 -0600
++++ Makefile 2013-04-03 13:52:08.721896778 -0600
+@@ -1,4 +1,5 @@
APPNAME=redeclipse
-+VERSION=@VERSION@
- APPCLIENT=reclient
- APPSERVER=reserver
++VERSION=1.4
+
+ all:
+
+--- core.mk.orig 2013-03-21 13:45:14.000000000 -0600
++++ core.mk 2013-04-03 13:52:08.723896754 -0600
+@@ -3,7 +3,7 @@
+ APPSERVER=$(APPNAME)_server
#CXXFLAGS= -ggdb3
-CXXFLAGS= -O3 -fomit-frame-pointer
-+CXXFLAGS= $(EXTRA_CXXFLAGS) -fomit-frame-pointer
++CXXFLAGS=$(EXTRA_CXXFLAGS) -fomit-frame-pointer
override CXXFLAGS+= -Wall -fsigned-char -fno-exceptions -fno-rtti
PLATFORM= $(shell uname -s)
---- system-install.mk.orig 2012-08-13 04:51:04.000000000 -0600
-+++ system-install.mk 2012-12-24 13:39:56.896599172 -0700
-@@ -3,15 +3,15 @@
- cappname=$(shell echo $(appname) | tr '[:lower:]' '[:upper:]')# Captial appname
- appclient=$(APPCLIENT)
+--- system-install.mk.orig 2013-03-20 16:21:57.000000000 -0600
++++ system-install.mk 2013-04-03 22:44:56.979810436 -0600
+@@ -6,15 +6,15 @@
appserver=$(APPSERVER)
+ appgamedir=game/$(APPSHORTNAME)
+
-prefix=/usr/local
+prefix=/usr
games=
@@ -28,14 +33,14 @@
-datadir=$(DESTDIR)$(prefix)/share$(games)
-docdir=$(DESTDIR)$(prefix)/share/doc
-mandir=$(DESTDIR)$(prefix)/share/man
-+libexecdir=$(DESTDIR)$(prefix)/libexec
-+datadir=$(DESTDIR)$(prefix)/share/games/$(appname)
++libexecdir=$(DESTDIR)$(prefix)/share/$(appname)-$(VERSION)/lib
++datadir=$(DESTDIR)$(prefix)/share/$(appname)-$(VERSION)
+docdir=$(DESTDIR)$(prefix)/doc/$(appname)-$(VERSION)
+mandir=$(DESTDIR)$(prefix)/man
menudir=$(DESTDIR)$(prefix)/share/applications
icondir=$(DESTDIR)$(prefix)/share/icons/hicolor
pixmapdir=$(DESTDIR)$(prefix)/share/pixmaps
-@@ -45,55 +45,55 @@
+@@ -54,62 +54,62 @@
icons: $(ICONS)
system-install-client: client
@@ -54,15 +59,19 @@
+ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
-e 's,@APPNAME@,$(appname),g' \
-i $(gamesbindir)/$(appname)
-- ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/$(appname)/data \
+ ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/$(appname)/data \
- $(libexecdir)/$(appname)/data
-+ ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/data \
+ $(libexecdir)/data
+ ln -s $(patsubst $(DESTDIR)%,%,$(datadir))/$(appname)/game \
+- $(libexecdir)/$(appname)/game
++ $(libexecdir)/game
system-install-server: server
- install -d $(libexecdir)/$(appname)
+ install -d $(libexecdir)
install -d $(gamesbindir)
+- install -d $(datadir)/$(appname)
++ install -d $(datadir)
install -m755 $(appserver) \
- $(libexecdir)/$(appname)/$(appname)-server
+ $(libexecdir)/$(appname)-server
@@ -76,20 +85,26 @@
+ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
-e 's,@APPNAME@,$(appname),g' \
-i $(gamesbindir)/$(appname)-server
+ install -m644 ../$(appgamedir)/version.cfg \
+- $(datadir)/$(appname)/version.cfg
++ $(datadir)/version.cfg
system-install-data:
- install -d $(datadir)/$(appname)
+- install -d $(datadir)/$(appname)/game
- cp -r ../data $(datadir)/$(appname)/data
+- cp -r ../$(appgamedir) $(datadir)/$(appname)/game
+ install -d $(datadir)
++ install -d $(datadir)/game
+ cp -r ../data $(datadir)/data
++ cp -r ../$(appgamedir) $(datadir)/game
system-install-docs: $(MANPAGES)
install -d $(mandir)/man6
-- install -d $(docdir)/$(appname)
+ install -d $(docdir)/$(appname)
- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
-+ install -d $(docdir)
+ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
+ -e 's,@DATADIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
@@ -114,14 +129,15 @@
system-install-menus: icons
install -d $(menudir)
-@@ -103,9 +103,9 @@
+@@ -119,9 +119,9 @@
install -d $(icondir)/64x64/apps
install -d $(icondir)/128x128/apps
install -d $(pixmapdir)
- sed -e 's,@LIBEXECDIR@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
-+ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+- -e 's,@DATADIR@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
- -e 's,@DOCDIR@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
++ sed -e 's,@LIBEXECDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(libexecdir)),g' \
++ -e 's,@DATADIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(datadir)),g' \
+ -e 's,@DOCDIR@/@APPNAME@,$(patsubst $(DESTDIR)%,%,$(docdir)),g' \
-e 's,@APPNAME@,$(appname),g' \
install/nix/$(appsrcname).desktop.am > \
diff --git a/games/redeclipse/redeclipse.SlackBuild b/games/redeclipse/redeclipse.SlackBuild
index 5ea869cdec..ceaa94ca5d 100644
--- a/games/redeclipse/redeclipse.SlackBuild
+++ b/games/redeclipse/redeclipse.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Red Eclipse
-# Copyright 2012 Erik Falor USA
+# Copyright 2013 Erik Falor USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=redeclipse
-VERSION=${VERSION:-1.3.1}
+VERSION=${VERSION:-1.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -61,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/${PRGNAM}_${VERSION}_nix_bsd.tar.bz2
-cd $PRGNAM
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${VERSION}_nix.tar.bz2
+cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -72,7 +70,7 @@ find . \
-exec chmod 644 {} \;
# remove the pre-built binaries
-rm -f bin/* bin64/*
+rm -rf bin/*
# Compile the application using custom SLKCFLAGS
(
diff --git a/games/redeclipse/redeclipse.info b/games/redeclipse/redeclipse.info
index c871263ffe..29a7d4f396 100644
--- a/games/redeclipse/redeclipse.info
+++ b/games/redeclipse/redeclipse.info
@@ -1,8 +1,8 @@
PRGNAM="redeclipse"
-VERSION="1.3.1"
+VERSION="1.4"
HOMEPAGE="http://www.redeclipse.net"
-DOWNLOAD="http://downloads.sourceforge.net/redeclipse/redeclipse_1.3.1_nix_bsd.tar.bz2"
-MD5SUM="7b320932965e61bf14ad115ac6f6e94b"
+DOWNLOAD="http://downloads.sourceforge.net/redeclipse/redeclipse_1.4_nix.tar.bz2"
+MD5SUM="3d478f5cf4838adcf5cde8d3421f2ffe"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/games/redeclipse/slack-desc b/games/redeclipse/slack-desc
index ca83c5becb..1d8f5ed75a 100644
--- a/games/redeclipse/slack-desc
+++ b/games/redeclipse/slack-desc
@@ -12,7 +12,7 @@ redeclipse: Red Eclipse is a single-player and multi-player first-person
redeclipse: ego-shooter, built as a total conversion of Cube Engine 2, which lends
redeclipse: itself toward a balanced gameplay, completely at the control of map
redeclipse: makers, while maintaining a general theme of agility in a variety of
-redeclipse: environments.
+redeclipse: environments.
redeclipse: This package is a re-build rather than a re-packaging of the
redeclipse: Red Eclipse release, respecting your custom SLKCFLAGS.
redeclipse: