summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Nikos Giotis <nikos.giotis@gmail.com>2017-03-05 09:29:35 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-03-05 09:30:23 +0700
commitf8cb5330cb6bf36ba168a9d61900dccb358b2c70 (patch)
treea192fa84cf7ce61adc2b3889c5dfe203ae418f04
parent255df1ea92ba388a73296bfdc4580016102cf7dd (diff)
downloadslackbuilds-f8cb5330cb6bf36ba168a9d61900dccb358b2c70.tar.gz
slackbuilds-f8cb5330cb6bf36ba168a9d61900dccb358b2c70.tar.xz
python/testtools: Added (Python unit testing framework extension).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/testtools/README5
-rw-r--r--python/testtools/slack-desc19
-rw-r--r--python/testtools/testtools.SlackBuild85
-rw-r--r--python/testtools/testtools.info10
4 files changed, 119 insertions, 0 deletions
diff --git a/python/testtools/README b/python/testtools/README
new file mode 100644
index 0000000000..40d1fafe3f
--- /dev/null
+++ b/python/testtools/README
@@ -0,0 +1,5 @@
+Extensions to the Python standard library unit testing framework
+
+testtools is a set of extensions to the Python standard library’s unit
+testing framework. These extensions have been derived from many years of
+experience with unit testing in Python and come from many different sources.
diff --git a/python/testtools/slack-desc b/python/testtools/slack-desc
new file mode 100644
index 0000000000..b09cb7eb2e
--- /dev/null
+++ b/python/testtools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+testtools: testtools (Extensions to the Python unit testing framework)
+testtools:
+testtools: testtools is a set of extensions to the Python standard library’s
+testtools: unit testing framework. These extensions have been derived from many
+testtools: years of experience with unit testing in Python and come from many
+testtools: different sources.
+testtools:
+testtools: https://github.com/testing-cabal/testtools
+testtools:
+testtools:
+testtools:
diff --git a/python/testtools/testtools.SlackBuild b/python/testtools/testtools.SlackBuild
new file mode 100644
index 0000000000..54e4b13877
--- /dev/null
+++ b/python/testtools/testtools.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for testtools
+
+# Copyright 2017 Nikos Giotis <nikos.giotis@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=testtools
+VERSION=${VERSION:-2.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE NEWS README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/testtools/testtools.info b/python/testtools/testtools.info
new file mode 100644
index 0000000000..13ba86f843
--- /dev/null
+++ b/python/testtools/testtools.info
@@ -0,0 +1,10 @@
+PRGNAM="testtools"
+VERSION="2.2.0"
+HOMEPAGE="https://github.com/testing-cabal/testtools"
+DOWNLOAD="https://pypi.python.org/packages/0d/72/3212c1723d49f5b58fca736dabdd2e74f38435076d943f4a642117f04d65/testtools-2.2.0.tar.gz"
+MD5SUM="adef817b07ba24fd6d807fd41a4f1ef4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pbr extras python-mimeparse traceback2 six"
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"