summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2017-06-04 10:30:04 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-06 07:56:43 +0700
commit06735c91626f488bf089329871e851a02f08b8d0 (patch)
treecff1dc3c45f6e0cc6423b040d89bd2cd5b697635
parentbfe4ac492b868fdd85f3e514134f04428f29a646 (diff)
downloadslackbuilds-06735c91626f488bf089329871e851a02f08b8d0.tar.gz
slackbuilds-06735c91626f488bf089329871e851a02f08b8d0.tar.xz
python/netifaces: Updated for version 0.10.6
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
-rw-r--r--python/netifaces/README6
-rw-r--r--python/netifaces/netifaces.SlackBuild8
-rw-r--r--python/netifaces/netifaces.info6
3 files changed, 15 insertions, 5 deletions
diff --git a/python/netifaces/README b/python/netifaces/README
index 008cffeaeb..a31609c93e 100644
--- a/python/netifaces/README
+++ b/python/netifaces/README
@@ -1 +1,7 @@
Portable module to access network interface information in Python.
+
+Optional dependencies: python3 and Sphinx
+
+Note: To install python3 bindings pass PYTHON3=yes to the slackbuild.
+
+ # PYTHON3=yes ./six.SlackBuild
diff --git a/python/netifaces/netifaces.SlackBuild b/python/netifaces/netifaces.SlackBuild
index 60acb41e48..0e9626f9bf 100644
--- a/python/netifaces/netifaces.SlackBuild
+++ b/python/netifaces/netifaces.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for netifaces
-# Copyright 2012-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2012-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=netifaces
-VERSION=${VERSION:-0.10.5}
+VERSION=${VERSION:-0.10.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -57,6 +57,10 @@ find -L . \
python setup.py install --root=$PKG
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/netifaces/netifaces.info b/python/netifaces/netifaces.info
index 36b7502c39..c649f4a22b 100644
--- a/python/netifaces/netifaces.info
+++ b/python/netifaces/netifaces.info
@@ -1,8 +1,8 @@
PRGNAM="netifaces"
-VERSION="0.10.5"
+VERSION="0.10.6"
HOMEPAGE="https://alastairs-place.net/projects/netifaces/"
-DOWNLOAD="https://pypi.io/packages/source/n/netifaces/netifaces-0.10.5.tar.gz"
-MD5SUM="5b4d1f1310ed279e6df27ef3a9b71519"
+DOWNLOAD="https://pypi.io/packages/source/n/netifaces/netifaces-0.10.6.tar.gz"
+MD5SUM="1d424cb5ef52907c5ab913011122a98b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""