summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons <andrew.clemons@gmail.com>2017-06-07 11:43:57 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-06-10 10:47:39 +0700
commitd72f714c4d1fca8b1d89c15788d550019c13b452 (patch)
tree79204b80f205b6996c46d255c8dfbd32fdb76771
parentb5b39a32a65d672b7d62be805c7a681d85e0301b (diff)
downloadslackbuilds-d72f714c4d1fca8b1d89c15788d550019c13b452.tar.gz
slackbuilds-d72f714c4d1fca8b1d89c15788d550019c13b452.tar.xz
system/fzf: Updated for version 0.16.8.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--system/fzf/README8
-rw-r--r--system/fzf/fzf.SlackBuild106
-rw-r--r--system/fzf/fzf.info32
3 files changed, 46 insertions, 100 deletions
diff --git a/system/fzf/README b/system/fzf/README
index d406de9de1..0844dad791 100644
--- a/system/fzf/README
+++ b/system/fzf/README
@@ -1,13 +1,5 @@
fzf - A command-line fuzzy finder written in Go
-If you'd like to build with the tcell support (24bit colour support),
-default no:
-
-WITH_TCELL=yes ./fzf.SlackBuild
-
-Please note the caveats mentioned here:
-https://github.com/junegunn/fzf/blob/master/BUILD.md#with-tcell
-
Vim Users: A fzf.vim plugin is installed to
/usr/share/vim/vimfiles/plugin. If you'd rather exclude the plugin,
or only manually enable it in your vim, you can build with:
diff --git a/system/fzf/fzf.SlackBuild b/system/fzf/fzf.SlackBuild
index fd1b61f60d..a701fec0c8 100644
--- a/system/fzf/fzf.SlackBuild
+++ b/system/fzf/fzf.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fzf
-VERSION=${VERSION:-0.16.7}
+VERSION=${VERSION:-0.16.8}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,74 +49,37 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-sed -i 's/cd \$(SRCDIR) && go get/cd \$(SRCDIR)/' src/Makefile
-sed -i '/\.\/deps/d' src/Makefile
+sed -i '/glide install/d' Makefile
-mkdir -p gopath/src/github.com/junegunn/
+mkdir -p vendor/github.com
-for DEPENDENCY in go-shellwords-02e3cf038dcea8290e44424da473dd12be796a8a \
- go-runewidth-14207d285c6c197daabb5c9793d63e7af9ab2d50 \
- go-isatty-66b8e73f3f5cda9f96b69efd03dd3d7fc4a5cdb8 ; do
- DEPENDENCY_NAME="$(echo "$DEPENDENCY" | rev | cut -d- -f2- | rev)"
+for DEPENDENCY in gdamore/encoding/b23993cbb6353f0e6aa98d0ee318a34728f628b9 \
+ gdamore/tcell/44772c121bb7838819d3ba4a7e84c0c2d617328e \
+ lucasb-eyer/go-colorful/c900de9dbbc73129068f5af6a823068fc5f2308c \
+ mattn/go-isatty/66b8e73f3f5cda9f96b69efd03dd3d7fc4a5cdb8 \
+ mattn/go-runewidth/14207d285c6c197daabb5c9793d63e7af9ab2d50 \
+ mattn/go-shellwords/02e3cf038dcea8290e44424da473dd12be796a8a ; do
+ DEPENDENCY_OWNER="$(echo "$DEPENDENCY" | cut -d/ -f1)"
+ DEPENDENCY_NAME="$(echo "$DEPENDENCY" | cut -d/ -f2)"
+ DEPENDENCY_REV="$(echo "$DEPENDENCY" | cut -d/ -f3)"
- tar xf $CWD/$DEPENDENCY.tar.gz
- mv $DEPENDENCY gopath/src/github.com/junegunn/$DEPENDENCY_NAME
+mkdir -p vendor/github.com/$DEPENDENCY_OWNER
+
+ tar xf $CWD/$DEPENDENCY_NAME-$DEPENDENCY_REV.tar.gz
+ mv $DEPENDENCY_NAME-$DEPENDENCY_REV vendor/github.com/$DEPENDENCY_OWNER/$DEPENDENCY_NAME
done
-mkdir -p gopath/src/golang.org/x
-for DEPENDENCY in crypto-abc5fa7ad02123a41f02bf1391c9760f7586e608 ; do
- DEPENDENCY_NAME="$(echo "$DEPENDENCY" | rev | cut -d- -f2- | rev)"
+mkdir -p vendor/golang.org/x
+for DEPENDENCY in crypto/e1a4589e7d3ea14a3352255d04b6f1a418845e5e \
+ sys/b90f89a1e7a9c1f6b918820b3daa7f08488c8594 \
+ text/4ee4af566555f5fbe026368b75596286a312663a ; do
+ DEPENDENCY_NAME="$(echo "$DEPENDENCY" | cut -d/ -f1)"
+ DEPENDENCY_REV="$(echo "$DEPENDENCY" | cut -d/ -f2)"
- tar xf $CWD/$DEPENDENCY.tar.gz
- mv $DEPENDENCY gopath/src/golang.org/x/$DEPENDENCY_NAME
+ tar xf $CWD/$DEPENDENCY_NAME-$DEPENDENCY_REV.tar.gz
+ mv $DEPENDENCY_NAME-$DEPENDENCY_REV vendor/golang.org/x/$DEPENDENCY_NAME
done
-if [ "$WITH_TCELL" != "yes" ] ; then :
-else
- for DEPENDENCY in tcell-44772c121bb7838819d3ba4a7e84c0c2d617328e ; do
- DEPENDENCY_NAME="$(echo "$DEPENDENCY" | rev | cut -d- -f2- | rev)"
-
- tar xf $CWD/$DEPENDENCY.tar.gz
- mv $DEPENDENCY gopath/src/github.com/junegunn/$DEPENDENCY_NAME
- done
-
- mkdir gopath/src/github.com/mattn
- (
- cd gopath/src/github.com/mattn
- ln -s ../junegunn/go-runewidth .
- )
-
- mkdir gopath/src/github.com/gdamore
- (
- cd gopath/src/github.com/gdamore
- ln -s ../junegunn/tcell .
- )
-
- mkdir -p gopath/src/github.com/gdamore
- for DEPENDENCY in encoding-b23993cbb6353f0e6aa98d0ee318a34728f628b9 ; do
- DEPENDENCY_NAME="$(echo "$DEPENDENCY" | rev | cut -d- -f2- | rev)"
-
- tar xf $CWD/$DEPENDENCY.tar.gz
- mv $DEPENDENCY gopath/src/github.com/gdamore/$DEPENDENCY_NAME
- done
-
- mkdir -p gopath/src/github.com/lucasb-eyer
- for DEPENDENCY in go-colorful-c900de9dbbc73129068f5af6a823068fc5f2308c ; do
- DEPENDENCY_NAME="$(echo "$DEPENDENCY" | rev | cut -d- -f2- | rev)"
-
- tar xf $CWD/$DEPENDENCY.tar.gz
- mv $DEPENDENCY gopath/src/github.com/lucasb-eyer/$DEPENDENCY_NAME
- done
-
- mkdir -p gopath/src/golang.org/x
- for DEPENDENCY in text-470f45bf29f4147d6fbd7dfd0a02a848e49f5bf4 ; do
- DEPENDENCY_NAME="$(echo "$DEPENDENCY" | rev | cut -d- -f2- | rev)"
-
- tar xf $CWD/$DEPENDENCY.tar.gz
- mv $DEPENDENCY gopath/src/golang.org/x/$DEPENDENCY_NAME
- done
-fi
-
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -124,17 +87,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-FZF_TAGS=tcell
-[ "$WITH_TCELL" != "yes" ] && FZF_TAGS=""
-
-(
- cd src
- TAGS="$FZF_TAGS" make
-
- mkdir -p $PKG/usr/bin
- install -m 0755 fzf/fzf-linux_* $PKG/usr/bin/fzf
-)
+make
+mkdir -p $PKG/usr/bin
+install -m 0755 target/fzf-linux_* $PKG/usr/bin/fzf
install -m 0755 bin/fzf-tmux $PKG/usr/bin/fzf-tmux
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -152,16 +108,13 @@ install -m 0644 shell/completion.bash $PKG/usr/share/bash-completion/completions
mkdir -p $PKG/usr/share/zsh/site-functions/
install -m 0644 shell/completion.zsh $PKG/usr/share/zsh/site-functions/_fzf
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/go
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- CHANGELOG.md LICENSE README.md shell/key-bindings.zsh shell/key-bindings.bash \
+ BUILD.md CHANGELOG.md LICENSE README-VIM.md README.md shell/key-bindings.zsh shell/key-bindings.bash \
$PKG/usr/doc/$PRGNAM-$VERSION
chmod 0755 $PKG/usr/doc/$PRGNAM-$VERSION/key-bindings.*
-cp -a \
- src/README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION/go
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
WITH_VIM=${WITH_VIM:-yes}
@@ -177,4 +130,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/system/fzf/fzf.info b/system/fzf/fzf.info
index 66e71ab0b4..6fccfb3fdb 100644
--- a/system/fzf/fzf.info
+++ b/system/fzf/fzf.info
@@ -1,24 +1,26 @@
PRGNAM="fzf"
-VERSION="0.16.7"
+VERSION="0.16.8"
HOMEPAGE="https://github.com/junegunn/fzf"
-DOWNLOAD="https://github.com/junegunn/fzf/archive/0.16.7/fzf-0.16.7.tar.gz \
- https://github.com/junegunn/go-shellwords/archive/02e3cf038dcea8290e44424da473dd12be796a8a/go-shellwords-02e3cf038dcea8290e44424da473dd12be796a8a.tar.gz \
- https://github.com/junegunn/go-runewidth/archive/14207d285c6c197daabb5c9793d63e7af9ab2d50/go-runewidth-14207d285c6c197daabb5c9793d63e7af9ab2d50.tar.gz \
- https://github.com/junegunn/go-isatty/archive/66b8e73f3f5cda9f96b69efd03dd3d7fc4a5cdb8/go-isatty-66b8e73f3f5cda9f96b69efd03dd3d7fc4a5cdb8.tar.gz \
- https://github.com/junegunn/tcell/archive/44772c121bb7838819d3ba4a7e84c0c2d617328e/tcell-44772c121bb7838819d3ba4a7e84c0c2d617328e.tar.gz \
+DOWNLOAD="https://github.com/junegunn/fzf/archive/0.16.8/fzf-0.16.8.tar.gz \
https://github.com/gdamore/encoding/archive/b23993cbb6353f0e6aa98d0ee318a34728f628b9/encoding-b23993cbb6353f0e6aa98d0ee318a34728f628b9.tar.gz \
+ https://github.com/gdamore/tcell/archive/44772c121bb7838819d3ba4a7e84c0c2d617328e/tcell-44772c121bb7838819d3ba4a7e84c0c2d617328e.tar.gz \
https://github.com/lucasb-eyer/go-colorful/archive/c900de9dbbc73129068f5af6a823068fc5f2308c/go-colorful-c900de9dbbc73129068f5af6a823068fc5f2308c.tar.gz \
- https://github.com/golang/text/archive/470f45bf29f4147d6fbd7dfd0a02a848e49f5bf4/text-470f45bf29f4147d6fbd7dfd0a02a848e49f5bf4.tar.gz \
- https://github.com/golang/crypto/archive/abc5fa7ad02123a41f02bf1391c9760f7586e608/crypto-abc5fa7ad02123a41f02bf1391c9760f7586e608.tar.gz"
-MD5SUM="2ef2afe236224beb7c9c4b175878c68b \
- 80447b1055e248f7273e7ef45521534d \
- cc482b237c1812152afd973b52f40852 \
- e15b95057201799f455982ce76ff7041 \
- 3995f7a041908df543293240d0c15b57 \
+ https://github.com/mattn/go-isatty/archive/66b8e73f3f5cda9f96b69efd03dd3d7fc4a5cdb8/go-isatty-66b8e73f3f5cda9f96b69efd03dd3d7fc4a5cdb8.tar.gz \
+ https://github.com/mattn/go-runewidth/archive/14207d285c6c197daabb5c9793d63e7af9ab2d50/go-runewidth-14207d285c6c197daabb5c9793d63e7af9ab2d50.tar.gz \
+ https://github.com/mattn/go-shellwords/archive/02e3cf038dcea8290e44424da473dd12be796a8a/go-shellwords-02e3cf038dcea8290e44424da473dd12be796a8a.tar.gz \
+ https://github.com/golang/crypto/archive/e1a4589e7d3ea14a3352255d04b6f1a418845e5e/crypto-e1a4589e7d3ea14a3352255d04b6f1a418845e5e.tar.gz \
+ https://github.com/golang/sys/archive/b90f89a1e7a9c1f6b918820b3daa7f08488c8594/sys-b90f89a1e7a9c1f6b918820b3daa7f08488c8594.tar.gz \
+ https://github.com/golang/text/archive/4ee4af566555f5fbe026368b75596286a312663a/text-4ee4af566555f5fbe026368b75596286a312663a.tar.gz"
+MD5SUM="d3333478abf17daa151d6700691f9d5b \
4c6fb2d95929b35e44788924edc56649 \
+ 3995f7a041908df543293240d0c15b57 \
ae47671585a14b145b3edd83b2240019 \
- 944b1c3deab6f421b541c5040644dec6\
- 49c396491b02386d1d31fda0adeafb4f"
+ e15b95057201799f455982ce76ff7041 \
+ cc482b237c1812152afd973b52f40852 \
+ 80447b1055e248f7273e7ef45521534d \
+ c31fd9423cd0e96632628226d2f36a05 \
+ 34a1e1f3baa7e0b733272fe81e1bf3e9 \
+ cc2a01a744b1d2eb588f213db4bf4485"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="google-go-lang"