summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyat>2019-01-24 20:42:11 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-01-25 12:11:00 +0700
commit28c825b2f23a7853a8e07d740fd3f50c3fba0ee1 (patch)
tree378e073c638a449b597df30367692a3595eaa154
parentc1bc1a4e1b9d7bd5341001ce1ccb755cb79fcd0f (diff)
downloadslackbuilds-28c825b2f23a7853a8e07d740fd3f50c3fba0ee1.tar.gz
slackbuilds-28c825b2f23a7853a8e07d740fd3f50c3fba0ee1.tar.xz
python/elasticsearch5: Added (python client for Elasticsearch).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/elasticsearch5/README14
-rw-r--r--python/elasticsearch5/elasticsearch5.SlackBuild87
-rw-r--r--python/elasticsearch5/elasticsearch5.info10
-rw-r--r--python/elasticsearch5/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/python/elasticsearch5/README b/python/elasticsearch5/README
new file mode 100644
index 0000000000..764ed59f2d
--- /dev/null
+++ b/python/elasticsearch5/README
@@ -0,0 +1,14 @@
+elasticsearch5 (Official low level python client for Elasticsearch)
+
+Official low-level client for Elasticsearch.
+Its goal is to provide common ground for all Elasticsearch-related
+code in Python; because of this it tries to be opinion-free and very extendable.
+
+It provides a more convenient and idiomatic way to write and manipulate
+queries. It stays close to the Elasticsearch JSON DSL, mirroring its
+terminology and structure while exposing the whole range of the DSL from Python
+either directly using defined classes or a queryset-like expressions.
+
+It also provides an optional persistence layer for working with documents as
+Python objects in an ORM-like fashion: defining mappings, retrieving and saving
+documents, wrapping the document data in user-defined classes.
diff --git a/python/elasticsearch5/elasticsearch5.SlackBuild b/python/elasticsearch5/elasticsearch5.SlackBuild
new file mode 100644
index 0000000000..401295e732
--- /dev/null
+++ b/python/elasticsearch5/elasticsearch5.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for elasticsearch5
+
+# Copyright 2019, Barry J. Grundy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial submission, version 5.5.5 Jan 2019
+
+PRGNAM=elasticsearch5
+VERSION=${VERSION:-5.5.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE PKG-INFO README docs/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/elasticsearch5/elasticsearch5.info b/python/elasticsearch5/elasticsearch5.info
new file mode 100644
index 0000000000..efaf0c0d7b
--- /dev/null
+++ b/python/elasticsearch5/elasticsearch5.info
@@ -0,0 +1,10 @@
+PRGNAM="elasticsearch5"
+VERSION="5.5.5"
+HOMEPAGE="https://github.com/elastic/elasticsearch-py"
+DOWNLOAD="https://files.pythonhosted.org/packages/ba/e1/f155aeb593f3ee18e35aa17194a6c7794b61ccb00d1542322724e1f95701/elasticsearch5-5.5.5.tar.gz"
+MD5SUM="6ae364c6e1a3186dc03e0a119e95ef50"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-urllib3"
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/elasticsearch5/slack-desc b/python/elasticsearch5/slack-desc
new file mode 100644
index 0000000000..79eebfa775
--- /dev/null
+++ b/python/elasticsearch5/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+elasticsearch5: elasticsearch5 (python client for Elasticsearch)
+elasticsearch5:
+elasticsearch5: Official low-level client for Elasticsearch.
+elasticsearch5:
+elasticsearch5: https://github.com/elastic/elasticsearch-py
+elasticsearch5:
+elasticsearch5:
+elasticsearch5:
+elasticsearch5:
+elasticsearch5:
+elasticsearch5: