summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Bogdan Radulescu <bogdan@nimblex.net>2019-01-24 18:18:30 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-01-24 18:18:30 +0700
commita5f3eb5226abd848cd1fd1d0c1bb4c160931cc57 (patch)
tree9526f191767121340123d03939e9b8001b73d3f4
parentfcb5d5ddde1c9bfaa68ff69ad1338b8b849720d9 (diff)
downloadslackbuilds-a5f3eb5226abd848cd1fd1d0c1bb4c160931cc57.tar.gz
slackbuilds-a5f3eb5226abd848cd1fd1d0c1bb4c160931cc57.tar.xz
python/pbr: Updated for version 5.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/pbr/pbr.SlackBuild10
-rw-r--r--python/pbr/pbr.info6
2 files changed, 8 insertions, 8 deletions
diff --git a/python/pbr/pbr.SlackBuild b/python/pbr/pbr.SlackBuild
index b0165bd457..3dd6193357 100644
--- a/python/pbr/pbr.SlackBuild
+++ b/python/pbr/pbr.SlackBuild
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pbr
-VERSION=${VERSION:-3.1.1}
+VERSION=${VERSION:-5.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i586 ;;
+ i?86) ARCH=i686 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -67,12 +67,12 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
diff --git a/python/pbr/pbr.info b/python/pbr/pbr.info
index 28478b1320..838072f2e0 100644
--- a/python/pbr/pbr.info
+++ b/python/pbr/pbr.info
@@ -1,8 +1,8 @@
PRGNAM="pbr"
-VERSION="3.1.1"
+VERSION="5.1.1"
HOMEPAGE="https://pypi.python.org/pypi/pbr"
-DOWNLOAD="https://pypi.python.org/packages/d5/d6/f2bf137d71e4f213b575faa9eb426a8775732432edb67588a8ee836ecb80/pbr-3.1.1.tar.gz"
-MD5SUM="4e82c2e07af544c56a5b71c801525b00"
+DOWNLOAD="https://files.pythonhosted.org/packages/33/07/6e68a96ff240a0e7bb1f6e21093532386a98a82d56512e1e3da6d125f7aa/pbr-5.1.1.tar.gz"
+MD5SUM="dbc94417a8ff0432d6244501a7f1bd49"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""