summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-06-07 05:30:13 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-09 05:33:16 +0700
commit24413e5cdcde81e9ad22d29d5bf2f273c076430f (patch)
tree3919e9bfeaa44781d5bd8885cad08f4a0b6df837
parent1513e79cc20ae10d581d5240d80c7774e78becb3 (diff)
downloadslackbuilds-24413e5cdcde81e9ad22d29d5bf2f273c076430f.tar.gz
slackbuilds-24413e5cdcde81e9ad22d29d5bf2f273c076430f.tar.xz
python/python3-traitlets: Removed (merged with python/traitlets).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--python/python3-traitlets/README12
-rw-r--r--python/python3-traitlets/python3-traitlets.SlackBuild86
-rw-r--r--python/python3-traitlets/python3-traitlets.info10
-rw-r--r--python/python3-traitlets/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/python/python3-traitlets/README b/python/python3-traitlets/README
deleted file mode 100644
index 67b73cc20d..0000000000
--- a/python/python3-traitlets/README
+++ /dev/null
@@ -1,12 +0,0 @@
-Traitlets is a pure Python library enabling:
-
-* the enforcement of strong typing for attributes of Python objects (typed
- attributes are called "traits")
-* notifications on changes of trait attributes
-* automatic validation and coercion of trait attributes when attempting a
- change
-
-Its implementation relies on the descriptor pattern.
-
-Traitlets powers the configuration system of IPython and Jupyter and the
-declarative API of IPython interactive widgets.
diff --git a/python/python3-traitlets/python3-traitlets.SlackBuild b/python/python3-traitlets/python3-traitlets.SlackBuild
deleted file mode 100644
index 7359b803a3..0000000000
--- a/python/python3-traitlets/python3-traitlets.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-traitlets
-
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=traitlets
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-4.3.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-traitlets/python3-traitlets.info b/python/python3-traitlets/python3-traitlets.info
deleted file mode 100644
index cc74ece3cd..0000000000
--- a/python/python3-traitlets/python3-traitlets.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-traitlets"
-VERSION="4.3.2"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/ipython/traitlets/archive/4.3.2/traitlets-4.3.2.tar.gz"
-MD5SUM="0b5b7986aef676d12f31a16cbbe3ed92"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3-six"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-traitlets/slack-desc b/python/python3-traitlets/slack-desc
deleted file mode 100644
index 059e225b04..0000000000
--- a/python/python3-traitlets/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-traitlets: python3-traitlets (lightweight Traits-like module)
-python3-traitlets:
-python3-traitlets: Traitlets is a pure Python library enabling:
-python3-traitlets: * the enforcement of strong typing for attributes of Python objects
-python3-traitlets: * notifications on changes of trait attributes
-python3-traitlets: * automatic validation and coercion of trait attributes when
-python3-traitlets: attempting a change
-python3-traitlets:
-python3-traitlets:
-python3-traitlets:
-python3-traitlets: