summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2019-06-07 05:00:30 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-09 05:33:15 +0700
commitc47e657e37562f1d3498340ce071afe9a0dbf281 (patch)
treeb1648422ef78bedcf228f8556be4369b94e24fb6
parent4d5a94a119cb3b95132dbb5bd47e8abf69e21e11 (diff)
downloadslackbuilds-c47e657e37562f1d3498340ce071afe9a0dbf281.tar.gz
slackbuilds-c47e657e37562f1d3498340ce071afe9a0dbf281.tar.xz
python/python3-Pygments: Removed (merged with python/Pygments).
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--python/python3-Pygments/README11
-rw-r--r--python/python3-Pygments/python3-Pygments.SlackBuild81
-rw-r--r--python/python3-Pygments/python3-Pygments.info10
-rw-r--r--python/python3-Pygments/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/python/python3-Pygments/README b/python/python3-Pygments/README
deleted file mode 100644
index 975ce911d5..0000000000
--- a/python/python3-Pygments/README
+++ /dev/null
@@ -1,11 +0,0 @@
-Pygments is a generic syntax highlighter for general use in all kinds of
-software such as forum systems, wikis or other applications that need to
-prettify source code.
-
-Highlights are:
- * A wide range of common languages and markup formats is supported.
- * Special attention is paid to details, increasing quality by a fair amount.
- * Support for new languages and formats are added easily.
- * A number of output formats, presently HTML, LaTeX, RTF, SVG and ANSI
- sequences.
- * It is usable as a command-line tool and as a library.
diff --git a/python/python3-Pygments/python3-Pygments.SlackBuild b/python/python3-Pygments/python3-Pygments.SlackBuild
deleted file mode 100644
index dab946f6bd..0000000000
--- a/python/python3-Pygments/python3-Pygments.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python3-Pygments
-
-# Copyright 2009 Grissiom <chaos.proton@gmail.com>
-# Copyright 2009-2015 LukenShiro, Italy
-# Copyright 2017-2019 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-SRCNAM=Pygments
-PRGNAM=python3-$SRCNAM
-VERSION=${VERSION:-2.4.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --prefix=/usr --root=$PKG
-
-mkdir -p $PKG/usr/man/man1
-cp -a doc/pygmentize.1 $PKG/usr/man/man1
-# Adapting to Slackware's directory layout
-sed -i "s|share/doc/python-pygments|doc/${PRGNAM}-${VERSION}|" \
- $PKG/usr/man/man1/pygmentize.1
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE TODO AUTHORS CHANGES README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python3-Pygments/python3-Pygments.info b/python/python3-Pygments/python3-Pygments.info
deleted file mode 100644
index 755293bf3b..0000000000
--- a/python/python3-Pygments/python3-Pygments.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-Pygments"
-VERSION="2.4.2"
-HOMEPAGE="http://pygments.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/P/Pygments/Pygments-2.4.2.tar.gz"
-MD5SUM="5ecc3fbb2a783e917b369271fc0e6cd1"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python3"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/python/python3-Pygments/slack-desc b/python/python3-Pygments/slack-desc
deleted file mode 100644
index 16d5ab9f7f..0000000000
--- a/python/python3-Pygments/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-Pygments: python3-Pygments (syntax highlighting package for Python 3)
-python3-Pygments:
-python3-Pygments: It is a generic syntax highlighter for general use in all kinds of
-python3-Pygments: software such as forum systems, wikis or other applications that need
-python3-Pygments: to prettify source code. A wide range of common languages and markup
-python3-Pygments: formats is supported.
-python3-Pygments:
-python3-Pygments:
-python3-Pygments:
-python3-Pygments:
-python3-Pygments: