summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Marcus Moeller <mmoeller@faircomputer.ch>2019-06-28 21:39:30 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2019-06-29 08:17:51 +0700
commit2a012d246e54d6a2f3b93c0ff66043b07b361334 (patch)
tree9d1f008e7d827a46597dc83e21b22fe1c4d60f84
parent8cfa72c3ed5b3b9e21b425c5dfe69a6c134bac8d (diff)
downloadslackbuilds-2a012d246e54d6a2f3b93c0ff66043b07b361334.tar.gz
slackbuilds-2a012d246e54d6a2f3b93c0ff66043b07b361334.tar.xz
network/x2goserver: Updated for version 20190625_b3ec119.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--network/x2goserver/README16
-rw-r--r--network/x2goserver/x2goserver.SlackBuild33
-rw-r--r--network/x2goserver/x2goserver.info12
3 files changed, 27 insertions, 34 deletions
diff --git a/network/x2goserver/README b/network/x2goserver/README
index 42c6e03044..36b61c6c01 100644
--- a/network/x2goserver/README
+++ b/network/x2goserver/README
@@ -3,15 +3,12 @@ x2goserver (X2Go Remote Desktop solution)
X2Go enables you to access a graphical desktop of a computer over
a low bandwidth (or high bandwidth) connection.
-X2Go is a Remote Desktop solution, which is not to be confused
-with Microsoft Remote Desktop Connection.
-
You can connect from a computer running Linux, Windows or MacOS X.
Multiple users/clients can access a single X2Go Server at the same time,
with each user/client having an individual Desktop session by default;
however, desktop sharing is possible.
-This is the server.
+This is the server component.
This script requires a 'x2gouser' user/group to exist before running.
You can create these using:
@@ -20,11 +17,14 @@ You can create these using:
useradd -u 290 -g 290 -c "X2Go Remote Desktop" -M -d /var/lib/x2go -s /bin/false x2gouser
groupadd -g 291 x2goprint
useradd -u 291 -g 291 -c "X2Go Remote Desktop" -m -d /var/spool/x2goprint -s /bin/false x2goprint
- chown x2goprint:x2goprint x2goprint
- chmod 0770 x2goprint
+ chown x2goprint:x2goprint /var/spool/x2goprint
+ chmod 0770 /var/spool/x2goprint
Before running the server, you have to initialize the internal database:
x2godbadmin --createdb
-If you want to run the server at boot, just run:
- chmod +x /etc/rc.d/rc.x2goserver
+If you want to run the server at boot include it in your /etc/rc.d/rc.local:
+
+if [ -x /etc/rc.d/rc.x2goserver ]; then
+ /etc/rc.d/rc.x2goserver start
+fi
diff --git a/network/x2goserver/x2goserver.SlackBuild b/network/x2goserver/x2goserver.SlackBuild
index 2c68747476..ba82397547 100644
--- a/network/x2goserver/x2goserver.SlackBuild
+++ b/network/x2goserver/x2goserver.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for x2goserver
-# Copyright 2014 Elvio "HelLViS69" Basello <hellvis69@gmail.com>
+# Copyright 2015-2018 Elvio "HelLViS69" Basello <hellvis69@gmail.com>
+# Copyright 2019 Marcus Moeller <mmoeller@faircomputer.ch>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +24,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=x2goserver
-VERSION=${VERSION:-4.0.1.19}
+VERSION=${VERSION:-20190625_b3ec119}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -60,7 +61,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -69,27 +70,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-make
-make install DESTDIR=$PKG
+# man2html hangs on some occasions and, BTW, html docs are not even installed
+sed -i "s|^MAN2HTML_BIN.*|MAN2HTML_BIN = |" */Makefile
-# There is no configure, so we have to move stuff out of /usr/local
-mv $PKG/usr/local/* $PKG/usr/
-rmdir $PKG/usr/local
-
-# Fix lib dir
-mkdir -p $PKG/usr/share/perl5/vendor_perl
-cp $PKG/usr/lib/x2go/*.pm $PKG/usr/share/perl5/vendor_perl
-if [ ! -z "$LIBDIRSUFFIX" ]; then
- mv $PKG/usr/lib $PKG/usr/lib${LIBDIRSUFFIX}
-fi
+make PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX}/x2go SHAREDIR=/usr/share/x2go
+make install PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX}/x2go SHAREDIR=/usr/share/x2go DESTDIR=$PKG
+# Move man pages in the proper place and compress them
mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
# Install init script
-mkdir $PKG/etc/rc.d
-cat $CWD/rc.x2goserver > $PKG/etc/rc.d/rc.x2goserver
+install -D -m 0755 $CWD/rc.x2goserver $PKG/etc/rc.d/rc.x2goserver
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/network/x2goserver/x2goserver.info b/network/x2goserver/x2goserver.info
index af9544eb2b..9e20cd4df2 100644
--- a/network/x2goserver/x2goserver.info
+++ b/network/x2goserver/x2goserver.info
@@ -1,10 +1,10 @@
PRGNAM="x2goserver"
-VERSION="4.0.1.19"
+VERSION="20190625_b3ec119"
HOMEPAGE="http://www.x2go.org"
-DOWNLOAD="http://code.x2go.org/releases/source/x2goserver/x2goserver-4.0.1.19.tar.gz"
-MD5SUM="7f1093c4dbc0a273bcc73a2e4b2c8b69"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/x2goserver-20190625_b3ec119.tar.xz"
+MD5SUM="031e3d92dfd06f22de3052360c524367"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="perl-Config-Simple perl-File-ReadBackwards perl-DBD-SQLite perl-Capture-Tiny perl-Unix-Syslog"
-MAINTAINER="Elvio Basello (HelLViS69)"
-EMAIL="hellvis69@gmail.com"
+REQUIRES="nx-libs perl-Config-Simple perl-File-ReadBackwards perl-DBD-SQLite perl-Capture-Tiny perl-Try-Tiny perl-Unix-Syslog perl-file-basedir perl-Switch"
+MAINTAINER="Marcus Moeller"
+EMAIL="mmoeller@faircomputer.ch"