summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Vincent Batts <vbatts@hashbangbash.com>2020-02-03 15:20:59 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-02-08 15:03:31 +0700
commit418f529ea95a638b7199ff933b982e249c0dbf47 (patch)
tree24ccc64581c434cf06d30e50047404d285af54a9
parent7d523f911d16b76e8251b6ea15cf85634dbc9e67 (diff)
downloadslackbuilds-418f529ea95a638b7199ff933b982e249c0dbf47.tar.gz
slackbuilds-418f529ea95a638b7199ff933b982e249c0dbf47.tar.xz
desktop/flatpak: fix build
Signed-off-by: Vincent Batts <vbatts@hashbangbash.com>
-rw-r--r--desktop/flatpak/3405.patch32
-rw-r--r--desktop/flatpak/flatpak.SlackBuild4
2 files changed, 35 insertions, 1 deletions
diff --git a/desktop/flatpak/3405.patch b/desktop/flatpak/3405.patch
new file mode 100644
index 0000000000..c7d1fb4eeb
--- /dev/null
+++ b/desktop/flatpak/3405.patch
@@ -0,0 +1,32 @@
+From e3232bb3d0649f3fdce01091e1948fb8e906f9eb Mon Sep 17 00:00:00 2001
+From: Matthew Leeds <matthew.leeds@endlessm.com>
+Date: Mon, 3 Feb 2020 11:24:41 -0800
+Subject: [PATCH] portal: Add g_autoptr() defines for old GLib versions
+
+We don't need to check for GLib 2.44 (the first release with g_autoptr()
+support) since Flatpak requires that version in configure.ac.
+
+Fixes https://github.com/flatpak/flatpak/issues/3403
+---
+ portal/flatpak-portal.c | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/portal/flatpak-portal.c b/portal/flatpak-portal.c
+index aa0d2d399..060987b7f 100644
+--- a/portal/flatpak-portal.c
++++ b/portal/flatpak-portal.c
+@@ -50,6 +50,14 @@
+ #include "portal-impl.h"
+ #include "flatpak-permission-dbus.h"
+
++/* GLib 2.47.92 was the first release to define these in gdbus-codegen */
++#if !GLIB_CHECK_VERSION (2, 47, 92)
++G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakProxy, g_object_unref)
++G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakSkeleton, g_object_unref)
++G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakUpdateMonitorProxy, g_object_unref)
++G_DEFINE_AUTOPTR_CLEANUP_FUNC (PortalFlatpakUpdateMonitorSkeleton, g_object_unref)
++#endif
++
+ #define IDLE_TIMEOUT_SECS 10 * 60
+
+ static GHashTable *client_pid_data_hash = NULL;
diff --git a/desktop/flatpak/flatpak.SlackBuild b/desktop/flatpak/flatpak.SlackBuild
index 486a3af5c9..d649b33f22 100644
--- a/desktop/flatpak/flatpak.SlackBuild
+++ b/desktop/flatpak/flatpak.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=flatpak
VERSION=${VERSION:-1.6.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,6 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/3405.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \