summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dominik Drobek <dominik.drobek (at) o2.pl>2020-02-08 08:52:45 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-02-08 13:39:33 +0700
commitddb7e59b58e8fc49a9423e29da581b1dc029a3e8 (patch)
treedbff799364e00e5611473330e20c30d3005e93b5
parent1edad651ef7e16d321519c920c071e0898a4458b (diff)
downloadslackbuilds-ddb7e59b58e8fc49a9423e29da581b1dc029a3e8.tar.gz
slackbuilds-ddb7e59b58e8fc49a9423e29da581b1dc029a3e8.tar.xz
python/werkzeug: Updated for version 0.16.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/werkzeug/README10
-rw-r--r--python/werkzeug/slack-desc2
-rw-r--r--python/werkzeug/werkzeug.SlackBuild8
-rw-r--r--python/werkzeug/werkzeug.info6
4 files changed, 13 insertions, 13 deletions
diff --git a/python/werkzeug/README b/python/werkzeug/README
index 6600183012..d72df6e82e 100644
--- a/python/werkzeug/README
+++ b/python/werkzeug/README
@@ -4,12 +4,12 @@ Werkzeug started as simple collection of various utilities for WSGI
applications and has become one of the most advanced WSGI utility modules.
It includes a powerful debugger, full featured request and response objects,
HTTP utilities to handle entity tags, cache control headers, HTTP dates,
-cookie handling, file uploads, a powerful URL routing system and a bunch
-of community contributed addon modules.
+cookie handling, file uploads, a powerful URL routing system and a bunch of
+community contributed addon modules.
-Werkzeug is unicode aware and doesn't enforce a specific template engine,
+Werkzeug is Unicode aware and doesn't enforce a specific template engine,
database adapter or anything else. It doesn't even enforce a specific way
of handling requests and leaves all that up to the developer.
-It's most useful for end user applications which should work on as many
-server environments as possible (such as blogs, wikis, bulletin boards, etc)
+It's most useful for end user applications which should work on as many server
+environments as possible (such as blogs, wikis, bulletin boards, etc).
diff --git a/python/werkzeug/slack-desc b/python/werkzeug/slack-desc
index 214a0b456e..b8cfcd3aed 100644
--- a/python/werkzeug/slack-desc
+++ b/python/werkzeug/slack-desc
@@ -11,7 +11,7 @@ werkzeug:
werkzeug: Werkzeug started as simple collection of various utilities for WSGI
werkzeug: and has become one of the most advanced WSGI utility modules.
werkzeug: It includes a powerful debugger, fully featured request and response
-werkzeug: objects, HTTP utilities to handle entity tags, cache control headers
+werkzeug: objects, HTTP utilities to handle entity tags, cache control headers,
werkzeug: HTTP dates, cookie handling, file uploads, a powerful URL routing
werkzeug: system and a bunch of community contributed addon modules.
werkzeug:
diff --git a/python/werkzeug/werkzeug.SlackBuild b/python/werkzeug/werkzeug.SlackBuild
index f8b754a065..26eb146bae 100644
--- a/python/werkzeug/werkzeug.SlackBuild
+++ b/python/werkzeug/werkzeug.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for werkzeug
# Copyright 2013 Mohamed LYAHYAOUI <mlyahyaoui@gmail.com>
-# Copyright 2018, 2019 Dominik Drobek <dominik.drobek (at) o2.pl>
+# Copyright 2018-2020 Dominik Drobek <dominik.drobek (at) o2.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
PRGNAM=werkzeug
SRCNAM=Werkzeug
-VERSION=${VERSION:-0.15.6}
+VERSION=${VERSION:-0.16.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,10 +71,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root $PKG
+python setup.py install --root=$PKG
if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
+ python3 setup.py install --root=$PKG
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/werkzeug/werkzeug.info b/python/werkzeug/werkzeug.info
index 5ca0a49072..adddd26e08 100644
--- a/python/werkzeug/werkzeug.info
+++ b/python/werkzeug/werkzeug.info
@@ -1,8 +1,8 @@
PRGNAM="werkzeug"
-VERSION="0.15.6"
+VERSION="0.16.1"
HOMEPAGE="https://palletsprojects.com/p/werkzeug/"
-DOWNLOAD="https://files.pythonhosted.org/packages/a3/32/2c91f662d66d4ae8993987b56cd1706a9a526f3ac310dd7fca47d7851533/Werkzeug-0.15.6.tar.gz"
-MD5SUM="99f94e0271b8a60462dd1e0ad5ec65ba"
+DOWNLOAD="https://files.pythonhosted.org/packages/c3/1d/1c0761d9365d166dc9d882a48c437111d22b0df564d6d5768045d9a51fd0/Werkzeug-0.16.1.tar.gz"
+MD5SUM="bfa03955bdc885e8612493b5d2122e15"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""