summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2020-01-27 13:18:45 +0000
committer Dave Woodfall <dave@slackbuilds.org>2020-04-05 16:23:13 +0100
commite62bd66ce73e15a9f7526e2f417727e517b5f0a0 (patch)
treeb1f717668e9e234970a76f1a4b1a8878943c63bf
parent1eb5faf1f910d167631069859450856ecd86decb (diff)
downloadslackbuilds-e62bd66ce73e15a9f7526e2f417727e517b5f0a0.tar.gz
slackbuilds-e62bd66ce73e15a9f7526e2f417727e517b5f0a0.tar.xz
libraries/PyQt5: Updated for version 5.13.2.
-rw-r--r--libraries/PyQt5/PyQt5.SlackBuild24
-rw-r--r--libraries/PyQt5/PyQt5.info8
-rw-r--r--libraries/PyQt5/patches/pyqt5-python2-crash.patch13
3 files changed, 34 insertions, 11 deletions
diff --git a/libraries/PyQt5/PyQt5.SlackBuild b/libraries/PyQt5/PyQt5.SlackBuild
index 5ff9ef1202..712a5aceda 100644
--- a/libraries/PyQt5/PyQt5.SlackBuild
+++ b/libraries/PyQt5/PyQt5.SlackBuild
@@ -35,7 +35,7 @@
# Updated for Qt5-5.9.6 by David Woodfall <dave@slackbuilds.org>
PRGNAM=PyQt5
-VERSION=${VERSION:-5.9.2}
+VERSION=${VERSION:-5.13.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf ${PRGNAM}_gpl-$VERSION
-tar xvf $CWD/${PRGNAM}_gpl-$VERSION.tar.gz
-cd ${PRGNAM}_gpl-$VERSION
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -81,8 +81,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# This is needed or an include from dbus is missed (tnx, Archlinux)
-sed -i '/target_config.dbus_inc_dirs = \[\]/d' configure.py
+# From alienBOB's SlackBuild
+# Remove code that is unneeded if Qt is not bundled and crashes on python2
+# https://www.riverbankcomputing.com/pipermail/pyqt/2019-July/041896.html
+cat $CWD/patches/pyqt5-python2-crash.patch | patch -p1 --verbose
export QTDIR=/usr/lib${LIBDIRSUFFIX}/qt5
export QT5DIR=/usr/lib${LIBDIRSUFFIX}/qt5
@@ -93,17 +95,25 @@ export CXXFLAGS="$SLKCFLAGS"
python configure.py \
--confirm-license \
+ --qsci-api \
--verbose \
--sip=/usr/bin/python2-sip \
--sip-incdir="/usr/include/python$PYTHONVER/python2-sip" \
-q /usr/bin/qmake-qt5
make
-make install DESTDIR=$PKG INSTALL_ROOT=$PKG
+make -j1 install DESTDIR=$PKG INSTALL_ROOT=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Remove rpaths (from alienBOB's SlackBuild):
+for file in $(find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : 2> /dev/null); do
+ if [ ! "$(patchelf --print-rpath $file 2> /dev/null)" = "" ]; then
+ patchelf --remove-rpath $file
+ fi
+done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ChangeLog LICENSE NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/PyQt5/PyQt5.info b/libraries/PyQt5/PyQt5.info
index f0991810c9..c7a1de0d86 100644
--- a/libraries/PyQt5/PyQt5.info
+++ b/libraries/PyQt5/PyQt5.info
@@ -1,10 +1,10 @@
PRGNAM="PyQt5"
-VERSION="5.9.2"
+VERSION="5.13.2"
HOMEPAGE="https://riverbankcomputing.com/software/pyqt/intro/"
-DOWNLOAD="https://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-5.9.2/PyQt5_gpl-5.9.2.tar.gz"
-MD5SUM="33d6d2ab8183da17ac18b8132a4b278e"
+DOWNLOAD="https://www.riverbankcomputing.com/static/Downloads/PyQt5/5.13.2/PyQt5-5.13.2.tar.gz"
+MD5SUM="c1023cb9c3d29a89fc109b163a0175c0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="qt5-webkit python2-sip enum34"
-MAINTAINER="David Woodfall"
+MAINTAINER="Dave Woodfall"
EMAIL="dave@slackbuilds.org"
diff --git a/libraries/PyQt5/patches/pyqt5-python2-crash.patch b/libraries/PyQt5/patches/pyqt5-python2-crash.patch
new file mode 100644
index 0000000000..14462f7563
--- /dev/null
+++ b/libraries/PyQt5/patches/pyqt5-python2-crash.patch
@@ -0,0 +1,13 @@
+diff -ur PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in
+--- PyQt5_gpl-5.12.3/qpy/QtCore/qpycore_post_init.cpp.in 2019-06-25 14:41:02.000000000 +0200
++++ PyQt5_gpl-5.12.3b/qpy/QtCore/qpycore_post_init.cpp.in 2019-07-01 17:06:34.882644535 +0200
+@@ -151,8 +151,4 @@
+ // initialised first (at least for Windows) and this is the only way to
+ // guarantee things are done in the right order.
+ PyQtSlotProxy::mutex = new QMutex(QMutex::Recursive);
+-
+- // Load the embedded qt.conf file if there is a bundled copy of Qt.
+- if (!qpycore_qt_conf())
+- Py_FatalError("PyQt5.QtCore: Unable to embed qt.conf");
+ }
+