summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Alan Aversa <alan_avNOersa@lSPAMavabit.com>2020-05-15 23:59:20 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-15 23:59:20 +0700
commit9dcf2f8935292072bd2c67283d58ac7aafc50e1b (patch)
tree37a36336d671ffedd8bf2797619c2149fd42fcbe
parent8cf98da01d210e5ad84b137f1cbfc5de025f4d78 (diff)
downloadslackbuilds-9dcf2f8935292072bd2c67283d58ac7aafc50e1b.tar.gz
slackbuilds-9dcf2f8935292072bd2c67283d58ac7aafc50e1b.tar.xz
python/schema: Added (Python data structures validation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/schema/README8
-rw-r--r--python/schema/schema.SlackBuild88
-rw-r--r--python/schema/schema.info10
-rw-r--r--python/schema/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/python/schema/README b/python/schema/README
new file mode 100644
index 0000000000..fdf11b8492
--- /dev/null
+++ b/python/schema/README
@@ -0,0 +1,8 @@
+Schema validation just got Pythonic
+
+schema is a library for validating Python data structures, such as those
+obtained from config-files, forms, external services or command-line
+parsing, converted from JSON/YAML (or something else) to Python
+data-types.
+
+python3 is an optional dependency.
diff --git a/python/schema/schema.SlackBuild b/python/schema/schema.SlackBuild
new file mode 100644
index 0000000000..57f4025a45
--- /dev/null
+++ b/python/schema/schema.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for schema
+
+# Copyright 2020 Alan Aversa
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=schema
+VERSION=${VERSION:-0.7.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+else
+ python setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/schema/schema.info b/python/schema/schema.info
new file mode 100644
index 0000000000..b3f07deb1c
--- /dev/null
+++ b/python/schema/schema.info
@@ -0,0 +1,10 @@
+PRGNAM="schema"
+VERSION="0.7.2"
+HOMEPAGE="https://pypi.org/project/schema/"
+DOWNLOAD="https://files.pythonhosted.org/packages/0d/de/84afc54d41aea9787c6d8814391a2d296a8240eef5b59d11704a82d82064/schema-0.7.2.tar.gz"
+MD5SUM="e9b98f979dbda29c3f7bc63e09b20878"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="contextlib2"
+MAINTAINER="Alan Aversa"
+EMAIL="alan_avNOersa@lSPAMavabit.com"
diff --git a/python/schema/slack-desc b/python/schema/slack-desc
new file mode 100644
index 0000000000..437674e2c2
--- /dev/null
+++ b/python/schema/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+schema: schema (Python data structures validation)
+schema:
+schema: schema is a library for validating Python data structures, such as
+schema: those obtained from config-files, forms, external services or
+schema: command-line parsing, converted from JSON/YAML (or something else) to
+schema: Python data-types.
+schema:
+schema: https://pypi.org/project/schema/
+schema:
+schema:
+schema: