summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Lenard Spencer <lenardrspencer@gmail.com>2020-05-15 21:52:23 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2020-05-15 21:52:23 +0700
commitf62ed0a22ce337e6887e3cbbd5a5c75749241b93 (patch)
treee6f5cd4b40fa1de7e81fd8a1728d08a6f313f29b
parent2e20cf24e18b9b02a8a6d53500815c076d53c51c (diff)
downloadslackbuilds-f62ed0a22ce337e6887e3cbbd5a5c75749241b93.tar.gz
slackbuilds-f62ed0a22ce337e6887e3cbbd5a5c75749241b93.tar.xz
games/FlightGear: Updated for version 2020.1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/FlightGear/FlightGear-version.patch22
-rw-r--r--games/FlightGear/FlightGear.SlackBuild15
-rw-r--r--games/FlightGear/FlightGear.info6
-rw-r--r--games/FlightGear/README7
4 files changed, 41 insertions, 9 deletions
diff --git a/games/FlightGear/FlightGear-version.patch b/games/FlightGear/FlightGear-version.patch
new file mode 100644
index 0000000000..c7eaa1bda9
--- /dev/null
+++ b/games/FlightGear/FlightGear-version.patch
@@ -0,0 +1,22 @@
+diff -Naur flightgear-2020.1.1/CMakeLists.txt flightgear-2020.1.1.new/CMakeLists.txt
+--- flightgear-2020.1.1/CMakeLists.txt 2020-05-14 14:13:11.836478728 -0400
++++ flightgear-2020.1.1.new/CMakeLists.txt 2020-05-14 14:29:27.692261758 -0400
+@@ -83,7 +83,7 @@
+ set(CMAKE_MINSIZEREL_POSTFIX "" CACHE STRING "add a postfix, usually empty on windows")
+
+ # read 'version' file into a variable (stripping any newlines or spaces)
+-file(READ version versionFile)
++file(READ flightgear-version versionFile)
+ if (NOT versionFile)
+ message(FATAL_ERROR "Unable to determine FlightGear version. Version file is missing.")
+ endif()
+diff -Naur flightgear-2020.1.1/flightgear-version flightgear-2020.1.1.new/flightgear-version
+--- flightgear-2020.1.1/flightgear-version 1969-12-31 19:00:00.000000000 -0500
++++ flightgear-2020.1.1.new/flightgear-version 2020-05-10 16:32:27.000000000 -0400
+@@ -0,0 +1 @@
++2020.1.1
+diff -Naur flightgear-2020.1.1/version flightgear-2020.1.1.new/version
+--- flightgear-2020.1.1/version 2020-05-10 16:32:27.000000000 -0400
++++ flightgear-2020.1.1.new/version 1969-12-31 19:00:00.000000000 -0500
+@@ -1 +0,0 @@
+-2020.1.1
diff --git a/games/FlightGear/FlightGear.SlackBuild b/games/FlightGear/FlightGear.SlackBuild
index 52b041b65d..a0cc30ea4d 100644
--- a/games/FlightGear/FlightGear.SlackBuild
+++ b/games/FlightGear/FlightGear.SlackBuild
@@ -3,6 +3,8 @@
# Copyright before version 2016.3.1 by Diego Pantano <poplin.dp@gmail.com>
# Copyright 2016-2018 Panagiotis Nikolaou, Culver City, CA
+# Copyright 2019, 2020 Lenard Spencer, Orlando, Florida, USA
+
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +26,7 @@
PRGNAM=FlightGear
SRCNAM=flightgear
-VERSION=${VERSION:-2018.3.5}
+VERSION=${VERSION:-2020.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -77,13 +79,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# patch for the new boost (Thanks Gentoo)
+if [ "${CURRENT:-no}" = "yes" ]; then
+ patch -p1 < $CWD/FlightGear-version.patch
+fi
+
mkdir -p build
cd build
cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_C_FLAGS="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DEVENT_INPUT:STRING="ON" \
+ -DEVENT_INPUT="ON" \
-DFG_DATA_DIR=/usr/share/${PRGNAM} \
$OPT \
-DCMAKE_BUILD_TYPE=Release ..
diff --git a/games/FlightGear/FlightGear.info b/games/FlightGear/FlightGear.info
index 115f6dd2e5..c2b89336ab 100644
--- a/games/FlightGear/FlightGear.info
+++ b/games/FlightGear/FlightGear.info
@@ -1,8 +1,8 @@
PRGNAM="FlightGear"
-VERSION="2018.3.5"
+VERSION="2020.1.1"
HOMEPAGE="http://www.flightgear.org/"
-DOWNLOAD="https://downloads.sourceforge.net/flightgear/flightgear-2018.3.5.tar.bz2"
-MD5SUM="8ac70abc515db67d25f676d73a87d758"
+DOWNLOAD="https://downloads.sourceforge.net/flightgear/flightgear-2020.1.1.tar.bz2"
+MD5SUM="67feb4c089222afb97bae06bebb6b091"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="FlightGear-data SimGear"
diff --git a/games/FlightGear/README b/games/FlightGear/README
index 4a5ce89cf0..3b576ddb62 100644
--- a/games/FlightGear/README
+++ b/games/FlightGear/README
@@ -2,8 +2,11 @@ FlightGear is a flight-simulator created by an international group of
volunteers, and released as free, open-source GPL software.
It has been used for academic research, education, and for fun.
-To build the internal Qt launcher, you will require QT5 and libxkbcommon
-and then pass QT5=yes to the script
+To build the internal Qt launcher, you will require QT5 and then pass
+QT5=yes to the script. Otherwise, you can install either fgo or ffgo
+as a more basic launcher.
+
+To build on current (15.0 EXPERIMENTAL), pass CURRENT=yes to the script.
speex and flite are optional dependencies for voice communication
(autodetected at build time).