summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2021-01-22 20:53:27 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-01-23 18:18:51 +0700
commitd183a7b3f6237264941fe34594208ccfd3d4b2bf (patch)
tree7e01185720b0f02a5354531eaf9724ceafd858ef
parentd81cdb9449b024bb4bcc206820cdf655cedd174a (diff)
downloadslackbuilds-d183a7b3f6237264941fe34594208ccfd3d4b2bf.tar.gz
slackbuilds-d183a7b3f6237264941fe34594208ccfd3d4b2bf.tar.xz
system/kitty: Added (fast, featureful, GPU-based terminal emulator)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/kitty/README14
-rw-r--r--system/kitty/doinst.sh9
-rw-r--r--system/kitty/kitty.SlackBuild99
-rw-r--r--system/kitty/kitty.info10
-rw-r--r--system/kitty/slack-desc19
5 files changed, 151 insertions, 0 deletions
diff --git a/system/kitty/README b/system/kitty/README
new file mode 100644
index 0000000000..a4cb22c88e
--- /dev/null
+++ b/system/kitty/README
@@ -0,0 +1,14 @@
+kitty (fast, featureful, GPU-based terminal emulator)
+
+kitty is a terminal emulator for X11 and Wayland[1], which offloads
+the rendering to the GPU[2] and supports modern terminal features. It
+also supports tiling multiple terminal windows without using an extra
+program like screen or tmux.
+
+[1] For Wayland support, install wayland-protocols before building
+ kitty. It will be auto-detected. It may be necessary to add the
+ following line to ~/.config/kitty/kitty.conf:
+
+ linux_display_server wayland
+
+[2] Requires hardware-accelerated OpenGL support.
diff --git a/system/kitty/doinst.sh b/system/kitty/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/system/kitty/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/system/kitty/kitty.SlackBuild b/system/kitty/kitty.SlackBuild
new file mode 100644
index 0000000000..7a6708062d
--- /dev/null
+++ b/system/kitty/kitty.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/sh
+
+# Slackware build script for kitty
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=kitty
+VERSION=${VERSION:-0.19.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# The Makefile ain't a real Makefile, everything's done in setup.py. Which
+# has issues:
+# - upstream claims harfbuzz >= 1.5 is required, but 14.2's 1.2 seems to work
+# just fine.
+# - CFLAGS not supported, -O3 hardcoded. The OVERRIDE stuff works, but the
+# hardcoded -O3 comes *after* them on the gcc command line. Grr.
+# - -Werror is used when compiling launcher.c, no way to disable. This assumes
+# upstream is perfect at writing code that compiles without warnings on every
+# version of gcc we might ever happen to use, and I don't believe it.
+# So, sed surgery.
+
+sed -i \
+ -e "/at_least_version('harfbuzz/s,5,2," \
+ -e 's,-O3,-O2,g' \
+ -e 's,-Werror , ,g' \
+ setup.py
+
+# The -Wl,-s makes the linker strip the binaries.
+OVERRIDE_CPPFLAGS="$SLKCFLAGS -Wl,-s" \
+OVERRIDE_CFLAGS="$SLKCFLAGS -Wl,-s" \
+ python3 setup.py --libdir-name lib$LIBDIRSUFFIX --verbose linux-package
+
+mkdir -p $PKG/usr/bin $PKG/usr/share $PKG/usr/lib$LIBDIRSUFFIX
+cp -a linux-package/bin/* $PKG/usr/bin
+cp -a linux-package/share/* $PKG/usr/share
+cp -a linux-package/lib*/* $PKG/usr/lib$LIBDIRSUFFIX
+
+mv $PKG/usr/share/man $PKG/usr/man
+gzip $PKG/usr/man/man?/*.?
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/html $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc/
+cp -a CHANGELOG* CONTRIBUTING* README* LICENSE* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+# make slack-desc reflect the display types the package is built for
+L=$PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM/$PRGNAM
+[ -e $L/glfw-x11.so ] && DISPLAYS+=" X11"
+[ -e $L/glfw-wayland.so ] && DISPLAYS+=" Wayland"
+
+mkdir -p $PKG/install
+sed "s,@DISPLAYS@,$DISPLAYS," $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/kitty/kitty.info b/system/kitty/kitty.info
new file mode 100644
index 0000000000..2047627277
--- /dev/null
+++ b/system/kitty/kitty.info
@@ -0,0 +1,10 @@
+PRGNAM="kitty"
+VERSION="0.19.3"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+DOWNLOAD="https://github.com/kovidgoyal/kitty/releases/download/v0.19.3/kitty-0.19.3.tar.xz"
+MD5SUM="262b677889d9b979b9ce609ec7b75186"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 libxkbcommon"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/system/kitty/slack-desc b/system/kitty/slack-desc
new file mode 100644
index 0000000000..c48660175a
--- /dev/null
+++ b/system/kitty/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kitty: kitty (fast, featureful, GPU-based terminal emulator)
+kitty:
+kitty: kitty is a terminal emulator for X11 and Wayland, which offloads the
+kitty: rendering to the GPU and supports modern terminal features. It also
+kitty: supports tiling multiple terminal windows without using an extra
+kitty: program like screen or tmux.
+kitty:
+kitty: This package supports:@DISPLAYS@
+kitty:
+kitty:
+kitty: