summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2022-12-08 23:48:04 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-10 07:43:12 +0700
commitc19800d2ae76a402375fbec2889a167c7f4f894f (patch)
tree1ddfc8f3fb48bdb0449b961cd0d46e5384eb662c
parent4e895261acad56cfe5eb0f3bb7286850465a31ee (diff)
downloadslackbuilds-c19800d2ae76a402375fbec2889a167c7f4f894f.tar.gz
slackbuilds-c19800d2ae76a402375fbec2889a167c7f4f894f.tar.xz
academic/python3-ase: Added (Atomic Simulation Environment (ASE))
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--academic/python3-ase/README7
-rw-r--r--academic/python3-ase/python3-ase.SlackBuild111
-rw-r--r--academic/python3-ase/python3-ase.info10
-rw-r--r--academic/python3-ase/slack-desc19
4 files changed, 147 insertions, 0 deletions
diff --git a/academic/python3-ase/README b/academic/python3-ase/README
new file mode 100644
index 0000000000..b37a13ecf8
--- /dev/null
+++ b/academic/python3-ase/README
@@ -0,0 +1,7 @@
+ The Atomic Simulation Environment (ASE) is a set of tools and Python
+modules for setting up, manipulating, running, visualizing and
+analyzing atomistic simulations. The code is freely available under
+the GNU LGPL license.
+
+
+ Optional dependence autodetected, matplotlib
diff --git a/academic/python3-ase/python3-ase.SlackBuild b/academic/python3-ase/python3-ase.SlackBuild
new file mode 100644
index 0000000000..d8f092e024
--- /dev/null
+++ b/academic/python3-ase/python3-ase.SlackBuild
@@ -0,0 +1,111 @@
+#!/bin/bash
+
+# Slackware build script for ASE (Atomic Simulation Environment)
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-ase
+VERSION=${VERSION:-3.22.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM="ase"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+python3 setup.py build
+[ "${TEST:-no}" == "yes" ] && PYTHONPATH=$PYTHONPATH:. ./bin/ase test
+PYTHONPATH=$PYTHONPATH:. ./bin/ase info; sleep 2
+python3 setup.py install --root=$PKG
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ {CHANGELOG,CONTRIBUTING,README}.rst \
+ COPYING COPYING.LESSER LICENSE PKG-INFO doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/python3-ase/python3-ase.info b/academic/python3-ase/python3-ase.info
new file mode 100644
index 0000000000..8620ee8b70
--- /dev/null
+++ b/academic/python3-ase/python3-ase.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-ase"
+VERSION="3.22.1"
+HOMEPAGE="https://wiki.fysik.dtu.dk/ase"
+DOWNLOAD="https://pypi.org/packages/source/a/ase/ase-3.22.1.tar.gz"
+MD5SUM="8173c8b598faf995ff11cbceafacedc1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-numpy python3-scipy"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/python3-ase/slack-desc b/academic/python3-ase/slack-desc
new file mode 100644
index 0000000000..59d1cf5415
--- /dev/null
+++ b/academic/python3-ase/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-ase: python3-ase (Atomic Simulation Environment (ASE))
+python3-ase:
+python3-ase:
+python3-ase:
+python3-ase: The Atomic Simulation Environment (ASE) is a set of tools and
+python3-ase: Python modules for setting up, manipulating, running, visualizing
+python3-ase: and analyzing atomistic simulations. The code is freely available
+python3-ase: under the GNU LGPL license.
+python3-ase:
+python3-ase:
+python3-ase: