summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2022-03-31 22:30:47 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-02 18:19:19 +0700
commitb5bb2cb8cc9347e3b752be60e268241d645dc6a4 (patch)
tree9814e146a72dc967bf35562825d23da170710540
parent27e81f96ead3543555beac62e677540d0672ca0d (diff)
downloadslackbuilds-b5bb2cb8cc9347e3b752be60e268241d645dc6a4.tar.gz
slackbuilds-b5bb2cb8cc9347e3b752be60e268241d645dc6a4.tar.xz
ham/tucnak: Added (Ham Radio - VHF/HF contest logbook)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--ham/tucnak/README3
-rw-r--r--ham/tucnak/doinst.sh10
-rw-r--r--ham/tucnak/slack-desc19
-rw-r--r--ham/tucnak/tucnak.SlackBuild120
-rw-r--r--ham/tucnak/tucnak.info10
5 files changed, 162 insertions, 0 deletions
diff --git a/ham/tucnak/README b/ham/tucnak/README
new file mode 100644
index 0000000000..3a29e671c3
--- /dev/null
+++ b/ham/tucnak/README
@@ -0,0 +1,3 @@
+tucnak is an amateur radio VHF/HF contest logbook.
+
+optional dependencies: hamlib, portaudio, rtl-sdr
diff --git a/ham/tucnak/doinst.sh b/ham/tucnak/doinst.sh
new file mode 100644
index 0000000000..a25271d80c
--- /dev/null
+++ b/ham/tucnak/doinst.sh
@@ -0,0 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications
+fi
+
+# If other icon themes are installed, then add to/modify this as needed
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/ham/tucnak/slack-desc b/ham/tucnak/slack-desc
new file mode 100644
index 0000000000..294827ad06
--- /dev/null
+++ b/ham/tucnak/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+tucnak: tucnak (Ham Radio - VHF/HF contest logbook)
+tucnak:
+tucnak: Amateur Radio VHF/HF Contest Logbook
+tucnak:
+tucnak:
+tucnak:
+tucnak:
+tucnak:
+tucnak:
+tucnak:
+tucnak:
diff --git a/ham/tucnak/tucnak.SlackBuild b/ham/tucnak/tucnak.SlackBuild
new file mode 100644
index 0000000000..f464a8ff40
--- /dev/null
+++ b/ham/tucnak/tucnak.SlackBuild
@@ -0,0 +1,120 @@
+#!/bin/bash
+
+# Slackware build script for tucnak
+
+# Copyright 2022 Matt Dinslage <daedra1980@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=tucnak
+VERSION=${VERSION:-4.34}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# fix libdir issue
+if [ "$ARCH" = "x86_64" ]; then
+ sed -i 's,/usr/lib/tucnak,/usr/lib64/tucnak,g' configure
+ sed -i 's,/lib/,/lib64/,g' src/Makefile.am
+fi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+autoreconf -v -f
+./configure \
+ --disable-static\
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-gpm \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/ham/tucnak/tucnak.info b/ham/tucnak/tucnak.info
new file mode 100644
index 0000000000..f43fcb7021
--- /dev/null
+++ b/ham/tucnak/tucnak.info
@@ -0,0 +1,10 @@
+PRGNAM="tucnak"
+VERSION="4.34"
+HOMEPAGE="http://tucnak.nagano.cz/wiki/Main_Page"
+DOWNLOAD="http://tucnak.nagano.cz/tucnak-4.34.tar.gz"
+MD5SUM="885b5061239f5339be63bf184d94f2bb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libzia"
+MAINTAINER="M.Dinslage"
+EMAIL="daedra1980@gmail.com"