summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2022-05-14 03:09:32 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-14 19:28:03 +0700
commitadb8188ca44cfbf5bd663e8e90cb441d1706fc97 (patch)
treed7d936acd0caea6657369807b735eed202b8464f
parent07da2c0413bfd8ce78f78a594d45426826ac7440 (diff)
downloadslackbuilds-adb8188ca44cfbf5bd663e8e90cb441d1706fc97.tar.gz
slackbuilds-adb8188ca44cfbf5bd663e8e90cb441d1706fc97.tar.xz
python/email-validator: Added (Validate Email Addresses)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/email-validator/README8
-rw-r--r--python/email-validator/email-validator.SlackBuild96
-rw-r--r--python/email-validator/email-validator.info10
-rw-r--r--python/email-validator/slack-desc19
4 files changed, 133 insertions, 0 deletions
diff --git a/python/email-validator/README b/python/email-validator/README
new file mode 100644
index 0000000000..be3b85f789
--- /dev/null
+++ b/python/email-validator/README
@@ -0,0 +1,8 @@
+email-validator: Validate Email Addresses
+
+A robust email address syntax and deliverability validation library
+for Python by Joshua Tauberer.
+
+This library validates that a string is of the form name@example.com.
+This is the sort of validation you would want for an email-based
+login form on a website.
diff --git a/python/email-validator/email-validator.SlackBuild b/python/email-validator/email-validator.SlackBuild
new file mode 100644
index 0000000000..e10f116364
--- /dev/null
+++ b/python/email-validator/email-validator.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for email-validator
+
+# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=email-validator
+SRCNAM=$(echo $PRGNAM | sed 's/\-/_/')
+VERSION=${VERSION:-1.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/email-validator/email-validator.info b/python/email-validator/email-validator.info
new file mode 100644
index 0000000000..ea13b4280a
--- /dev/null
+++ b/python/email-validator/email-validator.info
@@ -0,0 +1,10 @@
+PRGNAM="email-validator"
+VERSION="1.2.1"
+HOMEPAGE="https://github.com/JoshData/python-email-validator"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/e/email-validator/email_validator-1.2.1.tar.gz"
+MD5SUM="b357c78f8f3f3b7cabd061ab2127a6cb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/email-validator/slack-desc b/python/email-validator/slack-desc
new file mode 100644
index 0000000000..8d25de6305
--- /dev/null
+++ b/python/email-validator/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+email-validator: email-validator (Validate Email Addresses)
+email-validator:
+email-validator: A robust email address syntax and deliverability validation library
+email-validator: for Python by Joshua Tauberer.
+email-validator:
+email-validator: This library validates that a string is of the form name@example.com.
+email-validator: This is the sort of validation you would want for an email-based login
+email-validator: form on a website.
+email-validator:
+email-validator: Homepage: https://github.com/JoshData/python-email-validator
+email-validator: