summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundyat>2022-05-20 04:19:09 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:19 +0700
commita391ba7a7654cfe1e9485c2f033c43ffec1ac31e (patch)
treecf6c97c347e14e57a1a47f0a5741a1d2d5418936
parent47e863b059a7231b5d7d85dae727eb01badca942 (diff)
downloadslackbuilds-a391ba7a7654cfe1e9485c2f033c43ffec1ac31e.tar.gz
slackbuilds-a391ba7a7654cfe1e9485c2f033c43ffec1ac31e.tar.xz
python/artifacts: Updated for version 20220429.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/artifacts/artifacts.SlackBuild10
-rw-r--r--python/artifacts/artifacts.info8
2 files changed, 9 insertions, 9 deletions
diff --git a/python/artifacts/artifacts.SlackBuild b/python/artifacts/artifacts.SlackBuild
index 6a68184aff..3ee8d9286e 100644
--- a/python/artifacts/artifacts.SlackBuild
+++ b/python/artifacts/artifacts.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for artifacts
-# Copyright 2016-2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2016-2022 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,7 +21,7 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated to version 20190113, March 2019
+# Updated to version 20220429, May 2022
# 20220408 bkw: Modified by SlackBuilds.org, BUILD=2:
# - get rid of /usr/share/doc.
@@ -29,8 +29,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=artifacts
-VERSION=${VERSION:-20190113}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-20220429}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/artifacts/artifacts.info b/python/artifacts/artifacts.info
index 7ddab4edde..b42c5dc67e 100644
--- a/python/artifacts/artifacts.info
+++ b/python/artifacts/artifacts.info
@@ -1,10 +1,10 @@
PRGNAM="artifacts"
-VERSION="20190113"
+VERSION="20220429"
HOMEPAGE="https://github.com/ForensicArtifacts/artifacts"
-DOWNLOAD="https://slackware.uk/sbosrcarch/by-md5/e/a/eaad01405b7f4272adda2ea6ea9a0d04/artifacts-20190113.tar.gz"
-MD5SUM="eaad01405b7f4272adda2ea6ea9a0d04"
+DOWNLOAD="https://github.com/ForensicArtifacts/artifacts/archive/refs/tags/20220429/artifacts-20220429.tar.gz"
+MD5SUM="507e21f30eeacf8b469a841f6ed83a80"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-PyYAML"
+REQUIRES=""
MAINTAINER="Barry J. Grundy"
EMAIL="bgrundy<at>linuxleo.com"