summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2022-05-20 21:15:41 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:29 +0700
commitbf52d3df9ad268c217616612a041d9615909255d (patch)
treeead6ab04fef44aa83ee27f733272faa45ae42c92
parent6a04939bfa288b37d2038b8841d0f9871eca8040 (diff)
downloadslackbuilds-bf52d3df9ad268c217616612a041d9615909255d.tar.gz
slackbuilds-bf52d3df9ad268c217616612a041d9615909255d.tar.xz
python/Flask-Dance: Removed. Python3 script added.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/Flask-Dance/Flask-Dance.SlackBuild98
-rw-r--r--python/Flask-Dance/Flask-Dance.info10
-rw-r--r--python/Flask-Dance/README4
-rw-r--r--python/Flask-Dance/slack-desc19
4 files changed, 0 insertions, 131 deletions
diff --git a/python/Flask-Dance/Flask-Dance.SlackBuild b/python/Flask-Dance/Flask-Dance.SlackBuild
deleted file mode 100644
index 990ad5ae4a..0000000000
--- a/python/Flask-Dance/Flask-Dance.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Flask-Dance
-
-# Copyright 2019 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Flask-Dance
-VERSION=${VERSION:-3.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# fix path for requirements.txt file
-sed -i "s/tests\///" setup.py
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE CHANGELOG.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/Flask-Dance/Flask-Dance.info b/python/Flask-Dance/Flask-Dance.info
deleted file mode 100644
index 3906d29e3b..0000000000
--- a/python/Flask-Dance/Flask-Dance.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Flask-Dance"
-VERSION="3.0.0"
-HOMEPAGE="https://github.com/singingwolfboy/flask-dance"
-DOWNLOAD="https://files.pythonhosted.org/packages/e4/1b/14e319de35a7680db7ae189d883d4c11448807ae0f246f2b9d808d6b101e/Flask-Dance-3.0.0.tar.gz"
-MD5SUM="794db1b65dbb5221644a6ff5c201548d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Flask requests-oauthlib python3-urlobject"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Flask-Dance/README b/python/Flask-Dance/README
deleted file mode 100644
index b339d9bce7..0000000000
--- a/python/Flask-Dance/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Doing the OAuth dance with style using Flask, requests,
-and oauthlib. Currently, only OAuth consumers are supported,
-but this project could easily support OAuth providers
-in the future, as well.
diff --git a/python/Flask-Dance/slack-desc b/python/Flask-Dance/slack-desc
deleted file mode 100644
index a68e6f3e90..0000000000
--- a/python/Flask-Dance/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Flask-Dance: Flask-Dance (Doing the OAuth using Flask)
-Flask-Dance:
-Flask-Dance: Doing the OAuth dance with style using Flask, requests,
-Flask-Dance: and oauthlib. Currently, only OAuth consumers are supported,
-Flask-Dance: but this project could easily support OAuth providers
-Flask-Dance: in the future, as well.
-Flask-Dance:
-Flask-Dance: Homepage: https://github.com/singingwolfboy/flask-dance
-Flask-Dance:
-Flask-Dance:
-Flask-Dance: