summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dave Woodfall <dave@slackbuilds.org>2022-05-20 21:16:23 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:30 +0700
commitdefc9a245c0283c52bc8d717bea9ded62306174f (patch)
tree1c9f76658b114f55a8927f01247e04986d93b6d6
parentbf52d3df9ad268c217616612a041d9615909255d (diff)
downloadslackbuilds-defc9a245c0283c52bc8d717bea9ded62306174f.tar.gz
slackbuilds-defc9a245c0283c52bc8d717bea9ded62306174f.tar.xz
python/Flask-Login: Removed. Python3 script added.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/Flask-Login/Flask-Login.SlackBuild95
-rw-r--r--python/Flask-Login/Flask-Login.info10
-rw-r--r--python/Flask-Login/README4
-rw-r--r--python/Flask-Login/slack-desc19
4 files changed, 0 insertions, 128 deletions
diff --git a/python/Flask-Login/Flask-Login.SlackBuild b/python/Flask-Login/Flask-Login.SlackBuild
deleted file mode 100644
index 534a3c9929..0000000000
--- a/python/Flask-Login/Flask-Login.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for Flask-Login
-
-# Copyright 2016-2017 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Flask-Login
-VERSION=${VERSION:-0.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/Flask-Login/Flask-Login.info b/python/Flask-Login/Flask-Login.info
deleted file mode 100644
index 8de173db95..0000000000
--- a/python/Flask-Login/Flask-Login.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Flask-Login"
-VERSION="0.4.1"
-HOMEPAGE="https://github.com/maxcountryman/flask-login"
-DOWNLOAD="https://pypi.python.org/packages/c1/ff/bd9a4d2d81bf0c07d9e53e8cd3d675c56553719bbefd372df69bf1b3c1e4/Flask-Login-0.4.1.tar.gz"
-MD5SUM="25b34c74bd509792f291c16e184225df"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Flask"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/Flask-Login/README b/python/Flask-Login/README
deleted file mode 100644
index 472b705652..0000000000
--- a/python/Flask-Login/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Flask-Login provides user session management for Flask.
-It handles the common tasks of logging in, logging out,
-and remembering your users' sessions over extended periods
-of time.
diff --git a/python/Flask-Login/slack-desc b/python/Flask-Login/slack-desc
deleted file mode 100644
index 6f1a543189..0000000000
--- a/python/Flask-Login/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Flask-Login: Flask-Login (User session management for Flask)
-Flask-Login:
-Flask-Login: Flask-Login provides user session management for Flask. It handles
-Flask-Login: the common tasks of logging in, logging out, and remembering your
-Flask-Login: users' sessions over extended periods of time.
-Flask-Login:
-Flask-Login: Homepage: https://github.com/maxcountryman/flask-login
-Flask-Login:
-Flask-Login:
-Flask-Login:
-Flask-Login: