summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2024-05-13 05:21:55 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-05-18 06:55:49 +0700
commit7cc1a6f08bff1d6e593f4c6f891d1aaea334510f (patch)
tree04fac9a51527cba319865b2968abb16819da98ec
parentae41c34953e19ebdf49a5cc14d56850c81410439 (diff)
downloadslackbuilds-7cc1a6f08bff1d6e593f4c6f891d1aaea334510f.tar.gz
slackbuilds-7cc1a6f08bff1d6e593f4c6f891d1aaea334510f.tar.xz
python/python3-babelfish: Updated for version 0.6.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-babelfish/python3-babelfish.SlackBuild31
-rw-r--r--python/python3-babelfish/python3-babelfish.info8
2 files changed, 13 insertions, 26 deletions
diff --git a/python/python3-babelfish/python3-babelfish.SlackBuild b/python/python3-babelfish/python3-babelfish.SlackBuild
index 3725d12903..efabb1706d 100644
--- a/python/python3-babelfish/python3-babelfish.SlackBuild
+++ b/python/python3-babelfish/python3-babelfish.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-babelfish
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-babelfish
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-0.6.0}
+VERSION=${VERSION:-0.6.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -76,11 +59,15 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# to get rid of version warning
+sed -i '/^importlib-metadata/ s/4.6/7.1.0/' pyproject.toml
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-babelfish/python3-babelfish.info b/python/python3-babelfish/python3-babelfish.info
index d3ab04789f..fd24d42956 100644
--- a/python/python3-babelfish/python3-babelfish.info
+++ b/python/python3-babelfish/python3-babelfish.info
@@ -1,10 +1,10 @@
PRGNAM="python3-babelfish"
-VERSION="0.6.0"
+VERSION="0.6.1"
HOMEPAGE="https://github.com/Diaoul/babelfish"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/b/babelfish/babelfish-0.6.0.tar.gz"
-MD5SUM="985464e05a7fd275d650347af8aa2439"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/b/babelfish/babelfish-0.6.1.tar.gz"
+MD5SUM="a3ef27e5b12c795d48aa6fa4005d2826"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-poetry-core python-importlib_metadata"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"