summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author M.Dinslage <daedra1980@gmail.com>2015-01-05 09:46:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-05 09:46:12 +0700
commit2365b5c760076fcb2a1242d371c9051e8fb952a1 (patch)
tree710a40fad480f0d32247a254f50610aa346768bc
parent2da27ea436500ac65c89e318012a5ce76167da27 (diff)
downloadslackbuilds-2365b5c760076fcb2a1242d371c9051e8fb952a1.tar.gz
slackbuilds-2365b5c760076fcb2a1242d371c9051e8fb952a1.tar.xz
python/python-gflags: Added (Python argument parsing library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python-gflags/README8
-rw-r--r--python/python-gflags/python-gflags.SlackBuild71
-rw-r--r--python/python-gflags/python-gflags.info10
-rw-r--r--python/python-gflags/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/python/python-gflags/README b/python/python-gflags/README
new file mode 100644
index 0000000000..e9576697d2
--- /dev/null
+++ b/python/python-gflags/README
@@ -0,0 +1,8 @@
+python-gflags (Google's Python argument parsing library)
+
+This project is the python equivalent of gflags, a commandline
+flag implementation for C++ originally written by Google. It is
+intended to be used in situations where a project wants to mimic the
+command-line flag handling of a C++ app that uses gflags, or for a
+Python app that, via swig or some other means, is linked with a C++
+app that uses gflags.
diff --git a/python/python-gflags/python-gflags.SlackBuild b/python/python-gflags/python-gflags.SlackBuild
new file mode 100644
index 0000000000..620efe6a11
--- /dev/null
+++ b/python/python-gflags/python-gflags.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Slackware build script for python-gflags
+
+# Copyright 2014 Matt Dinslage <daedra1980[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-gflags
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a NEWS PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-gflags/python-gflags.info b/python/python-gflags/python-gflags.info
new file mode 100644
index 0000000000..1f7ba7d24c
--- /dev/null
+++ b/python/python-gflags/python-gflags.info
@@ -0,0 +1,10 @@
+PRGNAM="python-gflags"
+VERSION="2.0"
+HOMEPAGE="https://code.google.com/p/python-gflags/"
+DOWNLOAD="https://python-gflags.googlecode.com/files/python-gflags-2.0.tar.gz"
+MD5SUM="c3ab70218dbf945cc32c0cd64c51d162"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="M.Dinslage"
+EMAIL="daedra1980@gmail.com"
diff --git a/python/python-gflags/slack-desc b/python/python-gflags/slack-desc
new file mode 100644
index 0000000000..6432e61536
--- /dev/null
+++ b/python/python-gflags/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-gflags: python-gflags (Google's Python argument parsing library)
+python-gflags:
+python-gflags: This project is the python equivalent of gflags, a commandline
+python-gflags: flag implementation for C++ originally written by Google. It is
+python-gflags: intended to be used in situations where a project wants to mimic the
+python-gflags: command-line flag handling of a C++ app that uses gflags, or for a
+python-gflags: Python app that, via swig or some other means, is linked with a C++
+python-gflags: app that uses gflags.
+python-gflags:
+python-gflags:
+python-gflags: